Subject: [Netmod-ver-dt] YANG packages draft

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Wed, 22 Jan 2020 16:30:49 +0000

FYI, I've updated the YANG packages draft with the updated YANG model structure that we discussed previously and were using, and changed the way that the model is described (i.e. reference the common structure of the grouping).

I've made one further change which is to root the package list under a "packages" top level container rather than augmenting YANG library as was done previously.  I think that this probably makes YANG library more user friendly (so that clients querying YANG library don't suddenly get all the packages information that mostly they should not need - given the desire for packages information to be available offline).  I think that this probably also helps with YANG packages, since clients won't need to necessarily get the duplicate module list information in YANG library, and it also allows the package information to be included (e.g. in an instance-data document) without the YANG library information.

I've pushed the updates to my github rgwilton/YANG-Packages-Draft repository (so that you can easily see the history of what has changed), and also to the yang-ver-dt repository, which I propose that we use for this document going forward.

I've also been resolving/closing some of the open issues at github rgwilton/YANG-Packages-Draft repository.  For the ones that I think that we need to still keep open, I will copy them to the yang-ver-dt repository, so that everything is in one place, and anyone can easily update.

The examples in this draft still need to be updated, which would be nice to do before an adoption call, but is not critical.

Any comments, concerns, etc, please let me know, or raise them in tomorrow's meeting.

Thanks,
Rob

Subject: [Netmod-ver-dt] [rgwilton/YANG-Packages-Draft] a2d94d: Update draft with recent changes to packages YANG ...
From: Robert Wilton <[email-masked]>
To: "[email-masked]" <[email-masked]>
Date: Wed, 22 Jan 2020 16:11:55 +0000

  Branch: refs/heads/master
  Home:   https://github.com/rgwilton/YANG-Packages-Draft
  Commit: a2d94dfbe416fe77f41d12dbdb321f602c95149d
      https://github.com/rgwilton/YANG-Packages-Draft/commit/a2d94dfbe416fe77f41d12dbdb321f602c95149d
  Author: rwilton <[email-masked]>
  Date:   2020-01-22 (Wed, 22 Jan 2020)

  Changed paths:
    M draft-rwilton-netmod-yang-packages.txt
    M draft-rwilton-netmod-yang-packages.xml
    M ietf-yang-inst-data-pkg.yang
    A ietf-yang-package-instance.yang
    M ietf-yang-package-types.yang
    R ietf-yang-package.yang
    A ietf-yang-packages.yang
    R ietf-yl-packages.yang
    R tmp/ietf-yang-library-packages.yang
    M tmp/ietf-yang-revisions.yang

  Log Message:
  -----------
  Update draft with recent changes to packages YANG model

_______________________________________________
Netmod-ver-dt mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod-ver-dt

Subject: [Netmod-ver-dt] [netmod-wg/yang-ver-dt] 03d258: Add YANG packages draft to ver-dt-repo
From: Robert Wilton <[email-masked]>
To: "[email-masked]" <[email-masked]>
Date: Wed, 22 Jan 2020 16:15:34 +0000

  Branch: refs/heads/develop
  Home:   https://github.com/netmod-wg/yang-ver-dt
  Commit: 03d258d63982945375e22853be09d4c598ffe067
      https://github.com/netmod-wg/yang-ver-dt/commit/03d258d63982945375e22853be09d4c598ffe067
  Author: rwilton <[email-masked]>
  Date:   2020-01-22 (Wed, 22 Jan 2020)

  Changed paths:
    A yang-pkgs/draft-rwilton-netmod-yang-packages.txt
    A yang-pkgs/draft-rwilton-netmod-yang-packages.xml
    A yang-pkgs/example-3-pkg.json
    A yang-pkgs/example-ietf-network-device-pkg-folded.json
    A yang-pkgs/example-ietf-network-device-pkg.json
    A yang-pkgs/example-ietf-routing-pkg-folded.json
    A yang-pkgs/example-ietf-routing-pkg.json
    A yang-pkgs/example-import-1-pkg.json
    A yang-pkgs/example-import-2-pkg.json
    A yang-pkgs/full-example-ietf-network-device-pkg.json
    A yang-pkgs/ietf-yang-inst-data-pkg.yang
    A yang-pkgs/ietf-yang-package-instance.yang
    A yang-pkgs/ietf-yang-package-types.yang
    A yang-pkgs/ietf-yang-packages.yang
    A yang-pkgs/[email-masked]
    A yang-pkgs/simple-example-ietf-network-device-pkg.json
    A yang-pkgs/tmp/ietf-datastores.yang
    A yang-pkgs/tmp/[email-masked]
    A yang-pkgs/tmp/ietf-origin.yang
    A yang-pkgs/tmp/[email-masked]
    A yang-pkgs/tmp/ietf-yang-library.yang
    A yang-pkgs/tmp/ietf-yang-revisions.yang
    A yang-pkgs/tmp/[email-masked]
    A yang-pkgs/tools/example-ietf-network-device-pkg-folded.json
    A yang-pkgs/tools/example-ietf-network-device-pkg.json
    A yang-pkgs/tools/example-ietf-routing-pkg.json
    A yang-pkgs/tools/fold-artwork.sh

  Log Message:
  -----------
  Add YANG packages draft to ver-dt-repo

_______________________________________________
Netmod-ver-dt mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod-ver-dt

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Thu, 23 Jan 2020 10:27:00 +0000

One further thought on the updates that I made to the packages draft:

Currently the "packages" top-level container and the YANG library augmentation are in the same YANG module (and hence they have a dependency on the RFC 8525 version of YANG library).  I wonder whether it would be better to split these into two separate modules, i.e. allowing the packages solution to coexist with the older version of YANG library RFC 7995)?

Any thoughts on this?

Thanks,
Rob

From: Netmod-ver-dt <[email-masked]> On Behalf Of Rob Wilton (rwilton)
Sent: 22 January 2020 16:31
To: [email-masked]
Subject: [Netmod-ver-dt] YANG packages draft

Thanks,
Rob

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Thu, 23 Jan 2020 14:42:15 +0000

The split at the top level sounds like a good idea.

Let's put them in separate YANG modules.

From: Netmod-ver-dt <[email-masked]> On Behalf Of Rob Wilton (rwilton)
Sent: Thursday, January 23, 2020 5:27 AM
To: Rob Wilton (rwilton) <[email-masked]>; [email-masked]
Subject: Re: [Netmod-ver-dt] YANG packages draft

Any thoughts on this?

Thanks,
Rob

From: Netmod-ver-dt <[email-masked]<mailto:[email-masked]>> On Behalf Of Rob Wilton (rwilton)
Sent: 22 January 2020 16:31
To: [email-masked]<mailto:[email-masked]>
Subject: [Netmod-ver-dt] YANG packages draft

Thanks,
Rob

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Mon, 27 Jan 2020 10:06:29 +0000

I've updated and pushed the latest version of the YANG packages draft with this change made to it.

Thanks,
Rob

From: Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]>
Sent: 23 January 2020 14:42
To: Rob Wilton (rwilton) <[email-masked]>; [email-masked]
Subject: RE: YANG packages draft

From: Netmod-ver-dt <[email-masked]<mailto:[email-masked]>> On Behalf Of Rob Wilton (rwilton)
Sent: Thursday, January 23, 2020 5:27 AM
To: Rob Wilton (rwilton) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Netmod-ver-dt] YANG packages draft

Any thoughts on this?

Thanks,
Rob

Thanks,
Rob

Subject: [Netmod-ver-dt] [netmod-wg/yang-ver-dt] 9084bd: Split server side YANG package structure and YANG ...
From: Robert Wilton <[email-masked]>
To: "[email-masked]" <[email-masked]>
Date: Mon, 27 Jan 2020 10:03:47 +0000

  Branch: refs/heads/develop
  Home:   https://github.com/netmod-wg/yang-ver-dt
  Commit: 9084bd9be2d004f667fa6cd2296ce9cd3098e2c0
      https://github.com/netmod-wg/yang-ver-dt/commit/9084bd9be2d004f667fa6cd2296ce9cd3098e2c0
  Author: rwilton <[email-masked]>
  Date:   2020-01-27 (Mon, 27 Jan 2020)

  Changed paths:
    M yang-pkgs/draft-rwilton-netmod-yang-packages.txt
    M yang-pkgs/draft-rwilton-netmod-yang-packages.xml
    M yang-pkgs/ietf-yang-packages.yang
    A yang-pkgs/ietf-yl-packages.yang

  Log Message:
  -----------
  Split server side YANG package structure and YANG library augmentations into separate YANG modules