Subject: Re: [Netmod-ver-dt] Getting versioning draft ready to publish for WG adoption call

From: "Wubo (lana)" <[email-masked]>
Date: Tue, 25 Feb 2020 09:25:35 +0000

Hi Rob,

Besides those, the following changes are suggested:
1. the consistent name is better to be used, can we all use schema selection?

1）  The name of section 7,8  use  “Version selection”

2）  The name of section 10  use  “Schema version selection”
3)     the module name is  “ietf-schema-selection”, but the description text call it "ietf-schema-version-selection"

Additionally, does the draft also address hot fix scenarios?

Thanks,
Bo
发件人: Netmod-ver-dt [mailto:[email-masked]] 代表 Rob Wilton (rwilton)
发送时间: 2020年2月25日 0:46
收件人: [email-masked]
主题: [Netmod-ver-dt] Getting versioning draft ready to publish for WG adoption call

Hi,

I would like to get an updated version of the schema selection draft posted by Friday if possible.

These are the areas that we should fix before we publish:
1)      Sec 5: Expand RESTCONF description (5.4.2).  E.g. define the path that is used.
2)      Sec 6: Fix description of RPC operation:
a.       Also resolve the definition of the RPC in the YANG module (as per Jason’s comments).  Perhaps remove the choice & translate leaf, and just have an optional replacement-config?
3)      Sec 10: Fixup text in front of YANG module (e.g. it still uses primary/secondary)
4)      Prune references
5)      Clean up example text.

Does anyone else have any other areas that they think we need to fix?  I’ve noticed a few other typos that could do with fixing, but will just update these.

Nice to have (which I propose deferring):
-          Perhaps define “Package schema” instead of redefining YANG schema for RFC 7950.
-          Also define “Partial datastore schema”

Thanks,
Rob

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 25 Feb 2020 11:52:03 +0000

Hi Bo,

Yes, good point.  I think that we should just use “schema selection”.

Considering hot fixes, I think that there might need to be explored further.

At the moment, I think that the solution would probably be:

  *   Assumes that the base software is defined using an existing package (could also be multiple packages)
  *   A new (referentially incomplete) package is defined containing the changes in the hot fix (may include updated module revisions, deviations, new modules)
  *   A new (probably local) package is defined to merge the base software and hotfix package together, and specify how conflicts are resolved.
  *   The module-sets would refer to the new local package.

We could potentially avoid the need to define the extra local package if we had slightly more complicated rules about how packages are combined within a schema-set when using semver: i.e. the package and module with the highest semver version is always chosen.  However, the client wouldn’t then obviously know that the base package had been deviated (which in the case of using a local package definition could have been indicated by the “nbc-changes” and “nbc-modified” flags).

Thanks,
Rob

From: Wubo (lana) <[email-masked]>
Sent: 25 February 2020 09:26
To: Rob Wilton (rwilton) <[email-masked]>; [email-masked]
Subject: Re: [Netmod-ver-dt] Getting versioning draft ready to publish for WG adoption call

Hi Rob,

  1.  The name of section 7,8  use  “Version selection”
  2.  The name of section 10  use  “Schema version selection”
3)     the module name is  “ietf-schema-selection”, but the description text call it "ietf-schema-version-selection"

Thanks,
Bo
发件人: Netmod-ver-dt [mailto:[email-masked]] 代表 Rob Wilton (rwilton)
发送时间: 2020年2月25日 0:46
收件人: [email-masked]<mailto:[email-masked]>
主题: [Netmod-ver-dt] Getting versioning draft ready to publish for WG adoption call

Hi,

  1.  Sec 5: Expand RESTCONF description (5.4.2).  E.g. define the path that is used.
  2.  Sec 6: Fix description of RPC operation:

     *   Also resolve the definition of the RPC in the YANG module (as per Jason’s comments).  Perhaps remove the choice & translate leaf, and just have an optional replacement-config?

  1.  Sec 10: Fixup text in front of YANG module (e.g. it still uses primary/secondary)
  2.  Prune references
  3.  Clean up example text.

  *   Perhaps define “Package schema” instead of redefining YANG schema for RFC 7950.
  *   Also define “Partial datastore schema”

Thanks,
Rob