Subject: [Netmod-ver-dt] new schema-set terminology and 5.2 text

From: "Wubo (lana)" <[email-masked]>
Date: Wed, 26 Feb 2020 07:07:01 +0000

Hi all,

The new text for schema-set and other comments are as follows:

schema set:
   schema set: The union of datastore schemas of the device, and every
   datastore schema is specified as a collection of compatible YANG
   packages. A schema set is the basic unit of schema selection.

Abstract:
This document defines a mechanism to allow clients, using NETCONF or
RESTCONF, to configure and choose YANG schema for interactions with a
server out of a set of available YANG schemas(->schema sets ) supported by a server.
This functionality can help servers support clients using older
revisions of YANG modules even if later revisions contain nonbackwards-compatible changes.
It can also be used to allow clients
to select between YANG schema(->schema set) defined by different organizations

5.2.  Schema-sets

   A schema-set defines a set of datastore schema(s) that could potentially
   be used for client schema selection.
   (The schema-sets supported by the server are available at '/ietf-
   schema-selection/schema-set'(->'/schema-set-selection/schema-set')
   in the operational state datastore.)
   (moved here from the last paragraph of this section)

Thanks,
Bo

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Wed, 26 Feb 2020 14:26:09 +0000

Hi Bo,

Please see [RW] inline ...

From: Netmod-ver-dt <[email-masked]> On Behalf Of Wubo (lana)
Sent: 26 February 2020 07:07
To: Rob Wilton (rwilton) <[email-masked]>; [email-masked]
Subject: [Netmod-ver-dt] new schema-set terminology and 5.2 text

Hi all,

schema set:

[RW]
Thanks, this is better that my first attempt, but suggest refining it slightly to:

   schema set: A named set of datastore schemas for supported datastores, where every
   datastore schema is specified as a union of compatible YANG
   packages.  A schema set is the basic unit of client schema selection.

Abstract:

[RW]
For the abstract, I think that introducing schema sets will probably end up being slightly confusing.  I propose simplifying the abstract slightly to:

      <t>
           This document defines a mechanism to allow clients, using NETCONF or RESTCONF, to configure
           and select YANG schema for interactions with a server.  This functionality can help servers
           support clients using older revisions of YANG modules even if later revisions contain
           non-backwards-compatible changes.  It can also be used to allow clients to select between
           YANG schema defined by different organizations.</t>
      <t>This draft provides a solution to YANG versioning requirements 3.1 and 3.2.</t>

5.2.  Schema-sets

[RW]
I've fixed the path, and moved the paragraph from the end up to the second paragraph.  Is that what you meant?

Thanks,
Rob

Thanks,
Bo

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Wed, 26 Feb 2020 22:26:46 +0000

Please see inline.
Jason

From: Netmod-ver-dt <[email-masked]> On Behalf Of Rob Wilton (rwilton)
Sent: Wednesday, February 26, 2020 9:26 AM
To: Wubo (lana) <[email-masked]>; [email-masked]
Subject: Re: [Netmod-ver-dt] new schema-set terminology and 5.2 text

Hi Bo,

From: Netmod-ver-dt <[email-masked]<mailto:[email-masked]>> On Behalf Of Wubo (lana)
Sent: 26 February 2020 07:07
To: Rob Wilton (rwilton) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: [Netmod-ver-dt] new schema-set terminology and 5.2 text

Hi all,

schema set:

[RW]

[>>JTS: ] Should we use "schema-set" (with the dash) in all cases in that definition?

Abstract:

[RW]
For the abstract, I think that introducing schema sets will probably end up being slightly confusing..  I propose simplifying the abstract slightly to:
[>>JTS: ] Agree - let's keep schema-set out of the abstract

      <t>

5.2.  Schema-sets

[RW]

Thanks,
Rob

Thanks,
Bo