Subject: [Netmod-ver-dt] Meeting minutes - 18th Feb

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 18 Feb 2020 17:49:41 +0000

In summary there was further discussion today on what external schema-sets actually represent, and in particular what does it mean if a schema-set is removed from the list of selectable schema.  Potentially we are coming to the consensus (at least for the WG adoption call) is that it SHOULD NOT (or perhaps MUST NOT) change the configuration of the system unless an alternative configuration is provided.

Next steps (before this Thursday):

  1.  Jason (and any others) to confirm "5.3.3.  The relationship between packages and datastores", then Rob will post datastore draft.
  2.  All to review schema selection draft by EOD Thursday to determine what are the changes required before we can publish
  3.  Split up the work to update the draft with an aim to post an updated version of the draft before next Friday, i.e. basically the end of this month.

Thanks,
Rob

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Tue, 18 Feb 2020 17:54:41 +0000

On Feb 18, 2020, at 12:49, Rob Wilton (rwilton) <[email-masked]<mailto:[email-masked]>> wrote:

Sorry I missed the call.  This week I’m at an offsite meeting.  A schema set could be removed when the device is upgraded, and in that case the configuration is typically migrated to a new default.  However, if the device stores representations of configurations made using different schema (I don’t think this is really tenable for all vendors), then I’m not sure what would happen to them.  I suppose they could still be retrievable and indicate the old schema.  But probably more realistic is that device has one configuration at boot time, and it will be reflected in the default schema or optionally any others it currently supports.

Not sure if I missed the point of this, though.

  1.  Jason (and any others) to confirm “5.3.3.  The relationship between packages and datastores”, then Rob will post datastore draft.
  2.  All to review schema selection draft by EOD Thursday to determine what are the changes required before we can publish
  3.  Split up the work to update the draft with an aim to post an updated version of the draft before next Friday, i.e. basically the end of this month.

I’ll try and review on my flight home tomorrow.

Joe

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Tue, 18 Feb 2020 19:05:56 +0000

Hi Joe - yes, that is more along the lines of what I'm thinking.

The box internally (and in persistent config) stores the actual config *somehow* and that is independent of what schema a particular NETCONF client is using to access the config (and independent of what is configured as the "default" schema).   Changing the "default" schema doesn't (necessarily) have any impact on what is written to the persistent startup storage.

Also - IMO when the default schema is changed, or if NETCONF client X selects a new/different schema, that should not affect what other clients see as the config if they have previously selected a particular schema.

*But* - if a client selects a new schema *and*  provides a "replacement-config", then all clients could possibly see a difference in their own view of things before and after.

Jason

From: Netmod-ver-dt <[email-masked]> On Behalf Of Joe Clarke (jclarke)
Sent: Tuesday, February 18, 2020 12:55 PM
To: Rob Wilton (rwilton) <[email-masked]>
Cc: [email-masked]
Subject: Re: [Netmod-ver-dt] Meeting minutes - 18th Feb

Joe