Subject: [Netmod-ver-dt] Schema-comparison

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Wed, 18 Mar 2020 20:12:27 +0000

Hi Rob, all,

I took a look at schema-comparison, it had been a while…. Regarding the issue<https://github.com/netmod-wg/yang-ver-dt/issues/25> we briefly discussed during the meeting:

  *   Ideally I believe any path should work with renamed-from (e.g. module to module). Helpful when comparing schemas. But TBH I don’t know how common this is. As for a solution, what comes to mind is we need an import statement for the “from-module” in the “to-module” and the identifier used in rename-from stmt would need to include prefix of “from-module”.
  *   The question about moving across module made me wonder whether a revision/version would be useful with the renamed-from extension.

Some comments/questions:

  1.  Actions aren’t mentioned in section 3, oversight?
  2.  Filtered YANG schema comparison. In theory, some filters could be applied even for module comparison. Maybe take the filters out of YANG schema comparison and have a separate section?
  3.  Section 3 mentions minor and editorial and refers to yang-packages. Should refer to semver instead?
  4.  Section 3.1, this is where we should add descriptions of the extensions?
  5.  Examples would really help
  6.  Would be good to get feedback from tooling folks. Martin didn’t give any. I think we should ask yanglint (Radek?).

Regards,
Reshad.

From: Netmod-ver-dt <[email-masked]> on behalf of "Rob Wilton (rwilton)" <rwilton=[email-masked]>
Date: Tuesday, March 17, 2020 at 12:49 PM
To: "[email-masked]" <[email-masked]>
Subject: Re: [Netmod-ver-dt] Possible choices for editors

Notes from today’s DT meeting.

Bo, Joe, Reshad, Rob attended

We plan on keeping the 107 meeting slides format to broadly be the same, but raising more issues.

+ Joe to publish the ietf- version of the drafts..

+ RobW to ask about what we should do with the Reqs draft.

  *   Take to WGLC?
  *   Publish as informational?

+ RobW to raise with NETMOD/NETCONF chairs on the best way forward for progressing these drafts.

See further notes inline below.

From: Netmod-ver-dt <[email-masked]> On Behalf Of Rob Wilton (rwilton)
Sent: 03 March 2020 15:10
To: [email-masked]
Subject: [Netmod-ver-dt] Possible choices for editors

Obviously conditional on input from WG chairs & adoption results.

From discussion today:

6) draft-verdt-netmod-yang-schema-comparison-00 - Reshad?
  - Schema comparison tooling, unchanged from the version presented at 106.
[RW]

  *   Keep this discussion fairly short.

5) draft-wilton-netmod-yang-ver-selection-02 - Joe/Jason?
  - Version selection, updated since 106, as per notes below
[RW]
Issues:

  *   Move to NETCONF WG?
  *   Does it need to be split due to updating both NETCONF and RESTCONF?

4) draft-rwilton-netmod-yang-packages-03 - Bo?
  - YANG packages draft, updated since 106
[RW]
Bo producing slides
Discussed proposed issues to raise from the github issues list.

2) draft-verdt-netmod-yang-module-versioning-01 - Balazs?
  - Base module versioning solution, unchanged from the version presented at 106.
[RW]

  *   Feedback from Martin.
  *   Reshad to produce slides for 107.

3) draft-verdt-netmod-yang-semver-01 - Joe/Jason?
  - YANG Semantic version numbers, unchanged from the version presented at 106.
[RW]

-          Do we mandate IETF drafts use YANG Semver?

-          Joe’s going to produce slides.

1) draft-verdt-netmod-yang-solutions-03 - Rob?
  - Solution overview, updated since 106 to cover updates to version selection and schema comparison drafts.
[RW]

  *   Not planning to say much on this at all, at this stage.

0) requirements draft - Joe
  - Already adopted.

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Thu, 19 Mar 2020 16:42:02 +0000

Hi Reshad,

Some comments inline …

From: Reshad Rahman (rrahman) <rrahman=[email-masked]>
Sent: 18 March 2020 20:12
To: Rob Wilton (rwilton) <[email-masked]>; [email-masked]
Subject: Schema-comparison

Hi Rob, all,

For me:

  *   Renaming a node within a module is easier and we should make sure that we have that one covered.
  *   If we want to allow renaming from other modules then I think that we want to avoid using an import statement because it will create unwanted dependencies, and perhaps instead rely on a schema node path that uses qualified module name, e.g. perhaps like RESTCONF paths, with the default being the current module.

  *   The question about moving across module made me wonder whether a revision/version would be useful with the renamed-from extension.
[RW]
Not sure.  I think that this probably needs more further thought/discussion.  It may be that it turns out not to be required.

Some comments/questions:

Yes, probably.

  1.  Filtered YANG schema comparison. In theory, some filters could be applied even for module comparison. Maybe take the filters out of YANG schema comparison and have a separate section?
[RW]
Yes, but I think that it might be more work than just pulling out the filtered section, since it also talks about constructing a full schema tree.

Perhaps:
Generic filtering should be a subsection of section 3 (or a new section 4).
The existing section 4 should also mention that the filtered comparison can be used.
The existing section 5.2 should be extended/renamed to indicate that it is comparing a full schema tree (or perhaps this is what we should be referring to a package schema).

  1.  Section 3 mentions minor and editorial and refers to yang-packages. Should refer to semver instead?
[RW]
Yes, good catch.

  1.  Section 3.1, this is where we should add descriptions of the extensions?
[RW]
Yes, as a starting point.

  1.  Examples would really help
[RW]
I agree.

  1.  Would be good to get feedback from tooling folks. Martin didn’t give any. I think we should ask yanglint (Radek?).
[RW]
Yes.  We could also take a look at what pyang does here.

Thanks,
Rob

Regards,
Reshad.

  *   Take to WGLC?

From discussion today:

  *   Move to NETCONF WG?

  *   Feedback from Martin.

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Fri, 20 Mar 2020 20:29:20 +0000

Hi Rob, all,

I’ve attached slides, it’s basically the slides Rob did for 106 (pruned a few) + small addition.

I’ve kept the 1st 3 points which were already part of next steps (slide 7), not sure if they should be rediscussed or not?

Inline.

From: "Rob Wilton (rwilton)" <rwilton=[email-masked]>
Date: Thursday, March 19, 2020 at 12:42 PM
To: "Reshad Rahman (rrahman)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: Schema-comparison

Hi Reshad,

Some comments inline …

Hi Rob, all,

 <RR> Ack.

  *   The question about moving across module made me wonder whether a revision/version would be useful with the renamed-from extension.
[RW]
Not sure.  I think that this probably needs more further thought/discussion.  It may be that it turns out not to be required.
<RR> Missed the fact that this was already in the issue and presented at last IETF.

Regards,
Reshad.

Some comments/questions:

Perhaps:

Thanks,
Rob

Regards,
Reshad.

  *   Take to WGLC?

From discussion today:

  *   Move to NETCONF WG?

  *   Feedback from Martin.

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Fri, 20 Mar 2020 20:44:27 +0000

You may want to do a search and replace for “stuf” to “stuff” before you have to use the rev-ext:nbc tag :-).

Does it make sense to take a stance on points 1 and 2 here?  I think it makes sense to define the extensions in yang-versioning.

With respect to rev-ext:nbc, I think this is useful when the tooling would otherwise not be able to determine an nbc change (like in description).  So I think we could say nbc and renamed-from are the useful extensions.  I also don’t think it would be bad to allow a namespace in the value of renamed-from in case a vendor wanted to move something to a different module.

Joe

On Mar 20, 2020, at 16:29, Reshad Rahman (rrahman) <rrahman=[email-masked]<mailto:rrahman=[email-masked]>> wrote:

Hi Rob, all,

Inline.

From: "Rob Wilton (rwilton)" <rwilton=[email-masked]<mailto:rwilton=[email-masked]>>
Date: Thursday, March 19, 2020 at 12:42 PM
To: "Reshad Rahman (rrahman)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: Schema-comparison

Hi Reshad,

Some comments inline …

From: Reshad Rahman (rrahman) <rrahman=[email-masked]<mailto:rrahman=[email-masked]>>
Sent: 18 March 2020 20:12
To: Rob Wilton (rwilton) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Schema-comparison

Hi Rob, all,

[RW]
For me:

 <RR> Ack.

[RW]

Regards,
Reshad.

Some comments/questions:

[RW]
Yes, probably.

[RW]

Perhaps:

[RW]
Yes, good catch.

[RW]

[RW]
I agree.

[RW]

Thanks,
Rob

Regards,
Reshad.

From: Netmod-ver-dt <[email-masked]<mailto:[email-masked]>> on behalf of "Rob Wilton (rwilton)" <rwilton=[email-masked]<mailto:rwilton=[email-masked]>>
Date: Tuesday, March 17, 2020 at 12:49 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Netmod-ver-dt] Possible choices for editors

  *   Take to WGLC?

From: Netmod-ver-dt <[email-masked]<mailto:[email-masked]>> On Behalf Of Rob Wilton (rwilton)
Sent: 03 March 2020 15:10
To: [email-masked]<mailto:[email-masked]>
Subject: [Netmod-ver-dt] Possible choices for editors

From discussion today:

  *   Move to NETCONF WG?

  *   Feedback from Martin.

0) requirements draft - Joe
  - Already adopted.
<ietf-107-netmod-yang-schema-comparison.pptx>_______________________________________________
Netmod-ver-dt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod-ver-dt

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Fri, 20 Mar 2020 20:50:35 +0000

+1 and +1

From: Netmod-ver-dt <[email-masked]> on behalf of "Joe Clarke (jclarke)" <jclarke=[email-masked]>
Date: Friday, March 20, 2020 at 4:45 PM
To: "Reshad Rahman (rrahman)" <rrahman=[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "Rob Wilton (rwilton)" <rwilton=[email-masked]>
Subject: Re: [Netmod-ver-dt] Schema-comparison

Joe

Hi Rob, all,

Inline.

Hi Reshad,

Some comments inline …

Hi Rob, all,

·         Renaming a node within a module is easier and we should make sure that we have that one covered.

·         If we want to allow renaming from other modules then I think that we want to avoid using an import statement because it will create unwanted dependencies, and perhaps instead rely on a schema node path that uses qualified module name, e.g. perhaps like RESTCONF paths, with the default being the current module.
 <RR> Ack.

Regards,
Reshad.

Some comments/questions:

Perhaps:

Thanks,
Rob

Regards,
Reshad.

·         Take to WGLC?

·         Publish as informational?

From discussion today:

·         Move to NETCONF WG?

·         Does it need to be split due to updating both NETCONF and RESTCONF?

·         Feedback from Martin.

·         Reshad to produce slides for 107.

·         Not planning to say much on this at all, at this stage.

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Mon, 23 Mar 2020 16:26:56 +0000

Hi Reshad,

I think that the slides are basically fine.  Verbally you may want to say that there has been little discussion on the draft so far, and it hasn’t changed since 106, so these slides are being represented to help ensure that the WG is up to speed with the approach.

The “stuf” is the deliberate mistake that is being fixed.  If you fix that in the slides then the example won’t make sense ;-)

I also agree with Joe, that for each of the comments, it might be useful to give a suggestion of what the current leaning/thinking is.  This has the benefit in that it will either force comment/discussion if folks disagree, or we know which direction to head in if there are no comments.

Regards,
Rob

From: Netmod-ver-dt <[email-masked]> On Behalf Of Reshad Rahman (rrahman)
Sent: 20 March 2020 20:51
To: Joe Clarke (jclarke) <jclarke=[email-masked]>
Cc: [email-masked]; Rob Wilton (rwilton) <rwilton=[email-masked]>
Subject: Re: [Netmod-ver-dt] Schema-comparison

+1 and +1

From: Netmod-ver-dt <[email-masked]<mailto:[email-masked]>> on behalf of "Joe Clarke (jclarke)" <jclarke=[email-masked]<mailto:jclarke=[email-masked]>>
Date: Friday, March 20, 2020 at 4:45 PM
To: "Reshad Rahman (rrahman)" <rrahman=[email-masked]<mailto:rrahman=[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Rob Wilton (rwilton)" <rwilton=[email-masked]<mailto:rwilton=[email-masked]>>
Subject: Re: [Netmod-ver-dt] Schema-comparison

Joe

Hi Rob, all,

Inline.

Hi Reshad,

Some comments inline …

Hi Rob, all,

Regards,
Reshad.

Some comments/questions:

Perhaps:

Thanks,
Rob

Regards,
Reshad.

·       Take to WGLC?

From discussion today:

·       Move to NETCONF WG?

·       Feedback from Martin.

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Mon, 23 Mar 2020 16:29:57 +0000

I thought that about stuf, but I didn’t see it fixed in the new rev.

Joe

PGP Key : https://www.marcuscom.com/pgp.asc

On Mar 23, 2020, at 12:28, Rob Wilton (rwilton) <rwilton=[email-masked]> wrote:

Hi Reshad,

Regards,
Rob

+1 and +1

Joe

Hi Rob, all,

Inline.

Hi Reshad,

Some comments inline …

Hi Rob, all,

Regards,
Reshad.

Some comments/questions:

Perhaps:

Thanks,
Rob

Regards,
Reshad.

·       Take to WGLC?

From discussion today:

·       Move to NETCONF WG?

·       Feedback from Martin.

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Mon, 23 Mar 2020 16:32:01 +0000

Hi Rob,

From: "Rob Wilton (rwilton)" <rwilton=[email-masked]>
Date: Monday, March 23, 2020 at 12:28 PM
To: "Reshad Rahman (rrahman)" <[email-masked]>, "Joe Clarke (jclarke)" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "Rob Wilton (rwilton)" <[email-masked]>
Subject: RE: [Netmod-ver-dt] Schema-comparison

Hi Reshad,

The “stuf” is the deliberate mistake that is being fixed.  If you fix that in the slides then the example won’t make sense ;-)
<RR> Yes to show the editorial change, I should have been clearer what my +1s were for.

I also agree with Joe, that for each of the comments, it might be useful to give a suggestion of what the current leaning/thinking is.  This has the benefit in that it will either force comment/discussion if folks disagree, or we know which direction to head in if there are no comments.
<RR> Something we can discuss quickly tomorrow?

Regards.
Reshad.

Regards,
Rob

+1 and +1

Joe

Hi Rob, all,

Inline.

Hi Reshad,

Some comments inline …

Hi Rob, all,

Regards,
Reshad.

Some comments/questions:

Perhaps:

Thanks,
Rob

Regards,
Reshad.

·         Take to WGLC?

From discussion today:

·         Move to NETCONF WG?

·         Feedback from Martin.

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Mon, 23 Mar 2020 16:56:16 +0000

<RR> Something we can discuss quickly tomorrow?
Yes, but I’m sorry but I can’t make the meeting tomorrow.  It clashes with an IESG meeting due to virtual scheduling headache.  Can you or Joe host and the meeting go ahead without me?

Thanks,
Rob

From: Reshad Rahman (rrahman) <[email-masked]>
Sent: 23 March 2020 16:32
To: Rob Wilton (rwilton) <rwilton=[email-masked]>; Joe Clarke (jclarke) <[email-masked]>
Cc: [email-masked]; Rob Wilton (rwilton) <[email-masked]>
Subject: Re: [Netmod-ver-dt] Schema-comparison

Hi Rob,

From: "Rob Wilton (rwilton)" <rwilton=[email-masked]<mailto:rwilton=[email-masked]>>
Date: Monday, March 23, 2020 at 12:28 PM
To: "Reshad Rahman (rrahman)" <[email-masked]<mailto:[email-masked]>>, "Joe Clarke (jclarke)" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Rob Wilton (rwilton)" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Netmod-ver-dt] Schema-comparison

Hi Reshad,

Regards.
Reshad.

Regards,
Rob

From: Netmod-ver-dt <[email-masked]<mailto:[email-masked]>> On Behalf Of Reshad Rahman (rrahman)
Sent: 20 March 2020 20:51
To: Joe Clarke (jclarke) <jclarke=[email-masked]<mailto:jclarke=[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Rob Wilton (rwilton) <rwilton=[email-masked]<mailto:rwilton=[email-masked]>>
Subject: Re: [Netmod-ver-dt] Schema-comparison

+1 and +1

Joe

Hi Rob, all,

Inline.

Hi Reshad,

Some comments inline …

Hi Rob, all,

Regards,
Reshad.

Some comments/questions:

Perhaps:

Thanks,
Rob

Regards,
Reshad.

·       Take to WGLC?

From discussion today:

·       Move to NETCONF WG?

·       Feedback from Martin.

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Mon, 23 Mar 2020 16:58:16 +0000

Might be worth changing time just for this week? E.g. 1 hr earlier? Or Wednesday?

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Monday, March 23, 2020 at 12:56 PM
To: "Reshad Rahman (rrahman)" <[email-masked]>, "Rob Wilton (rwilton)" <rwilton=[email-masked]>, "Joe Clarke (jclarke)" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: RE: [Netmod-ver-dt] Schema-comparison

Thanks,
Rob

Hi Rob,

Hi Reshad,

Regards.
Reshad.

Regards,
Rob

+1 and +1

Joe

Hi Rob, all,

Inline.

Hi Reshad,

Some comments inline …

Hi Rob, all,

Regards,
Reshad.

Some comments/questions:

Perhaps:

Thanks,
Rob

Regards,
Reshad.

·         Take to WGLC?

From discussion today:

·         Move to NETCONF WG?

·         Feedback from Martin.

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Mon, 23 Mar 2020 16:59:31 +0000

I have a conflict tomorrow morning, too.

Joe

On Mar 23, 2020, at 12:56, Rob Wilton (rwilton) <[email-masked]> wrote:

Thanks,
Rob

Hi Rob,

Hi Reshad,

Regards.
Reshad.

Regards,
Rob

+1 and +1

Joe

Hi Rob, all,

Inline.

Hi Reshad,

Some comments inline …

Hi Rob, all,

Regards,
Reshad.

Some comments/questions:

Perhaps:

Thanks,
Rob

Regards,
Reshad.

·       Take to WGLC?

From discussion today:

·       Move to NETCONF WG?

·       Feedback from Martin.

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Mon, 23 Mar 2020 17:04:07 +0000

Weds would be fine, or an hour earlier would also be fine with me.

From: Reshad Rahman (rrahman) <[email-masked]>
Sent: 23 March 2020 16:58
To: Rob Wilton (rwilton) <[email-masked]>; Rob Wilton (rwilton) <rwilton=[email-masked]>; Joe Clarke (jclarke) <[email-masked]>
Cc: [email-masked]
Subject: Re: [Netmod-ver-dt] Schema-comparison

From: "Rob Wilton (rwilton)" <[email-masked]<mailto:[email-masked]>>
Date: Monday, March 23, 2020 at 12:56 PM
To: "Reshad Rahman (rrahman)" <[email-masked]<mailto:[email-masked]>>, "Rob Wilton (rwilton)" <rwilton=[email-masked]<mailto:rwilton=[email-masked]>>, "Joe Clarke (jclarke)" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Netmod-ver-dt] Schema-comparison

Thanks,
Rob

From: Reshad Rahman (rrahman) <[email-masked]<mailto:[email-masked]>>
Sent: 23 March 2020 16:32
To: Rob Wilton (rwilton) <rwilton=[email-masked]<mailto:rwilton=[email-masked]>>; Joe Clarke (jclarke) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Rob Wilton (rwilton) <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Netmod-ver-dt] Schema-comparison

Hi Rob,

Hi Reshad,

Regards.
Reshad.

Regards,
Rob

+1 and +1

Joe

Hi Rob, all,

Inline.

Hi Reshad,

Some comments inline …

Hi Rob, all,

Regards,
Reshad.

Some comments/questions:

Perhaps:

Thanks,
Rob

Regards,
Reshad.

·       Take to WGLC?

From discussion today:

·       Move to NETCONF WG?

·       Feedback from Martin.

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Tue, 24 Mar 2020 13:17:24 +0000

Let’s meet tomorrow then? Who can make it?

Date: Monday, March 23, 2020 at 1:04 PM

Thanks,
Rob

Hi Rob,

Hi Reshad,

Regards.
Reshad.

Regards,
Rob

+1 and +1

Joe

Hi Rob, all,

Inline.

Hi Reshad,

Some comments inline …

Hi Rob, all,

Regards,
Reshad.

Some comments/questions:

Perhaps:

Thanks,
Rob

Regards,
Reshad.

·         Take to WGLC?

From discussion today:

·         Move to NETCONF WG?

·         Feedback from Martin.

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Tue, 24 Mar 2020 13:19:18 +0000

Depends on the time.  I can do a half hour at 10:00 am EDT.

Joe

On Mar 24, 2020, at 09:17, Reshad Rahman (rrahman) <[email-masked]> wrote:

Thanks,
Rob

Hi Rob,

Hi Reshad,

Regards.
Reshad.

Regards,
Rob

+1 and +1

Joe

Hi Rob, all,

Inline.

Hi Reshad,

Some comments inline …

Hi Rob, all,

Regards,
Reshad.

Some comments/questions:

Perhaps:

Thanks,
Rob

Regards,
Reshad.

·         Take to WGLC?

From discussion today:

·         Move to NETCONF WG?

·         Feedback from Martin.

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Wed, 25 Mar 2020 22:00:21 +0000

Hi all,

We briefly discussed point 1 today. I don’t have strong opinion on this. The advantage of defining the extensions in yang-module-versioning is that we’re defining the extensions for tooling together with the extensions for the functionality (anything else?). But that’s also a disadvantage since the versioning work might get slowed down by tooling related extensions. And from what we discussed today, we think module-versioning, semver and packages are the 3 documents which we want to push asap.

For point 2, I agree that rev-ext:nbc is useful.

Regards,
Reshad.

Joe

Hi Rob, all,

Inline.

Hi Reshad,

Some comments inline …

Hi Rob, all,

Regards,
Reshad.

Some comments/questions:

Perhaps:

Thanks,
Rob

Regards,
Reshad.

·         Take to WGLC?

From discussion today:

·         Move to NETCONF WG?

·         Feedback from Martin.

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Mon, 30 Mar 2020 17:44:47 +0000

As per Joe’s suggestion, I’ve updated slide 7 (1st 2 points).

Thanks,
Reshad.

Joe

Hi Rob, all,

Inline.

Hi Reshad,

Some comments inline …

Hi Rob, all,

Regards,
Reshad.

Some comments/questions:

Perhaps:

Thanks,
Rob

Regards,
Reshad.

·         Take to WGLC?

From discussion today:

·         Move to NETCONF WG?

·         Feedback from Martin.