Subject: [Netmod-ver-dt] version-selection slides: discuss "this is too complex" ?

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Mon, 30 Mar 2020 17:55:17 +0000

Hi guys,

Martin raised this point during the adoption call for version-selection:

This solution is complex and may be impossible to implement in certain scenarios

Should we address that in the meetings (and slides) ?

I'm going to move it to the end of the preso if we keep it in.  I'd like to get through the other points & issues first.

Joe -> can you clarify what you meant with the following bullet on the slide?

     *   Document prescribes deviations to deal with such discrepancies

I'm not sure I'm following what deviation would be used (e.g. if a leaf X changed from an int to a Boolean) ?

I'm tempted to avoid those bullets in the slide. It starts to get into GitHub issue #43.  Maybe we can just focus on my example use cases for version selection from my response to Martin:

One example is when an NBC change needs to occur (e.g. bug fix, or extending functionality) that causes a leaf to change type but there is a strong desire to keep the same name (e.g. something basic like "interface" or "address"). We can't use a "status deprecated" approach to support the old functionality in this case.

Another example is the ability for a client to specify (and a server to advertise & limit) which data models (3rd party vs proprietary) it wants to use for interactions with the server.

Jason

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Mon, 30 Mar 2020 20:23:02 +0000

On Mar 30, 2020, at 13:55, Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>> wrote:

Hi guys,

This was incomplete.  Deviations and other [out-of-band] mechanisms can be used.  In particular, where mapping fails, this could generate a syslog or other alert.  I’m referring to section 4 (final bullet) of the version selection draft.

In the case of Boolean vs. int, a vendor may choose to deviate and not support a new node.  Or they may deviate the type of the new node to retain its previous int type.  Or the server may just report, “failed to map X from int(7) to Boolean; choosing false”.

Joe

Jason
_______________________________________________
Netmod-ver-dt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod-ver-dt

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Mon, 30 Mar 2020 20:55:54 +0000

Thx - see inline.
Jason

From: Joe Clarke (jclarke) <[email-masked]>
Sent: Monday, March 30, 2020 4:23 PM
To: Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]>
Cc: [email-masked]
Subject: Re: [Netmod-ver-dt] version-selection slides: discuss "this is too complex" ?

Hi guys,

This was incomplete.  Deviations and other [out-of-band] mechanisms can be used.  In particular, where mapping fails, this could generate a syslog or other alert.  I’m referring to section 4 (final bullet) of the version selection draft.
[>>JTS: ] Thx. My proposal is to leave this detail out of the slides. If someone raises it then I'll address it.

In the case of Boolean vs. int, a vendor may choose to deviate and not support a new node.
[>>JTS: ] OK. I guess that deviation gets published as part of the package for the new schema that has the leaf as a Boolean (or in a separate deviations package that gets combined with the new schema package).

Or they may deviate the type of the new node to retain its previous int type.  Or the server may just report, “failed to map X from int(7) to Boolean; choosing false”.
[>>JTS: ] Yes - and *how* to report that is tricky. NETCONF doesn't allow returning data from a get-config while also providing any sort of error or warning (currently).

Joe

Jason