Subject: [Netmod-ver-dt] prelim IETF 107 slides for version selection

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Fri, 13 Mar 2020 20:36:42 +0000

Hi guys,

I put together some slides on the changes to version selection since the previous IETF in case someone needs to present these next week while I'm away (seems unlikely though).

Joe - can you take ownership of this preso for next week and add your "Issues"?

If we don't present before I'm back (Monday March 23) then I can help polish them further but I wanted to at least get this part to the DT.

Rgds,
Jason

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Mon, 16 Mar 2020 18:13:05 +0000

On Mar 13, 2020, at 16:36, Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>> wrote:

Hi guys,

Slides look good, Jason.  I think we will need to talk through the NETCONF process a bit.  Clients will either need a priori knowledge of available schema sets or do a connect/disconnect/connect to get the set they want.

Yep.  I just raised an issue that we probably need to clarify the default behavior in RESTCONF more.

Looks like we’ll get a slot either on Mar 31 or Apr 2.

Joe

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 16 Mar 2020 13:14:37 -0700

Hi Joe/Jason,

I think it makes sense to present this in NETCONF WG also. What do you think?

> On Mar 16, 2020, at 11:13 AM, Joe Clarke (jclarke) <jclarke=[email-masked]> wrote:
> 
> 
> 
>> On Mar 13, 2020, at 16:36, Sterne, Jason (Nokia - CA/Ottawa) <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi guys,
>>  
> _______________________________________________
> Netmod-ver-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod-ver-dt

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Mon, 16 Mar 2020 20:17:26 +0000

Usually the same crowd goes to both?

From: Netmod-ver-dt <[email-masked]> on behalf of Mahesh Jethanandani <[email-masked]>
Date: Monday, March 16, 2020 at 4:14 PM
To: "Joe Clarke (jclarke)" <jclarke=[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Jason Sterne <[email-masked]>
Subject: Re: [Netmod-ver-dt] prelim IETF 107 slides for version selection

Hi Joe/Jason,

On Mar 16, 2020, at 11:13 AM, Joe Clarke (jclarke) <jclarke=[email-masked]<mailto:jclarke=[email-masked]>> wrote:

Hi guys,

Joe

_______________________________________________
Netmod-ver-dt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod-ver-dt

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 16 Mar 2020 13:22:23 -0700

[Adding Kent]

Usually, yes. And I a not suggesting the entire set of drafts. I would say the ones that focus on the impact on NETCONF/RESTCONF.

> On Mar 16, 2020, at 1:17 PM, Reshad Rahman (rrahman) <[email-masked]> wrote:
> 
>> On Mar 16, 2020, at 11:13 AM, Joe Clarke (jclarke) <jclarke=[email-masked] <mailto:jclarke=[email-masked]>> wrote:
>>  
>>  
>> 
>> 
>> [email-masked] <mailto:[email-masked]>

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Mon, 16 Mar 2020 20:24:35 +0000

Ack.

From: Mahesh Jethanandani <[email-masked]>
Date: Monday, March 16, 2020 at 4:22 PM
To: "Reshad Rahman (rrahman)" <[email-masked]>
Cc: "Joe Clarke (jclarke)" <jclarke=[email-masked]>, "[email-masked]" <[email-masked]>, Jason Sterne <[email-masked]>, Kent Watsen <[email-masked]>
Subject: Re: [Netmod-ver-dt] prelim IETF 107 slides for version selection

[Adding Kent]

On Mar 16, 2020, at 1:17 PM, Reshad Rahman (rrahman) <[email-masked]<mailto:[email-masked]>> wrote:

From: Netmod-ver-dt <[email-masked]<mailto:[email-masked]>> on behalf of Mahesh Jethanandani <[email-masked]<mailto:[email-masked]>>
Date: Monday, March 16, 2020 at 4:14 PM
To: "Joe Clarke (jclarke)" <jclarke=[email-masked]<mailto:jclarke=[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Jason Sterne <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Netmod-ver-dt] prelim IETF 107 slides for version selection

Hi Joe/Jason,

Hi guys,

Joe

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Mon, 16 Mar 2020 20:38:49 +0000

> On Mar 16, 2020, at 16:14, Mahesh Jethanandani <[email-masked]> wrote:
> 
> Hi Joe/Jason,
> 

This would be beneficial to share with NETCONF as well, yes.

Joe

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 17 Mar 2020 10:41:37 +0000

Adding NETCONF/NETMOD chairs.

I think that the version selection draft (if adopted) should probably end up in NETCONF rather than NETMOD (if the chairs agree).

But for the purposes of the WG group adoption of the drafts, it probably makes sense for those discussions to happen in one place.

Although not set in stone, according to the predefined schedule, it currently looks like the NETMOD meetings will happen before NETCONF.  Mahesh, do you think that someone from the DT should send up an email to NETCONF highlighting that the adoption call is taking place in NETMOD, but the eventual home of the version selection draft (if adopted) may end up being in NETCONF rather than NETMOD?

Thanks,
Rob

> -----Original Message-----
> From: Netmod-ver-dt <[email-masked]> On Behalf Of Joe
> Clarke (jclarke)
> Sent: 16 March 2020 20:39
> To: Mahesh Jethanandani <[email-masked]>
> Cc: Joe Clarke (jclarke) <jclarke=[email-masked]>; netmod-ver-
> [email-masked]; Jason Sterne <[email-masked]>

---

From: Lou Berger <[email-masked]>
Date: Tue, 17 Mar 2020 07:43:16 -0400

Hi

Kent and I discussed a joint NetMod and Netconf interim meeting yesterday - 
remember the chairs are lurkers on the DT list.  We were going to confirm 
with our co chairs before discussing with the dt. So stay tuned...

Lou

----------
On March 17, 2020 6:42:16 AM "Rob Wilton \(rwilton\)" 
<rwilton=[email-masked]> wrote:

> I think that the version selection draft (if adopted) should probably end 
> up in NETCONF rather than NETMOD (if the chairs agree).
>
> But for the purposes of the WG group adoption of the drafts, it probably 
> makes sense for those discussions to happen in one place.
>
> Although not set in stone, according to the predefined schedule, it 
> currently looks like the NETMOD meetings will happen before NETCONF.  
> Mahesh, do you think that someone from the DT should send up an email to 
> NETCONF highlighting that the adoption call is taking place in NETMOD, but 
> the eventual home of the version selection draft (if adopted) may end up 
> being in NETCONF rather than NETMOD?
>
> Thanks,
> Rob
>
>

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 17 Mar 2020 11:50:19 +0000

Hi Jason,

Slides generally look good to me.

A few minor comments:

On slide 2:

  *   Perhaps change "some on the client" to "minimal for the client"

On slide 3:

  *   I wasn't sure that the second bullet completely scans.  Should it just be "It can also be used to allow clients to select between YANG schema defined by different organizations"?

Between slides 4 and 5:

  *   I think that it might be helpful to have an extra slide after 4, that covers the "selectable" leaf-list, and perhaps default too, both in configuration and <operational>
  *   Having a diagram to show the relationship between packages, datastore-schema, schema-sets, might be helpful, but only if someone has the time to do them.

Thanks,
Rob

From: Netmod-ver-dt <[email-masked]> On Behalf Of Sterne, Jason (Nokia - CA/Ottawa)
Sent: 13 March 2020 20:37
To: [email-masked]
Subject: [Netmod-ver-dt] prelim IETF 107 slides for version selection

Hi guys,

Rgds,
Jason

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Tue, 17 Mar 2020 17:54:11 +0000

Extending on this, here are the proposed issues slides that will go at the end of this deck when the final changes are in.

I didn’t call out GitHub issues #42 and #43 here as I wasn’t sure those needed to be raised [yet] to the WG.  In particular, I think #42 can be handled by the authors, and #43 seems like we may want a suggestion to the WG first.  But for now, I think we have enough on our plates with these.

Joe

Hi guys,

Rgds,
Jason
<ietf-107-netmod-verdt-yang-ver-selection-update-v1.pptx>_______________________________________________
Netmod-ver-dt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod-ver-dt

---

From: Kent Watsen <[email-masked]>
Date: Tue, 17 Mar 2020 18:26:43 +0000

I'd assumed that all the ver-DT drafts would be run by NETMOD (since it’s charter allows it) but, if some drafts are to be run by NETCONF, then I think that the adoption call for those drafts MUST be in NETCONF, right?

Regarding a joint VI meeting, let’s determine where the drafts need to run first.  If all in NETMOD, then it can be a NETMOD-only VI meeting that NETCONF is simply made aware of (given high-overlap, this is likely not needed, but we’d do it more for formality).  If some drafts are to be run in NETCONF, then a joint VI meeting would be best (so the overlap doesn’t have to sit through it twice).

K.

> On Mar 17, 2020, at 7:43 AM, Lou Berger <[email-masked]> wrote:
> 
> Hi
> 
> Kent and I discussed a joint NetMod and Netconf interim meeting yesterday - remember the chairs are lurkers on the DT list.  We were going to confirm with our co chairs before discussing with the dt. So stay tuned...
> 
> Lou
> 
> 
> ----------
> On March 17, 2020 6:42:16 AM "Rob Wilton \(rwilton\)" <rwilton=[email-masked]> wrote:
>

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Tue, 17 Mar 2020 19:03:09 +0000

> On Mar 17, 2020, at 14:26, Kent Watsen <[email-masked]> wrote:
> 

The draft on version selection specifies changes to NETCONF and RESTCONF, so it would make sense to discuss in netconf.  It may be that this document needs to split into others so the right work is done in the right group.

Joe

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Fri, 20 Mar 2020 14:34:02 +0000

Here are my new ver selection issue slides.  I added the WG “issue”.

Joe

Hi guys,

Rgds,
Jason

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Thu, 26 Mar 2020 22:23:25 +0000

Thx. See inline.
Jason

From: Rob Wilton (rwilton) <[email-masked]>
Sent: Tuesday, March 17, 2020 7:50 AM
To: Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]>; [email-masked]
Subject: RE: prelim IETF 107 slides for version selection

Hi Jason,

A few minor comments:

On slide 2:

  *   Perhaps change "some on the client" to "minimal for the client"[>>JTS: ] changed

On slide 3:

  *   I wasn't sure that the second bullet completely scans.  Should it just be "It can also be used to allow clients to select between YANG schema defined by different organizations"?[>>JTS: ] Yes - changed

Between slides 4 and 5:

[>>JTS: ] Added new slide 5 - please take a look.

[>>JTS: ] I'll try to get some cycles to do that.  Basically that schema-sets are comprised of packages (or rather packages for each datastore).  But what do you mean by datastore-schema? That term is mentioned once in the version selection draft. Is it defined somewhere else?

Thanks,
Rob

From: Netmod-ver-dt <[email-masked]<mailto:[email-masked]>> On Behalf Of Sterne, Jason (Nokia - CA/Ottawa)
Sent: 13 March 2020 20:37
To: [email-masked]<mailto:[email-masked]>
Subject: [Netmod-ver-dt] prelim IETF 107 slides for version selection

Hi guys,

Rgds,
Jason

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Fri, 27 Mar 2020 13:49:39 +0000

Since I had the issues part, a few perhaps aids there.

For the file naming issue, I think showing an example of:

ietf-interfaces@2018-02-20

vs.

[email-masked]

Is one way to illustrate the challenge.  But smart parsers will deal with this easily.  I think the bigger risk is something like this:

vendor-example@2020-03-29

vs.

vendor-example@2020-02-31

Where the latter is the second vendor release of 2020 with build ID 31 (something silly, but doable with revision-labels).  Parsers that blindly assume something that looks like a date is may have other issues.  Sure, we could add verbiage that a revision-label can’t look like a date or a semver, but perhaps it’s easier to have:

vendor-example#2020-02-31

===

On the last slide, based on our discussion the other day, should we add a bullet that says, “DT prefers this to remain as one document in netconf”?

Joe

On Mar 26, 2020, at 18:23, Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>> wrote:

Thx. See inline.
Jason

From: Rob Wilton (rwilton) <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, March 17, 2020 7:50 AM
To: Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: prelim IETF 107 slides for version selection

Hi Jason,

A few minor comments:

On slide 2:

  *   Perhaps change “some on the client” to “minimal for the client”[>>JTS: ] changed

On slide 3:

  *   I wasn’t sure that the second bullet completely scans.  Should it just be “It can also be used to allow clients to select between YANG schema defined by different organizations”?[>>JTS: ] Yes - changed

Between slides 4 and 5:

  *   I think that it might be helpful to have an extra slide after 4, that covers the “selectable” leaf-list, and perhaps default too, both in configuration and <operational>

Thanks,
Rob

Hi guys,

Rgds,
Jason
<ietf-107-netmod-yang-ver-selection-update-v2.pptx>_______________________________________________
Netmod-ver-dt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod-ver-dt

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Fri, 27 Mar 2020 23:04:56 +0000

Hi Joe,

I like your point about the filename issue, but that's something for yang-module-versioning (not these slides).

Our version-selection slides do have an issue about numbering but it is about the schema-set name.

I added the bullet you mention to the last slide.

Jason

From: Joe Clarke (jclarke) <[email-masked]>
Sent: Friday, March 27, 2020 9:50 AM
To: Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]>
Cc: Rob Wilton (rwilton) <[email-masked]>; [email-masked]
Subject: Re: [Netmod-ver-dt] prelim IETF 107 slides for version selection

vs.

[email-masked]<mailto:[email-masked]>

vs.

===

Joe

Thx. See inline.
Jason

Hi Jason,

A few minor comments:

On slide 2:

·        Perhaps change “some on the client” to “minimal for the client”[>>JTS: ] changed

On slide 3:

·        I wasn’t sure that the second bullet completely scans.  Should it just be “It can also be used to allow clients to select between YANG schema defined by different organizations”?[>>JTS: ] Yes - changed

Between slides 4 and 5:

·        I think that it might be helpful to have an extra slide after 4, that covers the “selectable” leaf-list, and perhaps default too, both in configuration and <operational>
[>>JTS: ] Added new slide 5 - please take a look.

·        Having a diagram to show the relationship between packages, datastore-schema, schema-sets, might be helpful, but only if someone has the time to do them.
[>>JTS: ] I'll try to get some cycles to do that.  Basically that schema-sets are comprised of packages (or rather packages for each datastore).  But what do you mean by datastore-schema? That term is mentioned once in the version selection draft. Is it defined somewhere else?

Thanks,
Rob

Hi guys,

Rgds,
Jason

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Mon, 30 Mar 2020 17:53:54 +0000

Agree we leave out #42 and #43 for now:

https://github.com/netmod-wg/yang-ver-dt/issues/42
Document how schema-sets can be made available in instance-data documents

https://github.com/netmod-wg/yang-ver-dt/issues/43
Document reporting errors if configuration cannot be expressed in a schema

Jason

From: Joe Clarke (jclarke) <[email-masked]>
Sent: Tuesday, March 17, 2020 1:54 PM
To: Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]>
Cc: [email-masked]
Subject: Re: [Netmod-ver-dt] prelim IETF 107 slides for version selection

Joe

Hi guys,

Rgds,
Jason

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Mon, 30 Mar 2020 20:14:48 +0000

On Mar 27, 2020, at 19:04, Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Joe,

Ah, yeah.  Sorry.  I saw ‘@‘ and went to the filename thing since I had that on my mind.

Thanks.

Joe

Jason

From: Joe Clarke (jclarke) <[email-masked]<mailto:[email-masked]>>
Sent: Friday, March 27, 2020 9:50 AM
To: Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>
Cc: Rob Wilton (rwilton) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Netmod-ver-dt] prelim IETF 107 slides for version selection

vs.

vs.

===

Joe

Thx. See inline.
Jason

Hi Jason,

A few minor comments:

On slide 2:

•        Perhaps change “some on the client” to “minimal for the client”[>>JTS: ] changed

On slide 3:

•        I wasn’t sure that the second bullet completely scans.  Should it just be “It can also be used to allow clients to select between YANG schema defined by different organizations”?[>>JTS: ] Yes - changed

Between slides 4 and 5:

•        I think that it might be helpful to have an extra slide after 4, that covers the “selectable” leaf-list, and perhaps default too, both in configuration and <operational>

•        Having a diagram to show the relationship between packages, datastore-schema, schema-sets, might be helpful, but only if someone has the time to do them.

Thanks,
Rob

Hi guys,

Rgds,
Jason

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Mon, 30 Mar 2020 21:03:06 +0000

I've updated the version selection slides a fair bit. Enclosed and comments appreciated.

I added some details to the issues and reordered things to put the NETCONF issues first.

I added a slide to show relationships between packages, datastores and schema-sets.

I added a slide to defer questions about the other drafts.

Jason

Sent: Monday, March 30, 2020 4:15 PM

Hi Joe,

Thanks.

Joe

Jason

vs.

vs.

===

Joe

Thx. See inline.
Jason

Hi Jason,

A few minor comments:

On slide 2:

On slide 3:

Between slides 4 and 5:

Thanks,
Rob

Hi guys,

Rgds,
Jason

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Mon, 30 Mar 2020 22:01:16 +0000

On Mar 30, 2020, at 17:03, Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>> wrote:

Looks good.  I like the clarification on slide 14, but I admit I had to read it twice to see that you’re not talking config in paragraph 2.

Love slide 9.  Clarifies it well I think.

Joe

Jason

Hi Joe,

Thanks.

Joe

Jason

vs.

vs.

===

Joe

Thx. See inline.
Jason

Hi Jason,

A few minor comments:

On slide 2:

On slide 3:

Between slides 4 and 5:

Thanks,
Rob

Hi guys,

Rgds,
Jason

<ietf-107-netmod-yang-ver-selection-update-v3.pptx>

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Mon, 30 Mar 2020 22:07:37 +0000

Thx. How about if I add a bit to paragraph #2 as follows:

OLD:

If the server can only support a limited number of schema-sets in parallel, and the maximum number of schema-sets are currently in use, and a new NETCONF session attempts to use a new valid schema-set (exceeding the maximum number of parallel schema-sets), then the new NETCONF session is disconnected.

NEW:

If the server can only support a limited number of schema-sets in parallel, and the maximum number of schema-sets are currently in use by active NETCONF sessions (or RESTCONF requests), and a new NETCONF session attempts to connect and use a new valid schema-set (exceeding the maximum number of parallel schema-sets), then the new NETCONF session is disconnected.

If the server can only support a limited number of schema-sets in parallel, and the maximum number of schema-sets are currently in use by active NETCONF sessions (or RESTCONF requests), and a new RESTCONF request attempts use a new valid schema-set (exceeding the maximum number of parallel schema-sets), then the RESTCONF request fails and the server returns an error.

Jason

Sent: Monday, March 30, 2020 6:01 PM

Joe

Jason

Hi Joe,

Thanks.

Joe

Jason

vs.

vs.

===

Joe

Thx. See inline.
Jason

Hi Jason,

A few minor comments:

On slide 2:

On slide 3:

Between slides 4 and 5:

Thanks,
Rob

Hi guys,

Rgds,
Jason

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Mon, 30 Mar 2020 22:11:30 +0000

On Mar 30, 2020, at 18:07, Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>> wrote:

OLD:

NEW:

Works for me.

Joe

Jason

Joe

Jason

Hi Joe,

Thanks.

Joe

Jason

vs.

vs.

===

Joe

Thx. See inline.
Jason

Hi Jason,

A few minor comments:

On slide 2:

On slide 3:

Between slides 4 and 5:

Thanks,
Rob

Hi guys,

Rgds,
Jason

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 30 Mar 2020 15:15:43 -0700

In anticipation of you asking for a presentation slot in NETCONF (which I have either lost in the hundreds of emails, or has not been sent), we have allocated a 10 min. slot. But this slide deck already has 18 slides, which means you have less than one minute per slide, or you need to cut back on the number of slides. Maybe there is already a plan to take this deck for NETMOD, and cut it down??

> On Mar 30, 2020, at 3:07 PM, Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]> wrote:
> 
> On Mar 30, 2020, at 17:03, Sterne, Jason (Nokia - CA/Ottawa) <[email-masked] <mailto:[email-masked]>> wrote:
>  
> From: Joe Clarke (jclarke) <[email-masked] <mailto:[email-masked]>> 
> To: Sterne, Jason (Nokia - CA/Ottawa) <[email-masked] <mailto:[email-masked]>>
> Cc: Rob Wilton (rwilton) <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
> On Mar 27, 2020, at 19:04, Sterne, Jason (Nokia - CA/Ottawa) <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Hi Joe,
>  
> From: Joe Clarke (jclarke) <[email-masked] <mailto:[email-masked]>> 
> To: Sterne, Jason (Nokia - CA/Ottawa) <[email-masked] <mailto:[email-masked]>>
> Cc: Rob Wilton (rwilton) <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>
>  
> On Mar 26, 2020, at 18:23, Sterne, Jason (Nokia - CA/Ottawa) <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Thx. See inline.
> Jason
>  
> From: Rob Wilton (rwilton) <[email-masked] <mailto:[email-masked]>> 
> To: Sterne, Jason (Nokia - CA/Ottawa) <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
> From: Netmod-ver-dt <[email-masked] <mailto:[email-masked]>> On Behalf Of Sterne, Jason (Nokia - CA/Ottawa)
> To: [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/netmod-ver-dt <https://www.ietf.org/mailman/listinfo/netmod-ver-dt>
>

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Mon, 30 Mar 2020 22:25:09 +0000

Jason, I took a quick look at the slides (will try to spend more time on them tonight). They do look good, but there’s too many IMO…

Regards,
Reshad.

From: Netmod-ver-dt <[email-masked]> on behalf of "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Monday, March 30, 2020 at 6:08 PM
To: "Joe Clarke (jclarke)" <[email-masked]>
Cc: "Rob Wilton (rwilton)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Netmod-ver-dt] prelim IETF 107 slides for version selection

OLD:

NEW:

Jason

Joe

Jason

Hi Joe,

Thanks.

Joe

Jason

vs.

vs.

===

Joe

Thx. See inline.
Jason

Hi Jason,

A few minor comments:

On slide 2:

On slide 3:

Between slides 4 and 5:

Thanks,
Rob

Hi guys,

Rgds,
Jason

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Tue, 31 Mar 2020 16:09:42 +0000

Hi Mahesh,

Yes - I'd like a slot for version-selection please. We can make 10 minutes work although 15 would be better.

I will trim the deck and skip some slides (treat them as backup reference material).

Rgds,
Jason

From: Mahesh Jethanandani <[email-masked]>
Sent: Monday, March 30, 2020 6:16 PM
To: Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]>
Cc: Joe Clarke (jclarke) <[email-masked]>; Robert Wilton <[email-masked]>; [email-masked]
Subject: Re: [Netmod-ver-dt] prelim IETF 107 slides for version selection

On Mar 30, 2020, at 3:07 PM, Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>> wrote:

OLD:

NEW:

Jason

Joe

Jason

Hi Joe,

Thanks.

Joe

Jason

vs.

vs.

===

Joe

Thx. See inline.
Jason

Hi Jason,

A few minor comments:

On slide 2:

On slide 3:

Between slides 4 and 5:

Thanks,
Rob

Hi guys,

Rgds,
Jason

---

From: Mahesh Jethanandani <[email-masked]>
Date: Tue, 31 Mar 2020 09:23:28 -0700

Hi Jason,

Please send the slide deck you would like us to use. Thanks.

> On Mar 31, 2020, at 9:09 AM, Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]> wrote:
> 
> Hi Mahesh,
>  
> On Mar 30, 2020, at 3:07 PM, Sterne, Jason (Nokia - CA/Ottawa) <[email-masked] <mailto:[email-masked]>> wrote:
>

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Tue, 31 Mar 2020 16:29:02 +0000

I'm still making updates but will send the final PDF tomorrow afternoon if that is OK?

Sent: Tuesday, March 31, 2020 12:23 PM

Hi Jason,

On Mar 31, 2020, at 9:09 AM, Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Mahesh,

Rgds,
Jason

From: Mahesh Jethanandani <[email-masked]<mailto:[email-masked]>>
Sent: Monday, March 30, 2020 6:16 PM
To: Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>
Cc: Joe Clarke (jclarke) <[email-masked]<mailto:[email-masked]>>; Robert Wilton <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Netmod-ver-dt] prelim IETF 107 slides for version selection

OLD:

NEW:

Jason

Joe

Jason

Hi Joe,

Thanks.

Joe

Jason

vs.

vs.

===

Joe

Thx. See inline.
Jason

Hi Jason,

A few minor comments:

On slide 2:

On slide 3:

Between slides 4 and 5:

Thanks,
Rob

Hi guys,

Rgds,
Jason

---

From: Mahesh Jethanandani <[email-masked]>
Date: Tue, 31 Mar 2020 09:40:40 -0700

PPT(X) format please, and with slide numbers. Tomorrow is fine. Thanks.

> On Mar 31, 2020, at 9:29 AM, Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]> wrote:
> 
> On Mar 31, 2020, at 9:09 AM, Sterne, Jason (Nokia - CA/Ottawa) <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Hi Mahesh,
>  
> From: Mahesh Jethanandani <[email-masked] <mailto:[email-masked]>> 
> Cc: Joe Clarke (jclarke) <[email-masked] <mailto:[email-masked]>>; Robert Wilton <[email-masked] <mailto:[email-masked]>>;[email-masked] <mailto:[email-masked]>

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Tue, 31 Mar 2020 16:46:30 +0000

OK - I trimmed things a bit and moved a few slides to backup.  There are now 9 slides of "meat" that are the key part of the preso (slides 1-13 minus the various title slides & scope slide).

I fixed up the stuff about the 'selectable' and 'schema-set' lists.

Also incorporated the updated text for issue #40 that Joe and I were discussing and moved that into backup.

Enclosed are the latest.

Jason

From: Reshad Rahman (rrahman) <[email-masked]>
Sent: Monday, March 30, 2020 6:25 PM
To: Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]>; Joe Clarke (jclarke) <[email-masked]>
Cc: Rob Wilton (rwilton) <[email-masked]>; [email-masked]
Subject: Re: [Netmod-ver-dt] prelim IETF 107 slides for version selection

Regards,
Reshad.

From: Netmod-ver-dt <[email-masked]<mailto:[email-masked]>> on behalf of "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]<mailto:[email-masked]>>
Date: Monday, March 30, 2020 at 6:08 PM
To: "Joe Clarke (jclarke)" <[email-masked]<mailto:[email-masked]>>
Cc: "Rob Wilton (rwilton)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Netmod-ver-dt] prelim IETF 107 slides for version selection

OLD:

NEW:

Jason

Joe

Jason

Hi Joe,

Thanks.

Joe

Jason

vs.

vs.

===

Joe

Thx. See inline.
Jason

Hi Jason,

A few minor comments:

On slide 2:

On slide 3:

Between slides 4 and 5:

Thanks,
Rob

Hi guys,

Rgds,
Jason