Subject: [Netmod-ver-dt] YANG packages/version selection and schema mount

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Thu, 2 Apr 2020 10:48:33 +0000

Hi Bo, authors,

Currently the packages draft does not consider YANG schema mount (RFC 8528) at all.  However, it is possible that this draft and also the version selection drafts should potentially consider schema mount.  Possibly an issue that we should track, think further about whether it should be in scope, and get further input from the WG.

E.g. I'm wondering if some of the mount point information should be embedded into the packages definition, so a package can mount modules (or a package) at defined mount points.

Regards,
Rob

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Thu, 2 Apr 2020 13:39:12 +0000

Agree we should track this as a GitHub issue.

From: Netmod-ver-dt <[email-masked]> On Behalf Of Rob Wilton (rwilton)
Sent: Thursday, April 2, 2020 6:49 AM
To: Wubo (lana) <[email-masked]>; [email-masked]
Subject: [Netmod-ver-dt] YANG packages/version selection and schema mount

Hi Bo, authors,

Regards,
Rob