Subject: Re: [Netslices] a simple example of network slice template

From: Qin Wu <[email-masked]>
Date: Thu, 21 Sep 2017 14:05:42 +0000

Exactly, suggest you to read opsawg service model explained to figure out which layer model you are really dealing with? How does your model relate to network topology proposed in I2RS?

-Qin
发件人: Netslices [mailto:[email-masked]] 代表 Daniele Ceccarelli
发送时间: 2017年9月21日 21:47
收件人: qiangli (D) <[email-masked]>; Susan Hares <[email-masked]>; [email-masked]
主题: Re: [Netslices] a simple example of network slice template

Hi Cristina,

i think we need to define the scope of the work, i.e. are you targeting a customer service model, a service delivery model, network configuration model? I can agree that in the customer service model you might not want to know all the details of the network, even if knowing which nodes the NF/SF is attached to could be of some help, but for sure this info is needed from the service delivery model onwards.

BR
Daniele

From: Netslices [mailto:[email-masked]] On Behalf Of qiangli (D)
Sent: giovedì 21 settembre 2017 05:56
To: Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>; Susan Hares <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Netslices] a simple example of network slice template

Hi Daniele,

I agree with your opinion that VN is a good foundation for the transport part of network slice (“connectivity category”). My major concern is how are you going to augment the TE topology with the “storage/compute categories” and “predefined-function-block” (include VNF/SF you mentioned) in our following design.  Take the “storage” as an example, are you going to add some “storage related attributes” to nodes OR consider some “storage related metrics” during path compute OR maybe both? If you only augment nodes, I can’t see any meaning in TE scope. Then in the remaining two cases, your work in fact is connectivity enhancement. In a word, node in TE scope is forwarding node.

Network slice is a concept from resource perspective -- connectivity resources and storage resources can exist independently, they also can be bound together if necessary. An extreme example but easy going, a tenant just wants to buy some scattered storage units and a management unit, this is a slice but couldn’t be called VN, right?

Best regards,

Cristina QIANG

From: Daniele Ceccarelli [mailto:[email-masked]]
Sent: Wednesday, September 20, 2017 7:45 PM
To: Susan Hares; qiangli (D); [email-masked]<mailto:[email-masked]>
Subject: RE: [Netslices] a simple example of network slice template

Hi Sue, Cristina,

i suggest to start from this: https://tools.ietf.org/html/draft-lee-teas-actn-vn-yang-06 which is the yang model for the virtual network. It is derived from the info model (WG doc) https://tools.ietf.org/html/draft-ietf-teas-actn-info-model-02 .

Just to provide a further bit of info: on the MPI interface between the PNC (domain SDN controller) and the MDSC (hierarchical SDN controller/orchestrator) we use the TE tunnel and TE topology drafts because the VN is a concept exported by the MDSC towards the customer sitting on its NBI while between the MDSC and the PNC we preferred to keep on speaking about Tunnels and LSPs and not VNs. (also to make them understandable to legacy PNCs).

The VN is a concept defined over the CMI, namely the NBI of the MDSC and it looks like a good foundation for the transport part of the network slice (what you call connectivity category). It doesn’t include what you call the storage/compute category and the VNF/SF. We’re working on augmenting the TE topology with the latter.

BR
Daniele

From: Netslices [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: mercoledì 20 settembre 2017 12:51
To: 'qiangli (D)' <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Netslices] a simple example of network slice template

Cristina:

Before I answer this question, have you looked at the TEAS work on the underlay and compared It to this?

Sue Hares

From: Netslices [mailto:[email-masked]] On Behalf Of qiangli (D)
Sent: Wednesday, September 20, 2017 5:33 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Netslices] a simple example of network slice template

Hi All,

Following text is a simple example of network slice template. I would like to know what do you think about this kind of structure and design. Is this what you want?

module: ns-template
    +--rw network-slice
       +--rw atomic-component
       |  +--rw connectivity-category
       |  |  +--rw node*
       |  |  +--rw link*
       |  +--rw storage-category
       |  |  +--rw ram
       |  |  +--rw rom
       |  |  +--rw cache
       |  +--rw compute-category
       |     +--rw cpu
       |     +--rw gpu
       +--rw predefined-function-block
       |  +--rw sdn-controller
       |  +--rw firewall
       |  +--rw vswitch
       |  +--rw load-balancer
       +--rw service-profile
       |  +--rw qos-agreement*
       |  +--rw isolation-level?
       |  +--rw reliability-level?
       +--rw operation-management
          +--rw construction?
          +--rw monitoring?
          +--rw get-parameter?

Best regards,

Cristina QIANG

---

From: "qiangli (D)" <[email-masked]>
Date: Sat, 23 Sep 2017 03:48:18 +0000

I think you may want to have a look at RFC 3444 https://datatracker.ietf.org/doc/rfc3444/. What we are doing is information model not service model and data model.

Best regards,

Cristina QIANG

From: Qin Wu
Sent: Thursday, September 21, 2017 10:06 PM
To: Daniele Ceccarelli; qiangli (D); Susan Hares; [email-masked]
Subject: RE: [Netslices] a simple example of network slice template

-Qin
发件人: Netslices [mailto:[email-masked]] 代表 Daniele Ceccarelli
发送时间: 2017年9月21日 21:47
收件人: qiangli (D) <[email-masked]<mailto:[email-masked]>>; Susan Hares <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
主题: Re: [Netslices] a simple example of network slice template

Hi Cristina,

BR
Daniele

Hi Daniele,

Best regards,

Cristina QIANG

Hi Sue, Cristina,

BR
Daniele

Cristina:

Sue Hares

Hi All,

module: ns-template
    +--rw network-slice
       +--rw atomic-component

Best regards,

Cristina QIANG