Subject: [Netslices] a simple example of network slice template

From: "qiangli (D)" <[email-masked]>
Date: Wed, 20 Sep 2017 09:33:15 +0000

Hi All,

Following text is a simple example of network slice template. I would like to know what do you think about this kind of structure and design. Is this what you want?

module: ns-template
    +--rw network-slice
       +--rw atomic-component
       |  +--rw connectivity-category
       |  |  +--rw node*
       |  |  +--rw link*
       |  +--rw storage-category
       |  |  +--rw ram
       |  |  +--rw rom
       |  |  +--rw cache
       |  +--rw compute-category
       |     +--rw cpu
       |     +--rw gpu
       +--rw predefined-function-block
       |  +--rw sdn-controller
       |  +--rw firewall
       |  +--rw vswitch
       |  +--rw load-balancer
       +--rw service-profile
       |  +--rw qos-agreement*
       |  +--rw isolation-level?
       |  +--rw reliability-level?
       +--rw operation-management
          +--rw construction?
          +--rw monitoring?
          +--rw get-parameter?

Best regards,

Cristina QIANG

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 20 Sep 2017 06:51:12 -0400

Cristina:

Before I answer this question, have you looked at the TEAS work on the
underlay and compared It to this?  

Sue Hares

From: Netslices [mailto:[email-masked]] On Behalf Of qiangli (D)
Sent: Wednesday, September 20, 2017 5:33 AM
To: [email-masked]
Subject: [Netslices] a simple example of network slice template

Hi All,

Following text is a simple example of network slice template. I would like
to know what do you think about this kind of structure and design. Is this
what you want?

module: ns-template

    +--rw network-slice

       +--rw atomic-component

       |  |  +--rw node*

       |  |  +--rw link*

       |  +--rw storage-category

       |  |  +--rw ram

       |  |  +--rw rom

       |  |  +--rw cache

       |  +--rw compute-category

       |     +--rw cpu

       |     +--rw gpu

       |  +--rw sdn-controller

       |  +--rw firewall

       |  +--rw vswitch

       |  +--rw load-balancer

       +--rw service-profile

       |  +--rw qos-agreement*

       |  +--rw isolation-level?

          +--rw construction?

          +--rw monitoring?

          +--rw get-parameter?

Best regards,

Cristina QIANG

---

From: Daniele Ceccarelli <[email-masked]>
Date: Wed, 20 Sep 2017 11:45:22 +0000

Hi Sue, Cristina,

i suggest to start from this: https://tools.ietf.org/html/draft-lee-teas-actn-vn-yang-06 which is the yang model for the virtual network. It is derived from the info model (WG doc) https://tools.ietf.org/html/draft-ietf-teas-actn-info-model-02 .

Just to provide a further bit of info: on the MPI interface between the PNC (domain SDN controller) and the MDSC (hierarchical SDN controller/orchestrator) we use the TE tunnel and TE topology drafts because the VN is a concept exported by the MDSC towards the customer sitting on its NBI while between the MDSC and the PNC we preferred to keep on speaking about Tunnels and LSPs and not VNs. (also to make them understandable to legacy PNCs).

The VN is a concept defined over the CMI, namely the NBI of the MDSC and it looks like a good foundation for the transport part of the network slice (what you call connectivity category). It doesn't include what you call the storage/compute category and the VNF/SF. We're working on augmenting the TE topology with the latter.

BR
Daniele

From: Netslices [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: mercoledì 20 settembre 2017 12:51
To: 'qiangli (D)' <[email-masked]>; [email-masked]
Subject: Re: [Netslices] a simple example of network slice template

Cristina:

Before I answer this question, have you looked at the TEAS work on the underlay and compared It to this?

Sue Hares

From: Netslices [mailto:[email-masked]] On Behalf Of qiangli (D)
Sent: Wednesday, September 20, 2017 5:33 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Netslices] a simple example of network slice template

Hi All,

module: ns-template
    +--rw network-slice
       +--rw atomic-component

Best regards,

Cristina QIANG

---

From: GENG Liang <[email-masked]>
Date: Thu, 21 Sep 2017 01:30:07 +0000

Hi Cristina,

Thanks for your effort on organizing this template. According to the previous discussion (both in IETF99 BoF and offline with OPS ADs), I believe this is a very good starting point to visualize a "network slice".

I would also like to point out several additional consideration on the template
-A network slice tenant may want to provide explicit network topology information. This maybe considered as a attribute in "service profile"
-Pre-defined function blocks may very likely to be diversified. you may want to make the model extendable

Best wishes
Liang
________________________________
Liang GENG
China Mobile Research Institute

From: qiangli (D)<mailto:[email-masked]>
Date: 2017-09-20 17:33
To: [email-masked]<mailto:[email-masked]>
Subject: [Netslices] a simple example of network slice template
Hi All,

module: ns-template
    +--rw network-slice
       +--rw atomic-component

Best regards,

Cristina QIANG

---

From: "qiangli (D)" <[email-masked]>
Date: Thu, 21 Sep 2017 01:30:04 +0000

Hi Sue,

I have carefully studied TEAS's work before that. So what's your opinion?

Best regards,

Cristina QIANG

From: Susan Hares [mailto:[email-masked]]
Sent: Wednesday, September 20, 2017 6:51 PM
To: qiangli (D); [email-masked]
Subject: RE: [Netslices] a simple example of network slice template

Cristina:

Sue Hares

Hi All,

module: ns-template
    +--rw network-slice
       +--rw atomic-component

Best regards,

Cristina QIANG

---

From: "qiangli (D)" <[email-masked]>
Date: Thu, 21 Sep 2017 03:55:51 +0000

Hi Daniele,

I agree with your opinion that VN is a good foundation for the transport part of network slice ("connectivity category"). My major concern is how are you going to augment the TE topology with the "storage/compute categories" and "predefined-function-block" (include VNF/SF you mentioned) in our following design.  Take the "storage" as an example, are you going to add some "storage related attributes" to nodes OR consider some "storage related metrics" during path compute OR maybe both? If you only augment nodes, I can't see any meaning in TE scope. Then in the remaining two cases, your work in fact is connectivity enhancement. In a word, node in TE scope is forwarding node.

Network slice is a concept from resource perspective -- connectivity resources and storage resources can exist independently, they also can be bound together if necessary. An extreme example but easy going, a tenant just wants to buy some scattered storage units and a management unit, this is a slice but couldn't be called VN, right?

Best regards,

Cristina QIANG

From: Daniele Ceccarelli [mailto:[email-masked]]
Sent: Wednesday, September 20, 2017 7:45 PM
To: Susan Hares; qiangli (D); [email-masked]
Subject: RE: [Netslices] a simple example of network slice template

Hi Sue, Cristina,

BR
Daniele

From: Netslices [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: mercoledì 20 settembre 2017 12:51
To: 'qiangli (D)' <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Netslices] a simple example of network slice template

Cristina:

Sue Hares

Hi All,

module: ns-template
    +--rw network-slice
       +--rw atomic-component

Best regards,

Cristina QIANG

---

From: "qiangli (D)" <[email-masked]>
Date: Thu, 21 Sep 2017 07:39:43 +0000

Hi Liang,

Thank you for your comments. Adding a topology attribute to "service profile" for tenants/operators is really a good suggestion. For function block, I think maybe we can have two generation ways: pre-defined and on-demand. Some typical features could be packaged into pre-defined function blocks, and provide the "bind" operation to bind different atomic-components together on demand (e.g., bind a storage unit with a connectivity node).

Best regards,

Cristina QIANG

From: GENG Liang [mailto:[email-masked]]
Sent: Thursday, September 21, 2017 9:30 AM
To: qiangli (D); [email-masked]
Subject: Re: [Netslices] a simple example of network slice template

Hi Cristina,

Best wishes
Liang

module: ns-template
    +--rw network-slice
       +--rw atomic-component

Best regards,

Cristina QIANG

---

From: Thomas Nadeau <[email-masked]>
Date: Thu, 21 Sep 2017 07:38:57 -0400

It is worth documenting somewhere (even on the mailing list) why the TEAS work is insufficient
and justifies new work. 

	—Tom

> On Sep 20, 2017, at 9:30 PM, qiangli (D) <[email-masked]> wrote:
> 
> Hi Sue,
>  
> I have carefully studied TEAS’s work before that. So what’s your opinion?
>  
> Best regards,
>  
> Cristina QIANG
>  
> From: Susan Hares [mailto:[email-masked] <mailto:[email-masked]>] 
> To: qiangli (D); [email-masked] <mailto:[email-masked]>
> From: Netslices [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of qiangli (D)
> To: [email-masked] <mailto:[email-masked]>
> _______________________________________________
> Netslices mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/netslices <https://www.ietf.org/mailman/listinfo/netslices>

---

From: Daniele Ceccarelli <[email-masked]>
Date: Thu, 21 Sep 2017 13:46:54 +0000

Hi Cristina,

i think we need to define the scope of the work, i.e. are you targeting a customer service model, a service delivery model, network configuration model? I can agree that in the customer service model you might not want to know all the details of the network, even if knowing which nodes the NF/SF is attached to could be of some help, but for sure this info is needed from the service delivery model onwards.

BR
Daniele

From: Netslices [mailto:[email-masked]] On Behalf Of qiangli (D)
Sent: giovedì 21 settembre 2017 05:56
To: Daniele Ceccarelli <[email-masked]>; Susan Hares <[email-masked]>; [email-masked]
Subject: Re: [Netslices] a simple example of network slice template

Hi Daniele,

Best regards,

Cristina QIANG

From: Daniele Ceccarelli [mailto:[email-masked]]
Sent: Wednesday, September 20, 2017 7:45 PM
To: Susan Hares; qiangli (D); [email-masked]<mailto:[email-masked]>
Subject: RE: [Netslices] a simple example of network slice template

Hi Sue, Cristina,

BR
Daniele

Cristina:

Sue Hares

Hi All,

module: ns-template
    +--rw network-slice
       +--rw atomic-component

Best regards,

Cristina QIANG

---

From: GENG Liang <[email-masked]>
Date: Fri, 22 Sep 2017 00:56:15 +0000

Hi Daniele,

I have been following recent ACTN framework updates towards network slicing concept. I agree NBI of the MDSC in ACTN is a great example of how one can describe the connectivity resources in transport part of the network slice.

However, I see MDSC as one of the many controllers a transport domain slice manager may need to cooperate. For example, many connectivity resources may not be managed/controlled as ACTN-aware. This includes EMS for legacy network for even distributed control plane.

Meanwhile, I am not sure how computing, storage and other non-TE elements relates to ACTN since ACTN exclusively deals with Virtual Network,  which is a tunnel (connectivity). Those components described in network slice template closely relates to orchestration and NFV, which expects an SBI to MANO-like system. Similarly, ACTN virtual network yang models can also be used as on of the SBI reference from the network slice manager for connectivity components that are ACTN-aware.

From: Daniele Ceccarelli<mailto:[email-masked]>
Date: 2017-09-20 19:45
To: Susan Hares<mailto:[email-masked]>; 'qiangli (D)'<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Netslices] a simple example of network slice template
Hi Sue, Cristina,

The VN is a concept defined over the CMI, namely the NBI of the MDSC and it looks like a good foundation for the transport part of the network slice (what you call connectivity category). It doesn’t include what you call the storage/compute category and the VNF/SF. We’re working on augmenting the TE topology with the latter.

BR
Daniele

Cristina:

Sue Hares

Hi All,

module: ns-template
    +--rw network-slice
       +--rw atomic-component

Best regards,

Cristina QIANG

---

From: Sheng Jiang <[email-masked]>
Date: Fri, 22 Sep 2017 09:34:59 +0000

Hi, Cristina,

Thanks for kick of the discussion and provide the primary design of the network slice template. The first level of abstract (atomic-component, predefined-function-block, service-profile, operation-management) looks good for me. I have a couple of technical comments for now.

First, whether there are some slicing level performance/status properties (if yes, it means you missed something in the first level of abstract). My guess is you do have the performance/status properties attached with certain atomic-component, such as bandwidth occupancy on node or link. But, overall, you may need some properties to reflect the bandwidth occupancy for a slice as a whole.

Secondly, I am not sure about these sub items of storage and compute. We are doing a common template in order to separate the details from physical resources or specific supporting technologies. But the current design of these sub items of storage and compute looks like based on the nature of physical types. The upper-layer customers/administrator may not care about whether the storage is ram or rom unless they make differencies on the service they receive. It seems not be a good abstracting mechanism. The same for cpu and cpu.

Regards,

Sheng

From: Netslices [mailto:[email-masked]] On Behalf Of qiangli (D)
Sent: Wednesday, September 20, 2017 5:33 PM
To: [email-masked]
Subject: [Netslices] a simple example of network slice template

Hi All,

module: ns-template
    +--rw network-slice
       +--rw atomic-component

Best regards,

Cristina QIANG

---

From: Daniele Ceccarelli <[email-masked]>
Date: Fri, 22 Sep 2017 10:08:52 +0000

Hi Liang,

legacy EMS can be used as PNCs in an ACTN hierarchy provided they export an ACTN interface on their northbound. If you need to upgrade them to support newly defined models for network slicing and then manage them separately isn’t it more efficient to upgrade them to support an ACTN interfce and control everything with the same MDSC?

BR
Daniele

From: Netslices [mailto:[email-masked]] On Behalf Of GENG Liang
Sent: venerdì 22 settembre 2017 02:56
To: Daniele Ceccarelli <[email-masked]>; Susan Hares <[email-masked]>; 'qiangli (D)' <[email-masked]>; [email-masked]
Subject: [Suspected Spam] Re: [Netslices] a simple example of network slice template

Hi Daniele,

BR
Daniele

Cristina:

Sue Hares

Hi All,

module: ns-template
    +--rw network-slice
       +--rw atomic-component

Best regards,

Cristina QIANG

---

From: "qiangli (D)" <[email-masked]>
Date: Sat, 23 Sep 2017 03:38:26 +0000

Hi Daniele,

We are doing information model, a common and technical independent way to describe a network slice, neither customer service model, nor service delivery mode, nor network configuration model.
A reference here "On the Difference between Information Models and Data Models" https://datatracker.ietf.org/doc/rfc3444/

Best regards,

Cristina QIANG

From: Netslices [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, September 21, 2017 9:47 PM
To: qiangli (D); Susan Hares; [email-masked]
Subject: Re: [Netslices] a simple example of network slice template

Hi Cristina,

BR
Daniele

From: Netslices [mailto:[email-masked]] On Behalf Of qiangli (D)
Sent: giovedì 21 settembre 2017 05:56
To: Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>; Susan Hares <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Netslices] a simple example of network slice template

Hi Daniele,

Best regards,

Cristina QIANG

Hi Sue, Cristina,

BR
Daniele

Cristina:

Sue Hares

Hi All,

module: ns-template
    +--rw network-slice
       +--rw atomic-component

Best regards,

Cristina QIANG

---

From: "qiangli (D)" <[email-masked]>
Date: Sat, 23 Sep 2017 06:37:07 +0000

I just do some technical clarifications here, not target any techonoogy:

1. please try to understand network slicing from resource perspective;

2. there are kinds of resources in networ slice – connectivity, storage, compute;

3. different resources could exist and operated seperately, and also can combine with each other;

4. an example — a set of routers and connected together by cables – this is a network slice in some sense (resources) – you still need to break the ring, configure address before you can use these resources (implementation) – there are several available implemantation technologies like IP, ATM, token ring, FDDI.. (implemenation technology)

5. network slice information model just descibes the network slice not defines any implmentation details. Information model is a common thing, will not and should not bind to any specific technologies;

Best regards,

Cristina QIANG

From: Thomas Nadeau [mailto:[email-masked]]
Sent: Thursday, September 21, 2017 7:39 PM
To: qiangli (D)
Cc: Susan Hares; [email-masked]
Subject: Re: [Netslices] a simple example of network slice template

    —Tom

On Sep 20, 2017, at 9:30 PM, qiangli (D) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Sue,

Best regards,

Cristina QIANG

From: Susan Hares [mailto:[email-masked]]
Sent: Wednesday, September 20, 2017 6:51 PM
To: qiangli (D); [email-masked]<mailto:[email-masked]>
Subject: RE: [Netslices] a simple example of network slice template

Cristina:

Sue Hares

Hi All,

module: ns-template
    +--rw network-slice
       +--rw atomic-component

Best regards,

Cristina QIANG

_______________________________________________
Netslices mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netslices

---

From: "qiangli (D)" <[email-masked]>
Date: Sat, 23 Sep 2017 07:41:39 +0000

Hi Sheng,

Thank you for your comments:

Current design only considers performance/status properties in component level. You're right, there does need some slicing level status properties. Except for bandwidth, latency, jitter, is there any other metrics worth to be considered?

I think maybe the storage unit could be abstracted from the "size", "read-write-mode", "shared/dedicated" aspects, or do you have other suggestions? We are open to revise the design according to feedbacks.

Best regards,

Cristina QIANG

From: Sheng Jiang
Sent: Friday, September 22, 2017 5:35 PM
To: qiangli (D); [email-masked]
Subject: RE: a simple example of network slice template

Hi, Cristina,

Regards,

Sheng

Hi All,

module: ns-template
    +--rw network-slice
       +--rw atomic-component

Best regards,

Cristina QIANG

---

From: GENG Liang <[email-masked]>
Date: Mon, 25 Sep 2017 07:16:12 +0000

Hi Daniele,

Yes, I agree if everything is ACTN-interface-aware, the most straight-forward solution is to use MDSC for connectivity slicing.

However there are brown field systems which are not able to upgrade to fully support ACTN model. In this case, the NBI of this system may keep evolving as is and the network slice manager also need to talk to them. A common information model for network slicing can be used to map the slice-level description to the legacy interface in a best-effort manner. At the moment, we think it is to risky to exclude all non-ACTN-aware system out of network slicing.

At the same time, network slicing is more than connectivity. As the common information model is going to be discussed further, more components may be continuously involved beyond computing and storage. The slice manager need to integrate systems more than just connectivity domain.

From: Daniele Ceccarelli<mailto:[email-masked]>
Date: 2017-09-22 18:08
To: GENG Liang<mailto:[email-masked]>; Susan Hares<mailto:[email-masked]>; 'qiangli (D)'<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: Re: [Netslices] a simple example of network slice template
Hi Liang,

BR
Daniele

Hi Daniele,

BR
Daniele

Cristina:

Sue Hares

Hi All,

module: ns-template
    +--rw network-slice
       +--rw atomic-component

Best regards,

Cristina QIANG

---

From: Daniele Ceccarelli <[email-masked]>
Date: Mon, 25 Sep 2017 12:26:05 +0000

Cristina,

it's not just the way an information is encoded (data model) that changes depending on the consumer of the information, it is also the type of information (info model).

The pieces of information available at a node, at an SDN controller or exposed to a customer are totally different from each other.

BR
Daniele

From: qiangli (D) [mailto:[email-masked]]
Sent: sabato 23 settembre 2017 05:38
To: Daniele Ceccarelli <[email-masked]>; Susan Hares <[email-masked]>; [email-masked]
Subject: RE: [Netslices] a simple example of network slice template

Hi Daniele,

Best regards,

Cristina QIANG

From: Netslices [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, September 21, 2017 9:47 PM
To: qiangli (D); Susan Hares; [email-masked]<mailto:[email-masked]>
Subject: Re: [Netslices] a simple example of network slice template

Hi Cristina,

BR
Daniele

Hi Daniele,

Best regards,

Cristina QIANG

Hi Sue, Cristina,

BR
Daniele

Cristina:

Sue Hares

Hi All,

module: ns-template
    +--rw network-slice
       +--rw atomic-component

Best regards,

Cristina QIANG

---

From: "Kiran.Makhijani" <[email-masked]>
Date: Tue, 26 Sep 2017 01:02:48 +0000

Hello Daniele, 
To my understanding - I think, Cristina is alluding to an abstract information model, which is just above (or is logical) network configuration model and takes input from service delivery model. Through this model, network controllers choose what physical resources should they map southbound (in TE or non-TE manner, incl. SFs etc.). 

At first, it is important to focus on what a complete network slice will look like and all resource descriptions it need. It may be perfectly ok that a part or whole of it could be similar to what ACTN VN does in a domain. Other non-IP or non-ACTN networks could also bind to same info model. In https://www.ietf.org/id/draft-qiang-coms-netslicing-information-model-00.txt, it is quite explicit, what resource descriptions make a slice, easy to visualize a slice. It needs more elements & operations but is a good discussion starter.

Regards
-Kiran

From: Netslices <[email-masked]> on behalf of Daniele Ceccarelli <[email-masked]>
Date: Monday, September 25, 2017 at 5:26 AM
To: "qiangli (D)" <[email-masked]>, Susan Hares <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Netslices] a simple example of network slice template

Cristina,
 
it’s not just the way an information is encoded (data model) that changes depending on the consumer of the information, it is also the type of information (info model). 

BR
Daniele  

Hi Daniele,
 
We are doing information model, a common and technical independent way to describe a network slice, neither customer service model, nor service delivery mode, nor network configuration model.  
A reference here “On the Difference between Information Models and Data Models” https://datatracker.ietf.org/doc/rfc3444/
 
Best regards,
 
Cristina QIANG

Hi Cristina,

BR
Daniele  

Hi Daniele,
 
I agree with your opinion that VN is a good foundation for the transport part of network slice (“connectivity category”). My major concern is how are you going to augment the TE topology with the “storage/compute categories” and “predefined-function-block” (include VNF/SF you mentioned) in our following design.  Take the “storage” as an example, are you going to add some “storage related attributes” to nodes OR consider some “storage related metrics” during path compute OR maybe both? If you only augment nodes, I can’t see any meaning in TE scope. Then in the remaining two cases, your work in fact is connectivity enhancement. In a word, node in TE scope is forwarding node. 
 
Network slice is a concept from resource perspective -- connectivity resources and storage resources can exist independently, they also can be bound together if necessary. An extreme example but easy going, a tenant just wants to buy some scattered storage units and a management unit, this is a slice but couldn’t be called VN, right? 

Best regards,
 
Cristina QIANG

Hi Sue, Cristina,

 
 
BR
Daniele  

Cristina:

Sue Hares

Hi All,

module: ns-template
    +--rw network-slice
       +--rw atomic-component
 
Best regards,
 
Cristina QIANG

---

From: GENG Liang <[email-masked]>
Date: Fri, 29 Sep 2017 01:55:20 +0000

Hi Sheng,

Thanks for your comments.

The motivation on computing and storage is probably not something you are imagine. Let me try to give some examples.

A NSP would like to host a online gaming service within a slice. Besides the connectivity request which may consist of many VPNs, it may ask for cloud services to host gaming applications/proxies/agent, which requests for computing and storage resources. This resources may be presented as bare metal requests or VM requests.

Another example is an NSP requesting intra-slice SDN controller, which is a software entity. The required system resources scales with the size of the connectivity topology of the slice. This need to be described in the slice template as well.

I hope this make sense.

Best wishes,
Liang

From: qiangli (D)<mailto:[email-masked]>
Date: 2017-09-23 15:41
To: Sheng Jiang<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Netslices] a simple example of network slice template
Hi Sheng,

Current design only considers performance/status properties in component level. You’re right, there does need some slicing level status properties. Except for bandwidth, latency, jitter, is there any other metrics worth to be considered?

I think maybe the storage unit could be abstracted from the “size”, “read-write-mode”, “shared/dedicated” aspects, or do you have other suggestions? We are open to revise the design according to feedbacks.

Best regards,

Cristina QIANG

From: Sheng Jiang

Hi, Cristina,

Regards,

Sheng

Hi All,

module: ns-template
    +--rw network-slice
       +--rw atomic-component

Best regards,

Cristina QIANG

---

From: Sheng Jiang <[email-masked]>
Date: Sat, 30 Sep 2017 10:08:15 +0000

Hi, Liang,

I believe we were talking about something very similar but with slightly different vision. There are two types of computing and storage in the network (cloud services may out of scope if there are not run by network operators): a) computing and storage on the router or forwarding devices; b) computing and storage on the in-network services, such as MEC and data center run by ISP. Both are possible resources for slice, although the second may not always be available. As a common template, we should cover as much as possible potentials.

Cheers,

Sheng

From: GENG Liang [mailto:[email-masked]]
Sent: Friday, September 29, 2017 9:55 AM
To: qiangli (D) <[email-masked]>; Sheng Jiang <[email-masked]>; [email-masked]
Subject: Re: Re: [Netslices] a simple example of network slice template

Hi Sheng,

I hope this make sense.

Best wishes,
Liang

Best regards,

Cristina QIANG

From: Sheng Jiang

Hi, Cristina,

Regards,

Sheng

Hi All,

module: ns-template
    +--rw network-slice
       +--rw atomic-component

Best regards,

Cristina QIANG