Subject: [Netslices] COMS: What next?

From: Alexander Vainshtein <[email-masked]>
Date: Sun, 6 May 2018 14:37:04 +0000

Adrian and Gonzalo hi!
My colleagues and I wonder what (if any) are the expected next steps of the COMS BOF.
The status of this BOF at IETF-101 was Non-WG-forming.
My personal impression from reading the drafts and looking at the presentation at the session is that there is
Are there any plans to hold yet another session at IETF-102 in Montreal? To progress this BOF to a WG? Or simply to pass this subject to some other SDO?

Your feedback will be highly appreciated.

Regards, and lots of thanks in advance,
Sasha

Office: +972-39266302
Cell:      +972-549266302
Email:   [email-masked]

___________________________________________________________________________

This e-mail message is intended for the recipient only and contains information which is 
CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this 
transmission in error, please inform us by e-mail, phone or fax, and then delete the original 
and all copies thereof.
___________________________________________________________________________

---

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 6 May 2018 23:31:50 +0100

Hi Sasha,

> The status of this BOF at IETF-101 was Non-WG-forming. 

Right. The objectives were to get more focus and find answers to the questions
that the ADs had posed.

> My personal impression from reading the drafts and looking
> at the presentation at the session is that there is 

Oooh, you do know how to tantalise your audience, don't you?

Or possibly this is a competition and you will be awarding prizes for the best
completion of you sentence. ;-)

> Are there any plans to hold yet another session at IETF-102 in Montreal?
> To progress this BOF to a WG? Or simply to pass this subject to some other
> SDO?

You're asking the question on the right mailing list. But I have heard no plans
and have not seen anything recent in the IETF that seems like progress.

Maybe others will have something to say.

Cheers,
Adrian
--
Support an author and your imagination
Tales from the Wood - Eighteen new fairy tales
More Tales from the Wood - Eighteen MORE new fairy tales
Tales from Beyond the Wood - A bumper collection of twenty-two new tales
https://www.feedaread.com/profiles/8604/
http://www.amazon.co.uk/Tales-Wood-Adrian-Farrel/dp/1786100924
Or buy from me direct.

---

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 7 May 2018 09:45:29 +0300

Hi,

> Maybe others will have something to say.

In particular, at this point what to do next is up to the OPS ADs, who
are conveniently cc:ed.

Cheers,

Gonzalo

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 8 May 2018 08:16:26 +0000

Adrian,
Lots of thanks for a prompt response and sincere apologies for sending out an incomplete email.

The completion of the sentence that has puzzled you should be something like:

" My personal impression from reading the drafts and looking at the  presentation at the session is that there is certain similarity between the Service Delivery Interface (SDI) mentioned there and the YANG data models for L3/L2VPN services. Developing a YANG data model for network slices as services (NSaaS) therefore looks like a reasonable objective for a dedicated IETF WG to me".

Hopefully this clarifies my original question.

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]] 
Sent: Monday, May 7, 2018 1:32 AM
To: Alexander Vainshtein <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Netslices] COMS: What next?

Hi Sasha,

> The status of this BOF at IETF-101 was Non-WG-forming. 

Right. The objectives were to get more focus and find answers to the questions that the ADs had posed.

> My personal impression from reading the drafts and looking at the 
> presentation at the session is that there is

Or possibly this is a competition and you will be awarding prizes for the best completion of you sentence. ;-)

> To progress this BOF to a WG? Or simply to pass this subject to some 
> other SDO?

You're asking the question on the right mailing list. But I have heard no plans and have not seen anything recent in the IETF that seems like progress.

Cheers,
Adrian
--
Support an author and your imagination
Tales from the Wood - Eighteen new fairy tales More Tales from the Wood - Eighteen MORE new fairy tales Tales from Beyond the Wood - A bumper collection of twenty-two new tales http://webdefence.global.blackspider.com/urlwrap/?q=AXicHcqxDcIwEAXQ31GziG2RKAQq6GhoQ0Fl4otiybGj8wmHPVgIiRmYB0H93nqF6wd4vgEOD9PeVOa7mqwPfYrCKag-TSh1c-7kcjLVZldtcQy02OiIVWd9zKOQjwfqvVCg_x9F5rzXupSiBiJnmaz7iZ45DT5Q1m1jag1geQFflGksFQ&Z
http://www.amazon.co.uk/Tales-Wood-Adrian-Farrel/dp/1786100924
Or buy from me direct.

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 8 May 2018 08:18:00 +0000

Gonzalo,
Lots of thanks for a prompt response, and apologies for sending an incomplete email.

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302

-----Original Message-----
From: Gonzalo Camarillo [mailto:[email-masked]] 
Sent: Monday, May 7, 2018 9:45 AM
To: [email-masked]; Alexander Vainshtein <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Netslices] COMS: What next?

Hi,

> You're asking the question on the right mailing list. But I have heard 
> no plans and have not seen anything recent in the IETF that seems like progress.
> 

In particular, at this point what to do next is up to the OPS ADs, who are conveniently cc:ed.

Cheers,

Gonzalo

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 8 May 2018 09:51:30 +0100

Yes, and without pretending to speak for the whole room in London, there were
some observations made that L2SM and L3SM were "primitive" forms of slicing, and
that ACTN (see TEAS WG) constructs virtual networks over underlying transport
networks and is also slicing.

Some people, thus, are in agreement with you. Other,  I think, believe that the
problem space is larger and more complex.

A

> From: Alexander Vainshtein [mailto:[email-masked]]
> Sent: 08 May 2018 09:16
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> " My personal impression from reading the drafts and looking at the
> presentation at the session is that there is certain similarity between the
Service
> Delivery Interface (SDI) mentioned there and the YANG data models for
> L3/L2VPN services. Developing a YANG data model for network slices as services
> (NSaaS) therefore looks like a reasonable objective for a dedicated IETF WG to
> me".
> 
> You're asking the question on the right mailing list. But I have heard no
plans and
> have not seen anything recent in the IETF that seems like progress.
> 
> Tales from the Wood - Eighteen new fairy tales More Tales from the Wood -
> Eighteen MORE new fairy tales Tales from Beyond the Wood - A bumper
> collection of twenty-two new tales
> http://webdefence.global.blackspider.com/urlwrap/?q=AXicHcqxDcIwEAXQ31Gz
> iG2RKAQq6GhoQ0Fl4otiybGj8wmHPVgIiRmYB0H93nqF6wd4vgEOD9PeVOa7mqw
> PfYrCKag-TSh1c-
> 7kcjLVZldtcQy02OiIVWd9zKOQjwfqvVCg_x9F5rzXupSiBiJnmaz7iZ45DT5Q1m1jag1
> geQFflGksFQ&Z
> This e-mail message is intended for the recipient only and contains
information
> which is
> transmission in error, please inform us by e-mail, phone or fax, and then
delete
> the original

---

From: Alex Galis <[email-masked]>
Date: Tue, 8 May 2018 13:21:37 +0100

Hi Adrian

On one hand you statement that L2SM, L3SM and ACTN are "primitive" forms of slicing may be correct if you define what a primitive is and how could be used and managed.

On the other hand  L2SM, L3SM and ACTN/ virtual nets would be consider as slices or slice enablers if they can provide dynamic resource partition supporting a very large variety of service requirements per partition ( i.e. range from low latency service to high bandwidth service to defined QoS based services to ...)

In my view L2SM, L3SM, ACTN  and other L2/L3 technologies (i.e. VPN, IPV6 segment routing, etc) would be useful technology in the activation in a domain of a network slice but they are not necessarily ‘slices’.

As presented in London the COMS related work activities cannot be just reduced to L2SM, L3SM, ACTN or to operations  (i.e. operations on IPV6) on existing networking systems.

I support Sasha’s statement that "network slices as service (NSaaS) therefore looks like a reasonable objective for a dedicated IETF WG”

Best Regrards
Alex

> On 8 May 2018, at 9:51 AM, Adrian Farrel <[email-masked]> wrote:
> 
> _______________________________________________
> Netslices mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netslices

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 8 May 2018 12:36:28 +0000

Adrian,
Lots of thanks for an extra-prompt response.

Not sure if this helps, but I think that a bird in the hand is worth two in the bush.
No offence intended but, from my POV, going for something " larger and more complex " - but also quite vague - does not look as the right way to me.
Not to mention that some of this "larger and more complex" probably would include lots of things that IETF would not like to deal with claiming lack of expertise.

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]] 
Sent: Tuesday, May 8, 2018 11:52 AM
To: Alexander Vainshtein <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [Netslices] COMS: What next?

Yes, and without pretending to speak for the whole room in London, there were some observations made that L2SM and L3SM were "primitive" forms of slicing, and that ACTN (see TEAS WG) constructs virtual networks over underlying transport networks and is also slicing.

Some people, thus, are in agreement with you. Other,  I think, believe that the problem space is larger and more complex.

A

Service
> (NSaaS) therefore looks like a reasonable objective for a dedicated 
> IETF WG to me".
> 
> To: Alexander Vainshtein <[email-masked]>; 
> netslicing- [email-masked]
> no
plans and
> Support an author and your imagination Tales from the Wood - Eighteen 
> new fairy tales More Tales from the Wood - Eighteen MORE new fairy 
> tales Tales from Beyond the Wood - A bumper collection of twenty-two 
> new tales 
> http://webdefence.global.blackspider.com/urlwrap/?q=AXicHcqxDcIwEAXQ31
> Gz iG2RKAQq6GhoQ0Fl4otiybGj8wmHPVgIiRmYB0H93nqF6wd4vgEOD9PeVOa7mqw
> PfYrCKag-TSh1c-
information
> which is
> CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have 
> received this transmission in error, please inform us by e-mail, phone 
> or fax, and then
delete

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 8 May 2018 13:08:23 +0000

Alex,

Lots of thanks for a prompt response.

I would like to clarify my position regarding network slicing:

1.       I am not sure if L2/L3VPN are "primitive" network slices.

a.       Rather, I see network slices as both services (provided by the Slice Provider to a Slice Tenant) and virtual networks in their own right  (that could be used by the Slice Tenants to provide L2/L3VPN services to their customers).

b.       I think that this matches (more or less and notwithstanding some terminology differences) the approach to network virtualization taken by ITU-T in Recommendations Y.3011 and Y.1312

c.       Calling a L2/L3VPN service instance a “primitive” slice on top of which exactly one service is instantiated looks an exaggeration to me.

2.       The dualistic approach to network slices  mentioned above affects many aspects of networking:

a.       Some of these aspects are already handled (to some extent) by various IETF WGs. E.g., I think that SPRING WG work on Segment Routing (SR) may be highly relevant for network slicing because it facilitates setup of intra-slice traffic-engineered paths by the Slice Tenants without adding CP and DP state for these paths in transit nodes crossed by these paths and without any per-TE path interaction with the Slice Provider. I believe that this matches the approach presented in the Enhanced VPN<https://tools.ietf.org/html/draft-bryant-rtgwg-enhanced-vpn-02> draft

b.       Some of these aspects are not, to the best of my knowledge, handled by the existing IETF WGs.

                                                               i.      One of these is the YANG data model for Network Slice as a Service I have mentioned as a reasonable objective for a yet-to-be-created WG

                                                             ii.      Such a model could reuse some elements of the L2/L3VPN service data models, e.g., the some of the parameters that describe interconnection between the “slice tenant edge” devices and edge devices of its customers

3.       There are also some aspects of network slicing that should be left out of scope of the IETF work.

Not sure if this helps.

Regards,

Sasha

Office: +972-39266302

Cell:      +972-549266302

-----Original Message-----
From: Alex Galis [mailto:[email-masked]]
Sent: Tuesday, May 8, 2018 3:22 PM
To: Adrian Farrel <[email-masked]>
Cc: Alexander Vainshtein <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Netslices] COMS: What next?

Hi Adrian

Best Regrards

Alex

> On 8 May 2018, at 9:51 AM, Adrian Farrel <[email-masked]<mailto:[email-masked]>> wrote:

> Yes, and without pretending to speak for the whole room in London,

> there were some observations made that L2SM and L3SM were "primitive"

> forms of slicing, and that ACTN (see TEAS WG) constructs virtual

> networks over underlying transport networks and is also slicing.

> Some people, thus, are in agreement with you. Other,  I think, believe

> that the problem space is larger and more complex.

>> To: [email-masked]<mailto:[email-masked]>

>> Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

>> Lots of thanks for a prompt response and sincere apologies for

>> sending out an incomplete email.

>> presentation at the session is that there is certain similarity

>> between the

>> L3/L2VPN services. Developing a YANG data model for network slices as

>> services

>> Email:   [email-masked]<mailto:[email-masked]>

>> To: Alexander Vainshtein <[email-masked]<mailto:[email-masked]>>;

>> netslicing- [email-masked]<mailto:[email-masked]>

>> Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

>>> My colleagues and I wonder what (if any) are the expected next steps

>>> of the COMS BOF.

>> Right. The objectives were to get more focus and find answers to the

>> questions that the ADs had posed.

>> Or possibly this is a competition and you will be awarding prizes for

>> the best completion of you sentence. ;-)

>> You're asking the question on the right mailing list. But I have

>> heard no

>> http://webdefence.global.blackspider.com/urlwrap/?q=AXicHcqxDcIwEAXQ3

>> 1Gz iG2RKAQq6GhoQ0Fl4otiybGj8wmHPVgIiRmYB0H93nqF6wd4vgEOD9PeVOa7mqw

>> ______________________________________________________________

>> _____________

>> received this transmission in error, please inform us by e-mail,

>> phone or fax, and then

>> ______________________________________________________________

>> _____________

> [email-masked]<mailto:[email-masked]>

---

From: Daniele Ceccarelli <[email-masked]>
Date: Tue, 8 May 2018 22:35:48 +0000

Hi Alex,

> On the other hand  L2SM, L3SM and ACTN/ virtual nets would be consider as
> slices or slice enablers if they can provide dynamic resource partition
> supporting a very large variety of service requirements per partition ( i.e.
> range from low latency service to high bandwidth service to defined QoS
> based services to ...)

Actually they do. There is a wide plethora of TE constraints that can be defined/asked for when setting up an ACTN VN. Such constraints are inherited by the L2VPN, L3VPN when bound to the VN. 

BR
Daniele  

> From: Netslices [mailto:[email-masked]] On Behalf Of Alex Galis
> Sent: martedì 8 maggio 2018 14:22
> Cc: Alexander Vainshtein <[email-masked]>;
> [email-masked]; [email-masked]; [email-masked]
> On one hand you statement that L2SM, L3SM and ACTN are "primitive" forms
> of slicing may be correct if you define what a primitive is and how could be
> used and managed.
> 
> On the other hand  L2SM, L3SM and ACTN/ virtual nets would be consider as
> slices or slice enablers if they can provide dynamic resource partition
> supporting a very large variety of service requirements per partition ( i.e.
> range from low latency service to high bandwidth service to defined QoS
> based services to ...)
> 
> In my view L2SM, L3SM, ACTN  and other L2/L3 technologies (i.e. VPN, IPV6
> segment routing, etc) would be useful technology in the activation in a
> domain of a network slice but they are not necessarily ‘slices’.
> 
> As presented in London the COMS related work activities cannot be just
> reduced to L2SM, L3SM, ACTN or to operations  (i.e. operations on IPV6) on
> existing networking systems.
> 
> I support Sasha’s statement that "network slices as service (NSaaS) therefore
> looks like a reasonable objective for a dedicated IETF WG”
> 
> Best Regrards
> Alex
> 
> 
> 
> >> 1Gz

---

From: Daniele Ceccarelli <[email-masked]>
Date: Tue, 8 May 2018 22:40:12 +0000

Hi Sasha,

you said:

     *   Some of these aspects are not, to the best of my knowledge, handled by the existing IETF WGs.

TEAS WG is working on the YANG model for ACTN VNS, where the VN is offered as a service ( https://tools.ietf.org/id/draft-lee-teas-actn-vn-yang-12.txt ) as well as a model to map a L3/L2/L1 service to a given VN (https://tools.ietf.org/id/draft-lee-teas-te-service-mapping-yang-07.txt ). Is this what you’re looking for?

BR
Daniele

From: Netslices [mailto:[email-masked]] On Behalf Of Alexander Vainshtein
Sent: martedì 8 maggio 2018 15:08
To: Alex Galis <[email-masked]>
Cc: Adrian Farrel <[email-masked]>; Stewart Bryant <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Netslices] COMS: What next?

Alex,

  1.  I am not sure if L2/L3VPN are "primitive" network slices.
     *   Rather, I see network slices as both services (provided by the Slice Provider to a Slice Tenant) and virtual networks in their own right  (that could be used by the Slice Tenants to provide L2/L3VPN services to their customers).
     *   I think that this matches (more or less and notwithstanding some terminology differences) the approach to network virtualization taken by ITU-T in Recommendations Y.3011 and Y.1312
     *   Calling a L2/L3VPN service instance a “primitive” slice on top of which exactly one service is instantiated looks an exaggeration to me.
  2.  The dualistic approach to network slices  mentioned above affects many aspects of networking:
     *   Some of these aspects are already handled (to some extent) by various IETF WGs. E.g., I think that SPRING WG work on Segment Routing (SR) may be highly relevant for network slicing because it facilitates setup of intra-slice traffic-engineered paths by the Slice Tenants without adding CP and DP state for these paths in transit nodes crossed by these paths and without any per-TE path interaction with the Slice Provider. I believe that this matches the approach presented in the Enhanced VPN<https://tools.ietf.org/html/draft-bryant-rtgwg-enhanced-vpn-02> draft
     *   Some of these aspects are not, to the best of my knowledge, handled by the existing IETF WGs.

  1.  There are also some aspects of network slicing that should be left out of scope of the IETF work.

Not sure if this helps.

Regards,

Sasha

Office: +972-39266302

Cell:      +972-549266302

-----Original Message-----
From: Alex Galis [mailto:[email-masked]]
Sent: Tuesday, May 8, 2018 3:22 PM
To: Adrian Farrel <[email-masked]<mailto:[email-masked]>>
Cc: Alexander Vainshtein <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Netslices] COMS: What next?

Hi Adrian

Best Regrards

Alex

---

From: Qin Wu <[email-masked]>
Date: Wed, 9 May 2018 00:59:13 +0000

[Qin]: To have a clear whole picture of relevant aspects associated with model driven management, please read the initial version of survey and architecture document:

https://tools.ietf.org/html/draft-wu-model-driven-management-virtualization-00

Talking with TEAS WG experts, we believe additional TE related work need to be covered.

Not sure if this helps.

Regards,

Sasha

Office: +972-39266302

Cell:      +972-549266302

-----Original Message-----
From: Alex Galis [mailto:[email-masked]]
Sent: Tuesday, May 8, 2018 3:22 PM
To: Adrian Farrel <[email-masked]<mailto:[email-masked]>>
Cc: Alexander Vainshtein <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Netslices] COMS: What next?

Hi Adrian

Best Regrards

Alex

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Wed, 9 May 2018 07:28:49 +0000

Hi Sasha,

Yes some aspects of network slicing are currently handled by existing IETF WGs. The enhanced VPN draft you mentioned aims to provide a layered framework and the candidate technology components. Based on the discussion in RTGWG on last IETF meeting, this draft will be moved to TEAS WG to move forward.

And I totally agree that segment routing in SPRING WG is relevant due to the advantages you mentioned, while some enhancement may be needed to achieve the required isolation between network slices. Currently there is another draft which describes the mechanism of using SR for enhanced VPNs: https://tools.ietf.org/html/draft-dong-spring-sr-for-enhanced-vpn-00

Best regards,
Jie

Sent: Tuesday, May 08, 2018 9:08 PM

Alex,

Not sure if this helps.

Regards,

Sasha

Office: +972-39266302

Cell:      +972-549266302

-----Original Message-----
From: Alex Galis [mailto:[email-masked]]
Sent: Tuesday, May 8, 2018 3:22 PM
To: Adrian Farrel <[email-masked]<mailto:[email-masked]>>
Cc: Alexander Vainshtein <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Netslices] COMS: What next?

Hi Adrian

Best Regrards

Alex

---

From: Kiran.Makhijani <[email-masked]>
Date: Wed, 9 May 2018 14:33:46 +0000

a.       Calling a L2/L3VPN service instance a “primitive” slice on top of which exactly one service is instantiated looks an exaggeration to me.
I too agree that slices be not generalized as L@/L3VPN service instances. It is also an over simplification.
Instead, we should consider a slice as a service graph of any kind. And why it must be a VPN in the traditional sense of L2/L3VPN. It can also be stitching of paths across transit-edges (discussed in draft-defoy-coms-subnet-interconnection) without any explicit end to end tunnel. I see a slice can combination of SR in one domain + ACTN tunnel in another since each technology will compute and operate path constraints separately.

But I am not sure why there should be no CP or DP state? It is absolutely necessary because of the dynamic nature of slice operation management because as you say a slice is a network in its own right and should have and interface to be managed by the tenant.

-Kiran
From: Netslices <[email-masked]> on behalf of Alexander Vainshtein <[email-masked]>
Date: Tuesday, May 8, 2018 at 6:09 AM
To: "a.galis" <[email-masked]>
Cc: Adrian Farrel <[email-masked]>, "stewart.bryant" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Netslices] COMS: What next?

Alex,

Not sure if this helps.

Regards,

Sasha

Office: +972-39266302

Cell:      +972-549266302

-----Original Message-----
From: Alex Galis [mailto:[email-masked]]
Sent: Tuesday, May 8, 2018 3:22 PM
To: Adrian Farrel <[email-masked]>
Cc: Alexander Vainshtein <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Netslices] COMS: What next?

Hi Adrian

Best Regrards

Alex