Subject: Re: Using WGS to bypass external review (was: Re: [newtrk] last call on newtrk draft charter)

From: Harald Tveit Alvestrand <[email-masked]>
Date: Mon, 09 Feb 2004 10:21:02 -0800

--On 9. februar 2004 06:57 -0600 Spencer Dawkins <[email-masked]> 
wrote:

> Hi, Pekka,
>
> I've seen your assertion stated previously, that it is possible to
> move to PS in a short period of time if everyone is moving. I think
> your experience says quite a bit about your gifts in a number of
> areas! Please take this as a compliment.
>
> I'm thinking PS still has at least two problems that fast PS approval
> doesn't fix, reference dependencies and IANA dependencies.

FWIW.... the fastest processing of a Proposed Standard I have been able to 
find (from Publication Requested to RFC published) was 
draft-ietf-ipsec-aes-xcbc-prf - 117 days from Publication Requested to RFC 
Published.

The fastest IESG approval I have been able to find was 
draft-ietf-sip-manyfolks-resource - seems to have taken 17 days from entry 
into the I-D tracker to IESG approval (possibly somewhat longer - this was 
already in Last Call when it was first entered into the tracker, and this 
was close to tracker startup).

It's far from typical, I'm afraid - but it's NOT impossible.....

                            Harald

---

From: [email-masked]
Date: Tue, 10 Feb 2004 13:53:03 +0100

Are the current delays really that bad!  I had heard the process from
agreement to RFC was long but had never thought that 117 days was the
quickest case you could find.

If this WGS idea can reduce :
a) some of the referencing delays (RFC could be published with references
to other work's un-dated/un-numbered WGS tag implying "use the latest WGS
or RFC covered by this tag")

b) initiate early IANA allocation (=they start allocation process with the
first WGS version so that interop testing could be done with "final" IANA
code points)

Then we would be definitely back on the right track to match other
standards bodies that really do work at "internet speed" in the publishing
processes...
(see, for exampel 3GPP latest specifications - approved 18 dec 2003 and
published 16 Jan 2004 .. and that includes the christmas holiday period!)

- Alistair URIE

                      Harald Tveit                                                                                                        
                      Alvestrand                  To:      Spencer Dawkins <[email-masked]>, [email-masked]              
                      <harald@alvestrand.         cc:                                                                                     
                      no>                         Subject: Re: Using WGS to bypass external review (was: Re: [newtrk]  last call on       
                      Sent by:                    newtrk draft charter)                                                                   
                      owner-newtrk@lists.                                                                                                 
                      uoregon.edu                                                                                                         

                      09/02/2004 19:21                                                                                                    
                      Please respond to                                                                                                   
                      Harald Tveit                                                                                                        
                      Alvestrand                                                                                                          

                            Harald

(See attached file: att4khd0.dat)