Subject: Re: [newtrk] A few things I would like in a WGS

From: [email-masked]
Date: Wed, 11 Feb 2004 18:15:43 +0100

Personally, I would prefer a completely seperate name space so that when WG
wurzel (with or without ART or something else as well) agrees that
<draft-ietf-wurzel-rabbit-03> is stable enough for "WGS status" then a copy
of the same file (except for the name line on each page) is stored [under
say www.ietf.org/wgs] as <wgs-ietf-wurzel-rabbit-01>

Furthermore, we should build a simple alias system such that the URL
http://www.ietf.org/wgs/wgs-ietf-wurzel-rabbit is re-directed to the latest
WGS version (-01 or -02, or RFCYYYY, etc.) or to a page that summaries the
entire history of wgs-ietf-wurzel-rabbit (all version plus RFCs plus
information like "status", "IESG/ART/etc. comments on curent version", etc.
This would then offer the famous "undated reference" that other WGs and
external bodies could always use to reference this work.

The working group would then continue to progress development of revisions
to <draft-ietf-wurzel-rabbit-03> while the "outside world" would only need
to consider the successive versions posted to the wgs-ietf-wurzel-rabbit
page.

This mechanism would offer a simple split then between the "ongoing work"
and the "snapshot" views of the WG activities.

- Alistair

                      Dave Crocker                                                                                                        
                      <[email-masked]>          To:      "Christian Huitema" <[email-masked]>                            
                      Sent by:                    cc:      [email-masked]                                                       
                      owner-newtrk@lists.         Subject: Re: [newtrk] A few things I would like in a WGS                                
                      uoregon.edu                                                                                                         

                      11/02/2004 17:42                                                                                                    
                      Please respond to                                                                                                   
                      Dave Crocker                                                                                                        

Christian,

CH>  The snapshot should not disappear automatically
CH> after 6 months, and it also should not disappear automatically after
the
CH> publication of another draft.

good point.

CH> "draft-ietf-wurzel-rabbit-03" as "draft-ietf-wurzel-rabbit-wgs01.txt".

that's be pretty reasonable, although I'd suggest -01wgs, so that the
sorting order does not get disrupted.

d/
--
 Dave Crocker <dcrocker-at-brandenburg-dot-com>
 Brandenburg InternetWorking <www.brandenburg.com>
 Sunnyvale, CA  USA <tel:+1.408.246.8253>

.
newtrk resources:_____________________________________________________
web user interface: http://darkwing.uoregon.edu/~llynch/newtrk.html
mhonarc archive: http://darkwing.uoregon.edu/~llynch/newtrk/index.html

---

From: Dave Crocker <[email-masked]>
Date: Wed, 11 Feb 2004 09:28:21 -0800

Alistair,

the problem is the cost of creating and administering infrastructure.

so the trick is to find a way to use as much existing IETF mechanism as
possible.

AUac> Personally, I would prefer a completely seperate name space so that when WG
AUac> wurzel (with or without ART or something else as well) agrees that
AUac> <draft-ietf-wurzel-rabbit-03> is stable enough for "WGS status" then a copy
AUac> of the same file (except for the name line on each page) is stored [under
AUac> say www.ietf.org/wgs] as <wgs-ietf-wurzel-rabbit-01>

d/

.