Subject: RE: [newtrk] question one for newtrk

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Tue, 1 Jun 2004 15:54:43 +0200

I tend to agree with Joel. We need a first stable standards
track level that should be what PS was supposed to be, and
we should make clear that there will probably be changes
made when advancing it to the next level. As it is today,
it is not at all clear whether it is ok to make changes
when advancing the standard, or to what extent changes can
be accepted, or if changes would mean the standard must be
republished as a new PS. A PS should maybe also have an
expiration date when it is automatically moved to historic.

So, to answer the original question, I strongly believe 
the assumption for PS should be that it will be revised
and that changes are to be made as a result of experience.

/L-E

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Joel M. Halpern
> Sent: den 27 maj 2004 16:39
> To: [email-masked]
> Subject: Re: [newtrk] question one for newtrk
> 
> 
> I would like to see an initial standards level which says 
> "yes this has 
> been reviewed, but be warned it may change."
> The problem currently is that once deployments get out there, 
> the bar to 
> change gets set very high.  In several working groups I have 
> seen folks 
> objecting to changes to things that are still I-D because they have 
> implemented and delivered to customers already.  At I-D 
> level, we can say 
> "that's your problem."  But if we have a first 
> standardization level that 
> we expect people to implement to, and we expect to make 
> changes, we need to 
> be very clear what degree of implementation is an impediment 
> to change and 
> what degree of backwards compatibility WGs are expected to 
> maintain across 
> such changes.
> 
> Yours,
> Joel M. Halpern
> 
> At 09:26 AM 5/27/2004 -0400, Scott Bradner wrote:
> >So the question I'd like the WG to first discuss is:
> >
> >   "Should the first stage of IESG review of a standards 
> track document be
> >   done under the assumption that few documents will be 
> revised after first
> >   publication (and this must be "correct" the first time) 
> or should it
> >   assume that we will have a functioning multi-stage IETF 
> standards track?
> 
> .
> newtrk resources:_____________________________________________________
> web user interface: http://darkwing.uoregon.edu/~llynch/newtrk.html
> mhonarc archive: http://darkwing.uoregon.edu/~llynch/newtrk/index.html
> 
.
newtrk resources:_____________________________________________________
web user interface: http://darkwing.uoregon.edu/~llynch/newtrk.html
mhonarc archive: http://darkwing.uoregon.edu/~llynch/newtrk/index.html

---

From: "Spencer Dawkins" <[email-masked]>
Date: Tue, 1 Jun 2004 22:05:53 -0500

I agree with Lars-Erik.

Spencer

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Subject: RE: [newtrk] question one for newtrk

.