Subject: RE: [newtrk] Re: updated draft on cruft / draft-alvestrand-newtrk -cruft-00.txt

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Thu, 2 Sep 2004 08:38:01 -0700

> There've  just been too many cases in which prominent 
> IESG members have  pronounced things to be "dangerous" 
> and  "undeployable" in spite of  considerable empirical 
> evidence to the contrary.

I was on a security panel not so long ago where a person
representing the IETF starts into a bizare tirade against
firewalls.

At this point firewalls have been vastly more successful 
than any security technology to come out of the IETF. To
have someone who is not a security specialist dismiss them
out of hand came across very badly.

The phrase dangerous and undeployable were not used, but
it was clear to me that the statements were being made
by someone who is ten years behind where the field went.

I know that deperimeterization is now being talked about,
but the people promoting it have a very different model
to the one often cited in the IETF.

> One thing  that is clear  from all these  discussions about 
> IETF  process is that "rough consensus and working code"  
> is not a good way to make decisions about IETF process, as 
> (a) there is no way to produce "working code" in that context, 
> and (b) the IETF contains  few if any subject matter experts in 
> the area  of  "how  to run  an  organization"  or  "how an  
> organization  should communicate clearly to the outside". 

Trying to discuss process without being able to address 
accountability and communication is futile. 

A process is a finite state machine that is driven by interactions
with the external environment. The original purpose of the 
later process stages was to have the developer and user
community give input into the process. The reason that the
process gets stuck at the proposal stage is because there 
are no mechanisms for dialogue with those communities.

If all you do here is to create yet another deliberately 
unaccountable committee then you have failed to address the 
problem here.

The IETF organization model is neither unusual nor novel. It
is actually a very common model that tends to last about as 
long as the original movers stay arround. 

.
newtrk resources:_____________________________________________________
web user interface: http://darkwing.uoregon.edu/~llynch/newtrk.html
mhonarc archive: http://darkwing.uoregon.edu/~llynch/newtrk/index.html

---

From: Margaret Wasserman <[email-masked]>
Date: Thu, 2 Sep 2004 18:06:04 -0400

>representing the IETF starts into a bizare tirade against

As far as I know, there isn't anyone who could correctly to 
"represent the IETF" in this context.

Margaret
.

---

From: Margaret Wasserman <[email-masked]>
Date: Thu, 2 Sep 2004 20:15:41 -0400

>"represent the IETF" in this context.

s/could correctly to/could correctly claim to/

Margaret

.

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Fri, 03 Sep 2004 09:41:26 +0200

> representing the IETF starts into a bizare tirade against

Phil,

I think it would raise the information level if you were more specific - as 
in saying "on the Wednesday security panel at ConCon, James Whoever, who 
claimed to be representing the IETF, went on a bizarre tirade against 
firewalls".

That way, it is possible for other people to:

- figure out which tirade you meant
- figure out whether or not the IETF leadership knew that he was 
"representing" them
- figure out (if they heard it) whether they agreed that it was "bizarre".

There's only so much we should do to protect people against themselves.

                     Harald

.