Subject: RE: [newtrk] ... and, speaking of cruft ...

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Mon, 4 Oct 2004 13:37:57 -0700

DHCP is another area that would be much better served through a DNS based
configuration mechanism. It is much easier for a sysop to maintain DNS than
DHCP. It is also easier to get the security right.

I don't want a PC to plug into a network and start picking up configs for
the local mail or news server. Its a security nightmare. I want to get the
minimum info required to connect up to the local IP layer from the DHCP,
i.e. my local IP address, info on any NAT scheme that might be in play and
possibly local DNS servers (although that is a security issue).

There is no shortage of DNS extension prefixes. The extension prefix is a
large enough space to be pretty much collision free without the need for a
registry but a registry could be used with some advantage.

You could even make the entire scheme indexical and manage the whole system
via a DNS repository hosted off the ARPA space.

> -----Original Message-----
> From: Harald Tveit Alvestrand [mailto:[email-masked]]
> Sent: Sunday, October 03, 2004 3:59 PM
> To: Spencer Dawkins; NEWTRK Mailing List
> Subject: Re: [newtrk] ... and, speaking of cruft ...
> 
> 
> The only area where I know there has been serious work on reclaiming 
> IETF-controlled numbers is in DHCP options.
> 
> Certainly not in ports.
> 
>                      Harald
> 
> --On 2. oktober 2004 12:38 -0500 Spencer Dawkins 
> <[email-masked]> 
> wrote:
> 
> > Dear All,
> >
> > We are having a conversation in BEHAVE about port number 
> ranges, and I
> > happened to look at 
> http://www.iana.org/assignments/port-numbers. I DID
> > see a couple of notes about port numbers that had been 
> reclaimed, but
> > does this happen more often than once in a blue moon?
> >
> > Just wondering ...
> >
> > Spencer
> >
> > .
> > newtrk 
> resources:_____________________________________________________
> > web user interface: http://darkwing.uoregon.edu/~llynch/newtrk.html
> > mhonarc archive: 
http://darkwing.uoregon.edu/~llynch/newtrk/index.html

.
newtrk resources:_____________________________________________________
web user interface: http://darkwing.uoregon.edu/~llynch/newtrk.html
mhonarc archive: http://darkwing.uoregon.edu/~llynch/newtrk/index.html
.
newtrk resources:_____________________________________________________
web user interface: http://darkwing.uoregon.edu/~llynch/newtrk.html
mhonarc archive: http://darkwing.uoregon.edu/~llynch/newtrk/index.html

---

From: Eliot Lear <[email-masked]>
Date: Tue, 05 Oct 2004 09:15:49 +0200

I think you're talking about protocol development, which while perhaps 
interesting indicates that the current mechanisms aren't quite ready to 
be labeled "cruft".

Eliot
.