Subject: [newtrk] RE: Question about Obsoleted vs. Historic

From: <[email-masked]>
Date: Mon, 11 Jul 2005 13:12:06 +0300

Eliot,

> I would point out that it is historically useful to be able to track
> changes between draft and full or proposed and draft and we don't list
> status information in the RFCs...

I agree with that.

And, my head still hurts thinking about why we'd leave something as a 
"Proposed Standard" when its been obsoleted.  Seems more like an "Obsolete
Standard" ... but perhaps I am just nit-picking.

John
 
> Eliot
> 
> [email-masked] wrote:
> > Hi,
> > 
> > I was wondering if someone could help me out on this one.  
> I was doing a bit
> > of analysis on the current RFC list, and noticed that some 
> Draft Standard
> > documents are obsoleted.  For example:
> > 
> >  954 NICNAME/WHOIS. K. Harrenstien, M.K. Stahl, E.J. Feinler.
> >       Oct-01-1985. (Format: TXT=7397 bytes) (Obsoletes 
> RFC0812) (Obsoleted
> >       by RFC3912) (Status: DRAFT STANDARD)
> > 
> > This really made me scratch my head. One would imagine if a 
> protocol is obsoleted
> > by another, it would not be listed as a Draft Standard any longer.  
> > 
> > What is the reason for continuing to list something 
> obsolete as a Draft Standard?
> > 
> > John
> > 
> > _______________________________________________
> > Ietf mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ietf
> > 
> > 
> 

.
newtrk resources:_____________________________________________________
web user interface: http://darkwing.uoregon.edu/~llynch/newtrk.html
mhonarc archive: http://darkwing.uoregon.edu/~llynch/newtrk/index.html

---

From: John C Klensin <[email-masked]>
Date: Mon, 11 Jul 2005 10:34:04 -0400

--On Monday, 11 July, 2005 13:12 +0300 [email-masked]
wrote:

> Eliot,
> 
>> I would point out that it is historically useful to be able
>> to track changes between draft and full or proposed and draft
>> and we don't list status information in the RFCs...
> 
> I agree with that.
> 
> And, my head still hurts thinking about why we'd leave
> something as a  "Proposed Standard" when its been obsoleted.
> Seems more like an "Obsolete Standard" ... but perhaps I am
> just nit-picking.

If, as a community, we cared, we could easily have both the
tracking information and the status by introducing the
little-known term "former", as in "Obsolete, former Draft
Standard".

Of course, how many procedural hoops we'd have to jump through
to get there is another issue.

   john

.