Subject: [newtrk] SRD example - MIXER again

From: Harald Tveit Alvestrand <[email-masked]>
Date: Fri, 21 Oct 2005 10:16:40 +0200

OK, here's the example ISD I wrote for MIXER, now couched in SRD syntax.

Note the comments - it wasn't obvious for me what to do in a number of 
places after having read the SRD document.

The HTML version is at http://www.alvestrand.no/ietf/newtrk/mixer-isd.html

Comments?
(especially if you know MIXER technology and can say something about 
whether or not the SRD accurately and usefully reflects the technology 
set...)

                      Harald

<?xml version='1.0' encoding="UTF-8"?>
<!DOCTYPE srd SYSTEM "id-rfc-set-02.dtd">
<?xml-stylesheet type='text/xsl' href='id-rfc-set-02.xslt' ?>
<!-- why is the stylesheet internal and not external? -->
<?srd sortrefs="yes" ?>
<?srd strict="yes" ?>
<!-- why do these 2 elements exist? -->
<srd set="mixer.0" wip="0-alvestrand">
<title>MIME - X.400 Enhanced Relay - MIXER</title>
<description>
MIXER is about gatewaying between MIME and X.400 email.
Nobody's done anything to it recently, so it's a stable spec, but
complex enough to be an useful example.

>From the announce:
MIXER is an update to RFC 1327 which specifies mappings between
RFC822/SMTP and X.400 mail.
This update corrects several errors in RFC 1327, includes supprot for
MIME as well as Internet standards-track delivery status notifications
and SMTP extensions to request delivery reports, and defines a
standard notation for representation of address mapping and routing
information between X.400 and Internet Mail.
</description>
<srdDate>2005-10-21</srdDate>
<core>
  <srdref dt="RFC" dd="2156"/>
  <srdref dt="RFC" dd="2157"/>
  <!-- the above is the core specification. Below follows SRDs that -->
  <!-- this stuff critically depends on, in current versions. -->
  <srdref dt="SRD" dd="smtp"/>
  <srdref dt="SRD" dd="dsn"/>
  <srdref dt="SRD" dd="mdn"/>
  <srdref dt="SRD" dd="internet-mail-format"/>
  <!-- in addition, it's critically dependent on X.400/88 -->
</core>
<extensions>
  <srdref dt="RFC" dd="2158"/>
  <srdref dt="RFC" dd="2159"/>
  <srdref dt="RFC" dd="2160"/>
  <!-- the 3 above are content that can be carried in MIXER -->
  <srdref dt="RFC" dd="2163"/>
  <srdref dt="RFC" dd="2164"/>
  <!-- supporting technology. Need one. In practice neither is used. -->
</extensions>
<guidance>
</guidance>
<replaces>
  <srdref dt="RFC" dd="0987"/>
  <srdref dt="RFC" dd="1026"/>
  <srdref dt="RFC" dd="1138"/>
  <srdref dt="RFC" dd="1148"/>
  <!-- the above series was replaced by 1327. Should they be listed? -->
  <srdref dt="RFC" dd="1327"/>
  <srdref dt="RFC" dd="1495"/>
</replaces>
<experimental>
  <srdref dt="RFC" dd="2162"/>
  <!-- Using MIXER technology to access a 3rd mail system. Extension? -->
  <srdref dt="RFC" dd="2161"/>
  <!-- Content that can be carried -->
</experimental>
<companion>
 <!-- should the SRDs I listed under "core" go here, or there? -->
 <srdref dt="RFC" dd="1328"/>
 <!-- Related specification - needed if you do X.400 downgrade -->
 <srdref dt="RFC" dd="3854"/>
 <!-- unrelated spec except that they interfere with each other -->
 <srdref dt="RFC" dd="3855"/>
 <!-- as above -->
</companion>

</srd>

.
newtrk resources:_____________________________________________________
web user interface: http://darkwing.uoregon.edu/~llynch/newtrk.html
mhonarc archive: http://darkwing.uoregon.edu/~llynch/newtrk/index.html

---

From: Douglas Otis <[email-masked]>
Date: Fri, 21 Oct 2005 09:40:27 -0700

> <!-- why do these 2 elements exist? -->

These are called process instructions.  Currently, the sortrefs set  
to 'yes' will sort your reference elements per category.  Setting  
strict to 'yes' will prohibit the inclusion of I-D references within  
a non-WIP SRD.  Leaving these two lines out defaults to 'no', or do  
as you want as there are no process instructions...

I have included your XML and HTML output on the website.

http://www.sonic.net/~dougotis/newtrk/

I had imagined that an SRD would not be part of the Core definition,  
but rather found within the Companion section.  I have no strong  
feels about this, but it does seem a bit odd.

-Doug

.

---

From: Douglas Otis <[email-masked]>
Date: Fri, 21 Oct 2005 09:57:48 -0700

I also noticed an error in this mixer SRD as well.  Per the DTD and  
the draft, the empty Guidance section should not have been included.  
A utility that checks xml inputs against the DTD would have caught  
this error.

-Doug
.