Subject: [newtrk] Last Call comments on draft-ietf-newtrk-decruft-experiment-01.txt

From: Brian E Carpenter <[email-masked]>
Date: Sun, 06 Nov 2005 16:13:15 +0100

AD hat on.

Since none of these were copied to the WG, here is
a compilation of the Last Call comments, including responses
to IANA's question.

I request the authors and WG to reach consensus on

1. whether to remove the 5 RFCs mentioned by Orly from the list
(note his second message at the end that only mentions two of them).

2. how to respond to IANA

If some RFCs are removed, I would like to see a revised I-D,
since it would be very confusing to have them removed during
the editorial process.

    Brian

-------- Original Message --------
Subject: Re: [newtrk] Last Call: 'Getting rid of the cruft: an experiment to	identify obsolete standards document' to 
Informational RFC
Date: Fri, 21 Oct 2005 14:35:25 -0500
From: Spencer Dawkins <[email-masked]>
To: <[email-masked]>
References: <[email-masked]>

I support this action, FWIW...

Spencer

-------- Original Message --------
Subject: FW: FW: Last Call: 'Getting rid of the cruft: an experiment to	identify obsolete standards document' to Informational RFC
Date: Sun, 23 Oct 2005 23:26:27 +0200
From: Orly Nicklass <[email-masked]>
To: <[email-masked]>

- 1381, 1382:
- 1471, 1472, 1473:
are still in active use by some of our products.

-------- Original Message --------
Subject: RE: Last Call: 'Getting rid of the cruft: an experiment to identify	obsolete standards document' to Informational RFC 
[I06-051024-0011]
Date: Mon, 24 Oct 2005 20:44:53 -0700
From: [email-masked]
Reply-To: [email-masked]
To: [email-masked]
CC: [email-masked], [email-masked], [email-masked]

IESG:

The IANA has reviewed the following Internet-Draft which is in Last
Call:  draft-ietf-newtrk-decruft-experiment-01.txt,  and has the following
with regards to the publication of this document:

Upon approval of this document the IANA will review all the IANA registries and update the references to be this document for 
the all documents described in section 3.  Should all the actual assignments also be marked as OBSOLETE or should the reference 
only be changed?

Thank you.

Michelle Cotton
(on behalf of IANA)

-------- Original Message --------
Subject: Re: Last Call: 'Getting rid of the cruft: an experiment to identify obsolete standards document' to Informational RFC 
[I06-051024-0011]
Date: Tue, 25 Oct 2005 08:27:50 +0200
From: Eliot Lear <[email-masked]>
To: Brian E Carpenter <[email-masked]>
CC: [email-masked], [email-masked], [email-masked]
References: <[email-masked]> <[email-masked]>

Michelle,

My recommendation would be to simply add the notation "Historic" to the
reference.  Or if you like,  Historic, see RFCs (original, cruft).  Just
because these documents are marked HISTORIC doesn't mean someone out
there isn't using them.  We don't make that claim and there's no need to
cause those people grief.

There is potentially a separate effort that should be undertaken to
attempt to clean up some of the IANA databases.  For example, I'm pretty
sure that HEMS implementations never got out of labs.  And SGMP is listed.

What do you think?

Eliot

-------- Original Message --------
Subject: RE: Last Call: 'Getting rid of the cruft: an experiment to identify	obsolete standards document' to Informational RFC 
[I06-051024-0011]
Date: Tue, 25 Oct 2005 05:38:09 -0400 (EDT)
From: [email-masked] (Scott Bradner)
To: [email-masked]
CC: [email-masked], [email-masked], [email-masked]

I hnk that the references should be changed and that is all that
should happen - I do not think teh status of the assignments should
change

Scott

-------- Original Message --------
Subject: RE: Last Call: 'Getting rid of the cruft: an experiment to identify obsolete standards document' to Informational RFC 
[I06-051024-0011]
Date: Tue, 25 Oct 2005 05:44:05 -0700
From: Harald Tveit Alvestrand <[email-masked]>
To: [email-masked], [email-masked]
CC: [email-masked], [email-masked]
References: <[email-masked]>

My immediate thought would be that IANA should not change the references in
the registries at all - the correct interpretation of the values in the
registries is still the defining RFC, not the one that declares them
Historical.

I believe the port number registry, for instance, has many references to
documents that are not standards-track RFCs already.

If you want to add annotations saying "Historical" to such references,
that's reasonable, but then you should also add "Informational",
"Experimental" or "Standards-track" to the other references in the
registries - and as far as I know, there's no such marking now.

Don't make work you don't have to.....

                               Harald

-------- Original Message --------
Subject: RE: Last Call: 'Getting rid of the cruft: an experiment to identify	obsolete standards document' to Informational RFC 
[I06-051024-0011]
Date: Tue, 25 Oct 2005 17:12:29 -0400 (EDT)
From: [email-masked] (Scott Bradner)
To: [email-masked], [email-masked], [email-masked]
CC: [email-masked], [email-masked]

 > the registries at all - the correct interpretation of the values in the=20
 > registries is still the defining RFC, not the one that declares them=20
 > Historical.

good point

Scott

-------- Original Message --------
Subject: FW: [newtrk] I-D ACTION:draft-ietf-newtrk-decruft-experiment-00.txt
Date: Sun, 30 Oct 2005 18:43:46 +0200
From: Orly Nicklass <[email-masked]>
To: <[email-masked]>

- RFC1471 - RFC1473 - are used by our products

(end of Last Call comments)

.
newtrk resources:_____________________________________________________
web user interface: http://darkwing.uoregon.edu/~llynch/newtrk.html
mhonarc archive: http://darkwing.uoregon.edu/~llynch/newtrk/index.html

---

From: Pekka Savola <[email-masked]>
Date: Sun, 6 Nov 2005 19:01:14 +0200 (EET)

> (note his second message at the end that only mentions two of them).

I support removing 1471, 1472, 1473 from the list; PPP-related MIBs 
could be used more widely now and in the future as well.

I disagree with 1381, 1382 -- these are MIBs on X.25.  I doubt anyone 
is building new products with these; the fact that they're supported 
in existing products does not take these "away" in any sense.  But if 
folks want to remove them from the list, I don't object.

> 2. how to respond to IANA

The best seems to keep the reference to the existing RFCs but add a 
note like '(Historic, see RFC XXXX)' beside the assignments.
.
newtrk resources:_____________________________________________________
web user interface: http://darkwing.uoregon.edu/~llynch/newtrk.html
mhonarc archive: http://darkwing.uoregon.edu/~llynch/newtrk/index.html

---

From: "Spencer Dawkins" <[email-masked]>
Date: Sun, 6 Nov 2005 09:39:32 -0800

I agree with Pekka on a pretty fundamental point here - we can decruft 
specifications that are really old, based on few if any people at the IETF 
knowing or caring about a technology, and that does not prevent anyone from 
continuing to use the specification and the technology it describes - all it 
says is that the IETF is no longer paying attention to either the 
specification or the technology.

Thanks,

Spencer

> I disagree with 1381, 1382 -- these are MIBs on X.25.  I doubt anyone is 
> building new products with these; the fact that they're supported in 
> existing products does not take these "away" in any sense.  But if folks 
> want to remove them from the list, I don't object. 

.

---

From: "C. M. Heard" <[email-masked]>
Date: Tue, 8 Nov 2005 19:08:22 -0800 (PST)

>>>>> On Sun, 6 Nov 2005, Brian E Carpenter wrote:
BEC> AD hat on.
BEC> 
BEC> Since none of these were copied to the WG, here is
BEC> a compilation of the Last Call comments, including responses
BEC> to IANA's question.
BEC> 
BEC> I request the authors and WG to reach consensus on
BEC> 
BEC> 1. whether to remove the 5 RFCs mentioned by Orly from the list
BEC> (note his second message at the end that only mentions two of them).
        ^^^
        her

On Sun, 6 Nov 2005, Pekka Savola wrote:
PS> I support removing 1471, 1472, 1473 from the list; PPP-related MIBs 
PS> could be used more widely now and in the future as well.
PS> 
PS> I disagree with 1381, 1382 -- these are MIBs on X.25.  I doubt anyone 
PS> is building new products with these; the fact that they're supported 
PS> in existing products does not take these "away" in any sense.  But if 
PS> folks want to remove them from the list, I don't object.

There probably won't be any new X.25 implementations, but there may well
be new products built with existing code, since it's still used to carry
TL1 messages in some telecom environments.

BEC> 2. how to respond to IANA

PS> The best seems to keep the reference to the existing RFCs but add a 
PS> note like '(Historic, see RFC XXXX)' beside the assignments.

I disagree with this, and emphatically agree with Harald's comment
below ... IANA should not do anything at all to the registries since
it creates work but serves no purpose.  The assignments themselves
won't be changed, and people can and should go elsewhere to find out
the status of the RFCs.

BEC> If some RFCs are removed, I would like to see a revised I-D,
BEC> since it would be very confusing to have them removed during
BEC> the editorial process.

Agreed.

BEC>     Brian
BEC> 
BEC> -------- Original Message --------
BEC> Subject: Re: [newtrk] Last Call: 'Getting rid of the cruft: an experiment to	identify obsolete standards document' to 
BEC> Informational RFC
BEC> Date: Fri, 21 Oct 2005 14:35:25 -0500
BEC> From: Spencer Dawkins <[email-masked]>
BEC> To: <[email-masked]>
BEC> References: <[email-masked]>
BEC> 
BEC> I support this action, FWIW...
BEC> 
BEC> Spencer
BEC> 
BEC> -------- Original Message --------
BEC> Subject: FW: FW: Last Call: 'Getting rid of the cruft: an experiment to	identify obsolete standards document' to Informational RFC
BEC> Date: Sun, 23 Oct 2005 23:26:27 +0200
BEC> From: Orly Nicklass <[email-masked]>
BEC> To: <[email-masked]>
BEC> 
BEC> 
BEC> - 1381, 1382:
BEC> - 1471, 1472, 1473:
BEC> are still in active use by some of our products.
BEC> 
BEC> -------- Original Message --------
BEC> Subject: RE: Last Call: 'Getting rid of the cruft: an experiment to identify	obsolete standards document' to Informational RFC 
BEC> [I06-051024-0011]
BEC> Date: Mon, 24 Oct 2005 20:44:53 -0700
BEC> From: [email-masked]
BEC> Reply-To: [email-masked]
BEC> To: [email-masked]
BEC> CC: [email-masked], [email-masked], [email-masked]
BEC> 
BEC> 
BEC> IESG:
BEC> 
BEC> The IANA has reviewed the following Internet-Draft which is in Last
BEC> Call:  draft-ietf-newtrk-decruft-experiment-01.txt,  and has the following
BEC> with regards to the publication of this document:
BEC> 
BEC> Upon approval of this document the IANA will review all the IANA registries and update the references to be this document for 
BEC> the all documents described in section 3.  Should all the actual assignments also be marked as OBSOLETE or should the reference 
BEC> only be changed?
BEC> 
BEC> Thank you.
BEC> 
BEC> Michelle Cotton
BEC> (on behalf of IANA)
BEC> 
BEC> -------- Original Message --------
BEC> Subject: Re: Last Call: 'Getting rid of the cruft: an experiment to identify obsolete standards document' to Informational RFC 
BEC> [I06-051024-0011]
BEC> Date: Tue, 25 Oct 2005 08:27:50 +0200
BEC> From: Eliot Lear <[email-masked]>
BEC> To: Brian E Carpenter <[email-masked]>
BEC> CC: [email-masked], [email-masked], [email-masked]
BEC> References: <[email-masked]> <[email-masked]>
BEC> 
BEC> Michelle,
BEC> 
BEC> My recommendation would be to simply add the notation "Historic" to the
BEC> reference.  Or if you like,  Historic, see RFCs (original, cruft).  Just
BEC> because these documents are marked HISTORIC doesn't mean someone out
BEC> there isn't using them.  We don't make that claim and there's no need to
BEC> cause those people grief.
BEC> 
BEC> There is potentially a separate effort that should be undertaken to
BEC> attempt to clean up some of the IANA databases.  For example, I'm pretty
BEC> sure that HEMS implementations never got out of labs.  And SGMP is listed.
BEC> 
BEC> What do you think?
BEC> 
BEC> Eliot
BEC> 
BEC> 
BEC> -------- Original Message --------
BEC> Subject: RE: Last Call: 'Getting rid of the cruft: an experiment to identify	obsolete standards document' to Informational RFC 
BEC> [I06-051024-0011]
BEC> Date: Tue, 25 Oct 2005 05:38:09 -0400 (EDT)
BEC> From: [email-masked] (Scott Bradner)
BEC> To: [email-masked]
BEC> CC: [email-masked], [email-masked], [email-masked]
BEC> 
BEC> 
BEC> I hnk that the references should be changed and that is all that
BEC> should happen - I do not think teh status of the assignments should
BEC> change
BEC> 
BEC> Scott
BEC> 
BEC> 
BEC> -------- Original Message --------
BEC> Subject: RE: Last Call: 'Getting rid of the cruft: an experiment to identify obsolete standards document' to Informational RFC 
BEC> [I06-051024-0011]
BEC> Date: Tue, 25 Oct 2005 05:44:05 -0700
BEC> From: Harald Tveit Alvestrand <[email-masked]>
BEC> To: [email-masked], [email-masked]
BEC> CC: [email-masked], [email-masked]
BEC> References: <[email-masked]>
BEC> 
BEC> My immediate thought would be that IANA should not change the references in
BEC> the registries at all - the correct interpretation of the values in the
BEC> registries is still the defining RFC, not the one that declares them
BEC> Historical.
BEC> 
BEC> I believe the port number registry, for instance, has many references to
BEC> documents that are not standards-track RFCs already.
BEC> 
BEC> If you want to add annotations saying "Historical" to such references,
BEC> that's reasonable, but then you should also add "Informational",
BEC> "Experimental" or "Standards-track" to the other references in the
BEC> registries - and as far as I know, there's no such marking now.
BEC> 
BEC> Don't make work you don't have to.....
BEC> 
BEC>                                Harald
BEC> 
BEC> 
BEC> 
BEC> -------- Original Message --------
BEC> Subject: RE: Last Call: 'Getting rid of the cruft: an experiment to identify	obsolete standards document' to Informational RFC 
BEC> [I06-051024-0011]
BEC> Date: Tue, 25 Oct 2005 17:12:29 -0400 (EDT)
BEC> From: [email-masked] (Scott Bradner)
BEC> To: [email-masked], [email-masked], [email-masked]
BEC> CC: [email-masked], [email-masked]
BEC> 
BEC>  > the registries at all - the correct interpretation of the values in the=20
BEC>  > registries is still the defining RFC, not the one that declares them=20
BEC>  > Historical.
BEC> 
BEC> good point
BEC> 
BEC> Scott
BEC> 
BEC> 
BEC> 
BEC> -------- Original Message --------
BEC> Subject: FW: [newtrk] I-D ACTION:draft-ietf-newtrk-decruft-experiment-00.txt
BEC> Date: Sun, 30 Oct 2005 18:43:46 +0200
BEC> From: Orly Nicklass <[email-masked]>
BEC> To: <[email-masked]>
BEC> 
BEC> - RFC1471 - RFC1473 - are used by our products
BEC> 
BEC> (end of Last Call comments)

.

---

From: Pekka Savola <[email-masked]>
Date: Wed, 9 Nov 2005 08:00:31 +0200 (EET)

> won't be changed, and people can and should go elsewhere to find out

There seems to be a point in this justification, and I could agree to 
this approach as well.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
.
newtrk resources:_____________________________________________________
web user interface: http://darkwing.uoregon.edu/~llynch/newtrk.html
mhonarc archive: http://darkwing.uoregon.edu/~llynch/newtrk/index.html

---

From: Eliot Lear <[email-masked]>
Date: Fri, 11 Nov 2005 12:44:42 -0800

> There seems to be a point in this justification, and I could agree to 

As it is the port number database is a mess.  Not our job to fix that, 
but I would like to see the IANA update what information they envision 
providing when they get around to cleaning it up so we don't make the 
later cleanup effort harder than need be.  Especially since right now 
decruft is a special case that would require special handling regarding 
references.

Eliot
.

---

From: "C. M. Heard" <[email-masked]>
Date: Tue, 15 Nov 2005 10:41:55 -0800 (PST)

On Fri, 11 Nov 2005, Eliot Lear wrote:
> As it is the port number database is a mess.  Not our job to fix
> that, but I would like to see the IANA update what information
> they envision providing when they get around to cleaning it up
> so we don't make the later cleanup effort harder than need be.  
> Especially since right now decruft is a special case that would
> require special handling regarding references.

Why is decruft a special case that requires special handling
regarding references?  What Harald A. and I have been advocating is
NOT treating it any differently that anything else.  For MIB work we
came to the agreement that updated MIB documents would not cause the
IANA to update the references in the SMI numbers database;  rather,
the references would point to the document associated with the
initial allocation.  As far as I know everything else is handled
that way, and I don't see why decruft should be an exception.

//cmh

.

---

From: Eliot Lear <[email-masked]>
Date: Tue, 15 Nov 2005 19:51:58 +0100

C. M. Heard wrote:
> regarding references?

Just by numbers.  It's the only document that changes the status of so 
many standards.  That might not remain the case in the future, but it 
might.  This is why I'd like to hear from the IANA on the matter.

Eliot
.

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Tue, 15 Nov 2005 12:25:28 -0800

> might.  This is why I'd like to hear from the IANA on the matter.

I talked to Michelle in Vancouver, and she was very happy with a resolution 
that did not require her to do anything......

                  Harald

---

From: Eliot Lear <[email-masked]>
Date: Tue, 15 Nov 2005 21:39:44 +0100

Harald Tveit Alvestrand wrote:

> I talked to Michelle in Vancouver, and she was very happy with a 
> resolution that did not require her to do anything......

Alright.  I'm not going to stand on my head on this issue.  Send text.

Eliot
.

---

From: "C. M. Heard" <[email-masked]>
Date: Tue, 15 Nov 2005 12:57:29 -0800 (PST)

> Alright.  I'm not going to stand on my head on this issue.  Send text.

OK, here is a suggestion.  In Section 6, "IANA Considerations":

OLD:
   The IANA is requested to review the above list of documents for any
   entries that may need to be marked as Historic in various databases.

NEW:
   Registrations made in connection with the above list of documents
   are not being changed by the reclassification to Historic status,
   hence no actions are required of the IANA.

Wordsmith to taste.

//cmh

.

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Tue, 15 Nov 2005 13:05:11 -0800

OLD:

6.  IANA Considerations

NEW:

6.  IANA Considerations

   The IANA databases contain references to many of these documents.
   The documents are still the normative definitions for these values,
   and the IANA databases do not contain information about the status
   of the RFCs referred to.

   Therefore, the IANA should not need to do anything based on this
   document.

OK?

                 Harald

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 16 Nov 2005 17:19:12 +0100

Please add

[RFC Editor - please do not remove this section.]

just to be sure.

     Brian

.

---

From: Eliot Lear <[email-masked]>
Date: Thu, 17 Nov 2005 17:33:47 +0100

Brian,

I have submitted draft-ietf-newtrk-decruft-experiment-02.txt for 
publication with the five RFCs removed, a comment added regarding them, 
and the text that Harald provided for IANA considerations.

Eliot

Brian E Carpenter wrote:
> Subject: Re: [newtrk] Last Call: 'Getting rid of the cruft: an 
> experiment to    identify obsolete standards document' to Informational RFC
> Subject: FW: FW: Last Call: 'Getting rid of the cruft: an experiment 
> to    identify obsolete standards document' to Informational RFC
> Subject: RE: Last Call: 'Getting rid of the cruft: an experiment to 
> identify    obsolete standards document' to Informational RFC 
> [I06-051024-0011]
> Upon approval of this document the IANA will review all the IANA 
> registries and update the references to be this document for the all 
> documents described in section 3.  Should all the actual assignments 
> also be marked as OBSOLETE or should the reference only be changed?
> 
> Thank you.
> 
> Michelle Cotton
> (on behalf of IANA)
> 
> Subject: Re: Last Call: 'Getting rid of the cruft: an experiment to 
> identify obsolete standards document' to Informational RFC 
> [I06-051024-0011]
> <[email-masked]>
> 
> Michelle,
> 
> Subject: RE: Last Call: 'Getting rid of the cruft: an experiment to 
> identify    obsolete standards document' to Informational RFC 
> [I06-051024-0011]
> Subject: RE: Last Call: 'Getting rid of the cruft: an experiment to 
> identify obsolete standards document' to Informational RFC 
> [I06-051024-0011]
> Subject: RE: Last Call: 'Getting rid of the cruft: an experiment to 
> identify    obsolete standards document' to Informational RFC 
> [I06-051024-0011]
> Subject: FW: [newtrk] I-D 
> ACTION:draft-ietf-newtrk-decruft-experiment-00.txt
.

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 18 Nov 2005 15:05:14 +0100

Thanks!

WG Chair, do you want me to put this on the IESG agenda when
it comes out? (We'll have a very heavy agenda on December 1,
so I would probably wait for the December 15 meeting.)

    Brian

.