Subject: Re: uid strings, was (Re: Draft minutes for Oslo NFSv4 WG meeting.)

From: Ram Marti <[email-masked]>
Date: Thu, 12 Aug 1999 12:58:18 -0700 (PDT)

> Date: Thu, 12 Aug 1999 12:24:52 -0700 (PDT)
> From: Mike Eisler <[email-masked]>
> Subject: Re: uid strings, was (Re: Draft minutes for Oslo NFSv4 WG meeting.)
> To: [email-masked]
> Cc: [email-masked]
> MIME-Version: 1.0
......
.....
> 
> Agreed. Unless anyone objects, I'll assume we've reached consensus that
> that uid and gids are expressed as a canonical form of:
> 
> 	 user@dns_domain or group@dns_domain
> 
> In the event a server or client cannot translate from its operating system
> user or group id, the server and client MAY use a string that has no @ symbol
> to dennote names that are meaningful only to the client or server.

Are you worried that presence of "@" will confuse the client or server 
processing? Is the absence of "@" intended to convey that a locally meaningful 
format is used?

	- Ram
> 	-mre

---

From: Mike Eisler <[email-masked]>
Date: Thu, 12 Aug 1999 13:13:20 -0700 (PDT)

> processing? Is the absence of "@" intended to convey that a locally

I'm not worried about that. Carl's point is that sometimes a translation
isn't possible. In that case we have two choices in the design of the protocol:

	- translate to native id to a special id, e.g. "[email-masked]"
	- pass the native id "as is" in a form that is human readable, but
		makes it clear it was untranslated. One way to do this is
		to simply pass a string that has no @ symbol in it. There are
		others (e.g. [email-masked]). I'm not
		particularly religious about it. Just religious
		about reaching closure.
		
> meaningful  format is used?

yes.