Subject: clarify section 6.7 on

From: Naidu Bollineni <[email-masked]>
Date: Wed, 11 Aug 1999 13:55:07 -0700 (PDT)

Can somebody clarify this.

Should the server only keep a pseudo-root-file-system of all paths leading
to all exported points ?

Here is an example :

Server's physical root has /a /b /c /d as the directory contents.

/a/p /b are directories exported.

Should the server only keep a pseudo tree of /, /a( and subtree /a/p), /b
so that when the server returns the contents to the client as part of a READDIR,
it will only return the contents of the pseudo root, not actual root ?

Doesn't this make sense to "browsing exports" and server name space relevant for
clients, rather than whatever server's real root keeps ?

Also say when the server admin exports /c later on, it will add /c to
the pseudo root, and the contents seen by the clients in READDIR will be
/, /a(and subtree /a/p), /b, /c here after.

/d is of no relevance to the clients ?

Thanks,
Naidu.

---

From: Brent Callaghan <[email-masked]>
Date: Wed, 11 Aug 1999 16:01:31 -0700 (PDT)

> Should the server only keep a pseudo-root-file-system of all paths leading

The server must provide a path to all NFS directories that
are intended to be visible to clients.  A pseudo filesystem
will be required if there are directories that are not
exported to clients and/or are intended to be hidden.

A pseudo filesystem may also be needed to bridge gaps further
down the filesystem name space caused by an exported filesystem
that is mounted within a filesystem that is not exported.

The root filesystem is just the most likely example of that.

> it will only return the contents of the pseudo root, not actual root ?

Yes, that's correct.   The server should return the actual
root directory contents only if the root filesystem itself
is exported.  Otherwise it should make visible (via readdir or
lookup) just those directories that are needed to provide a 
path to exported filesystems.

> /d is of no relevance to the clients ?

That's right.  If you haven't exported /d then you shouldn't
make it visible to clients.

	Brent

---

From: Naidu Bollineni <[email-masked]>
Date: Wed, 11 Aug 1999 16:46:35 -0700 (PDT)

Thanks,
Naidu.