Subject: Re: READDIR cleanup

From: Peter Staubach <[email-masked]>
Date: Tue, 2 Nov 1999 17:04:23 -0800 (PST)

> 
> I would like to clear up some READDIR issues that have
> come up in WG email and during the bakeoff.
> 
> The READDIR arguments currently contain:
> 	cookie
> 	dircount
> 	maxcount
> 	attr_request
> 
> The response is:
> 	A linked list of:
> 		cookie
> 		name
> 		attrs
> 	eof
> 
> From NFSv3 we have lost the cookieverifier as part of the request
> and response.  So the server doesn't have a method to confirm
> the cookie.  Is that okay?  I would think not.
> 

Is the file handle for each name being returned part of the results?
If not, that was lost from the NFS Version 3 specification as well.

The reason for the file handle being part of the READDIRPLUS results
was that without it, the attribute information can not be easily
cached on the client.  Client implementations such as Solaris store
attributes in the NFS dependent node.  These nodes are only addressible
via the file handle.  Therefore, if there is no file handle, then it
doesn't make sense to cache the attributes.

		ps

---

From: Spencer Shepler <[email-masked]>
Date: Tue, 02 Nov 1999 19:09:47 -0600

> doesn't make sense to cache the attributes.

The client makes a specific request for the filehandle with the 
'attr_request' field.  In the case of readdir the filehandle is 
considered an attribute.

Spencer