Subject: guard on SETATTR

From: "Noveck, Dave" <[email-masked]>
Date: Mon, 18 Jun 2001 09:24:13 -0700

Does anybody know what happened to the guard
mechanism for SETATTR that was in V3?  It isn't
in V4 and I'm wondering why.

Is it the case that it has turned out to be
useless (i.e. that no clients use it)?  It doesn't
appear that it would be difficult for a server to 
implement so even if it were used only by a few people, 
it doesn't seem as though there would be a need to 
remove it from NFS.

Anybody remember the history here?

---

From: salit gazit <[email-masked]>
Date: Mon, 18 Jun 2001 13:44:31 -0700

> Anybody remember the history here?

Dave, when I implemented setattr here, I faced the same
dilema, and eventually used GETATTR and VERIFY to replace
the guard. It seems to work well, but it's not atomic
anymore (as the guard used to be wrt SETATTR).

Salit
-- 
Standard disclaimers apply.

MailTo:[email-masked]