Subject: RE: Issues list for RFC3010

From: "Noveck, Dave" <[email-masked]>
Date: Fri, 21 Sep 2001 06:44:46 -0700

Spencer Shepler wrote:
> On Fri, Peter ?strand wrote:
> > > > > I vote to remove "tag" at all. If it used for debugging - use snoop, if it
> > > > > used for caching - use something else (xids from RPC)
> > ...
> > > I like the idea of a fixed length for the tag.
> > >
> > > It seems that its variable length is more of a
> > > problem than its presence.
> > 
> > Why is the variable length a problem?
> > 
> > My opinion is that the tags should be included in the protocol, in one
> > form or another. They are really useful, IMHO.
> 
> Variable length adds overhead to the decoding of the request.

Not that much.  A fixed length would mean that all clients 
would have to bear additional network overhead even if they
didn't want to use the feature.  A variable-length allows
the client to choose a length of zero and only pay four
bytes.  

My first choice is no tag.

My second choice would be a variable-length tag with the 
server encouraged to return the tag unmodified in the 
response but allowed to truncate it because of resource
issues caused by long tags.

---

From: "Dan Trufasiu" <[email-masked]>
Date: Fri, 21 Sep 2001 15:06:59 -0400

In my opinion the tag is useful only if is a variable-length tag. Fixed
length is a compromise that make little sense.
I like the tag.

Dan

> -----Original Message-----
> From: Noveck, Dave [mailto:[email-masked]]
> Sent: Friday, September 21, 2001 9:45 AM
> To: [email-masked]'; [email-masked]
> Subject: RE: Issues list for RFC3010
>
>
> Spencer Shepler wrote: