Subject: Out-of-range data

From: Peter Åstrand <[email-masked]>
Date: Wed, 17 Oct 2001 16:04:23 +0200 (CEST)

How should a NFSv4 server respond upon a request with enum arguments, with
an invalid integer? For example, calling ACCESS with accessreq=0x00000040.

The CITI implementation accepts this and returns OK. Is this correct
behavior?

-- 
Peter Åstrand                Telephone: +46-13-29 08 61
Cendio Systems               E-mail: [email-masked]
Teknikringen 3
583 30 Linköping

---

From: "Kendrick M. Smith" <[email-masked]>
Date: Wed, 17 Oct 2001 13:37:29 -0400 (EDT)

I think that this should return an error, but it's not clear to me whether
the error should be ERR_INVAL or ERR_XDR.

Note: The current CVS version of our server returns ERR_XDR.

- k