Subject: RE: Replication/Migration conference call minutes, 5/29

From: "Noveck, Dave" <[email-masked]>
Date: Thu, 30 May 2002 11:19:48 -0700

Yes.  In NFS-v4, streams are called "named attributes".  Whether
they count as data or metadata (and people differ on this) the
migration/replication protocol has to deal with them.

-----Original Message-----
From: Yoder, Alan [mailto:[email-masked]]
Sent: Thursday, May 30, 2002 1:52 PM
To: 'Robert Thurlow'; [email-masked]
Subject: RE: Replication/Migration conference call minutes, 5/29

>   Brad raised another interesting issue: how should file
>   data and metadata be arranged on the wire?  

   Could I ask a possibly stupid question?
Are files with streams, as in NTFS or a NetApp
filer, covered by the considerations here?

Alan

===============================================================
Alan G. Yoder                                    [email-masked]
Network Appliance, Inc.                           
Sunnyvale, CA                                      408-822-6919
===============================================================

---

From: "Juan Gomez" <[email-masked]>
Date: Fri, 31 May 2002 11:58:36 -0700

My vote is for transferring as much state as possible and making these
events as transparent to the client as possible; following this path will
result in lower transfer latencies.

Juan

|---------+---------------------------------->
|         |           Robert Thurlow         |
|         |           <[email-masked]|
|         |           .com>                  |
|         |           Sent by:               |
|         |           owner-nfsv4-wg@sunroof.|
|         |           eng.sun.com            |
|         |                                  |
|         |                                  |
|         |           05/31/02 09:59 AM      |
|         |           Please respond to      |
|         |           Robert Thurlow         |
|         |                                  |
|---------+---------------------------------->
  >------------------------------------------------------------------------------------------------------------------------|
  |                                                                                                                        |
  |       To:       "J. Bruce Fields" <[email-masked]>                                                               |
  |       cc:       Robert Thurlow <[email-masked]>, [email-masked]                              |
  |       Subject:  Re: Replication/Migration conference call minutes, 5/29                                                |
  |                                                                                                                        |
  |                                                                                                                        |
  >------------------------------------------------------------------------------------------------------------------------|

...

> This doesn't solve the problem of transferring state, but
> no-one knows how to solve that problem anyway right now.  As a first
> attempt, we've said we're content with migrations that look to clients
> like server reboots.

Opinions vary, but state transfer is still of interest to some
as a way to get the best transparency.
...

Rob T