Subject: RE: [nfsv4] re: re: more on open with claim_delegate_prev

From: "Khan, Saadia" <[email-masked]>
Date: Fri, 12 Dec 2003 15:57:54 -0800

> Then in the 3rd para after the bullet points in 9.2.1:
> 	...consult stable storage so that the delegations can 
> be reclaimed.
> 	For open delegations, such delegations are reclaimed using OPEN
> 	with a claim type of CLAIM_DELEGATE_PREV.
> 
> and the comment on pg 170
> 	/* Right to file based on a delegation granted to a 
> previous boot
> 	 * instance of the client. File is specified by name.
> 	 */
> 
> To me, this seems to imply that the purpose of 
> CLAIM_DELEGATE_PREV is to reclaim those delegations. The 
> comment also seems to suggest that the open is based on the 
> old delegation. If the old delegation doesn't still exist, 
> does it make sense for the open to succeed?

IMHO, it does not make sense for the open to succeed if the server can
not give out a delegation with it. The server should return an error in
this case, maybe NFS4ERR_EXPIRED.

Saadia

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Trond Myklebust <[email-masked]>
Date: 12 Dec 2003 19:14:41 -0500

>>>>> " " == Saadia Khan <Khan> writes:

    >> comment also seems to suggest that the open is based on the old
    >> delegation. If the old delegation doesn't still exist, does it
    >> make sense for the open to succeed?

     > IMHO, it does not make sense for the open to succeed if the
     > server can not give out a delegation with it. The server should
     > return an error in this case, maybe NFS4ERR_EXPIRED.

What extra information does that convey to the client? It already
knows why the delegation is not being granted.

All you'd be doing is to force it to issue yet another open call over
the wire...

Cheers,
  Trond