Subject: RE: [nfsv4] Minor Versioning.

From: Mike Eisler <[email-masked]>
Date: Tue, 01 Feb 2005 12:57:18 -0800

For what is worth, many years ago, we had similar discussion about
minor version and asking the server for a detailed description of
what it supported, and the discussion was no less lively or
contentious. I think we came to Trond's conclusion:

 > A protocol with large numbers of optional features doesn't make sense
 > from an interoperability perspective.

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Brent Callaghan <[email-masked]>
Date: Tue, 01 Feb 2005 14:18:08 -0800

>  > from an interoperability perspective.

Though presumably one would have to make an exception
for the following list of "recommended" features  :-)

         ACL
         aclsupport
         archive
         cansettime
         case_insensitive
         case_preserving
         chown_restricted
         fileid
         files_avail
         files_free
         files_total
         fs_locations
         hidden
         homogeneous
         maxfilesize
         maxlink
         maxname
         maxread
         maxwrite
         mimetype
         mode
         no_trunc
         numlinks
         owner
         owner_group
         quota_avail_hard
         quota_avail_soft
         quota_used
         rawdev
         space_avail
         space_free
         space_total
         space_used
         system
         time_access
         time_access_set
         time_backup
         time_create
         time_delta
         time_metadata
         time_modify
         time_modify_set
         mounted_on_fileid

-------------

	  Brent

---

From: Robert Gordon <[email-masked]>
Date: Tue, 01 Feb 2005 16:38:31 -0600

> > from an interoperability perspective.

I don't think that anyone would disagree with that conclusion.

However, the RFC as it currently stands does not allow a mandatory
feature be introduced in a minor version..  of course a minor
version can alter that definition... and it also does not allow
the alteration of an existing operation.. which "rules out" the
modification of OP "2" ...  (this tar baby is very sticky i need
Gin, stat!)

Robert...