Subject: Re: [nfsv4] Minor Versioning.

From: Trond Myklebust <[email-masked]>
Date: Tue, 01 Feb 2005 10:47:26 -0800

må den 31.01.2005 Klokka 19:25 (-0600) skreiv Robert Gordon:

> > Why is the existing NFS4ERR_NOTSUPP insufficient for these purposes?
> 
> The proposal allows for a succinct up-front mechanism to ascertain
> the operations supported by the server in one round-trip. One could
> also figure out the minor versions supported by the server if the
> supported operations in the reply was zero.
>
> I don't see how one could achieve the same with NFS4ERR_NOTSUPP,
> maybe i'm missing something..

The minor version is always known to the client, since it supplies it as
an argument to COMPOUND. The server will return
NFS4ERR_MINOR_VERS_MISMATCH if it does not support that minor version.

Beyond that, NFS4ERR_NOTSUPP is sufficient to ascertain which ops
actually have been implemented. In practice it makes little sense for a
server to advertise a minor version if it does not actually implement
any of the features of that minor version, so we should be able to
assume that the number of unimplemented recommended features will always
be small.

Cheers,
  Trond
-- 
Trond Myklebust <[email-masked]>

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: "Noveck, Dave" <[email-masked]>
Date: Tue, 1 Feb 2005 14:58:55 -0500

> Robert's proposal would allow a server to choose not to implement all the
> features of a minor release.

How does it do that?  

I think that decision has yet to be made, and what facilities you provide
(or don't prvide) to interrogate the level of support doesn't affect that.

Right now, I think the idea is that all the features will be optional and
that does have the consequence that you can implement the minor version 
trivially, which is kind of annoying, but I don't see that it is worse 
than that.

-----Original Message-----
From: wurzl, mario [mailto:[email-masked]]
Sent: Tuesday, February 01, 2005 2:30 PM
To: 'Trond Myklebust'; Robert Gordon
Cc: [email-masked]
Subject: RE: [nfsv4] Minor Versioning.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Trond Myklebust
> Sent: Tuesday, February 01, 2005 1:47 PM
> To: Robert Gordon
> Cc: [email-masked]
> Subject: Re: [nfsv4] Minor Versioning.
> 

Robert's proposal would allow a server to choose not to implement all the
features of a minor release.

Mario