Subject: [nfsv4] NFSv4 error 10008

From: gueniche <[email-masked]>
Date: Mon, 14 Mar 2005 10:21:24 +0100

Hello all,

we have 2 linux/debian servers, alternatively nfs4 server and client

on the two machines I download debian packages
 (from 
http://www.citi.umich.edu/projects/nfsv4/debian/dists/unstable/main/binary-i386/) 
:

bsdutils_2.12.nfsv4-7_i386.deb
libnfsidmap1_0.1-1_i386.deb
mount_2.12.nfsv4-7_i386.deb
nfs-common_1.0.6.nfsv4-3_i386.deb
nfs-kernel-server_1.0.6.nfsv4-3_i386.deb
nhfsstone_1.0.6.nfsv4-3_i386.deb
util-linux_2.12.nfsv4-7_i386.deb
util-linux-locales_2.12.nfsv4-7_all.deb

and install them by dpkg -i *

server#> mkdir /home/NFS4
server#> cp foo* /home/NFS4

on server and client :
#> chown nobody /var/lib/nfs/sm
#> chown nobody /var/lib/nfs/state
because we've got this message at startup :
Mar 11 09:58:22 server rpc.statd[4635]: statd running as root. chown 
/var/lib/nfs/sm to choose different user

launch nfs :
  /etc/init.d/portmap start
  /etc/init.d/nfs-kernel-server start
  /etc/init.d/nfs-common start
stop nfs:
  /etc/init.d/nfs-common stop
  /etc/init.d/nfs-kernel-server stop
  /etc/init.d/portmap stop

on server and client rpcinfo -p :
   program vers proto   port
    100000    2   tcp    111  portmapper
    100000    2   udp    111  portmapper
    100003    2   udp   2049  nfs
    100003    3   udp   2049  nfs
    100003    4   udp   2049  nfs
    100003    2   tcp   2049  nfs
    100003    3   tcp   2049  nfs
    100003    4   tcp   2049  nfs
    100021    1   udp  32772  nlockmgr
    100021    3   udp  32772  nlockmgr
    100021    4   udp  32772  nlockmgr
    100021    1   tcp  32827  nlockmgr
    100021    3   tcp  32827  nlockmgr
    100021    4   tcp  32827  nlockmgr
    100005    1   udp   1016  mountd
    100005    1   tcp   1019  mountd
    100005    2   udp   1016  mountd
    100005    2   tcp   1019  mountd
    100005    3   udp   1016  mountd
    100005    3   tcp   1019  mountd
    100024    1   udp  32773  status
    100024    1   tcp  32828  status

server#> cat /etc/fstab
proc            /proc           proc    defaults        0       0
/dev/hda1       /               ext3    defaults,errors=remount-ro 0       1
/dev/hda6       /home           ext3    rw        0       2
/dev/hda5       none            swap    sw              0       0
/dev/hdc        /media/cdrom0   iso9660 ro,user,noauto  0       0
rpc_pipefs      /var/lib/nfs/rpc_pipefs rpc_pipefs      defaults        
0       0
nfsd            /proc/fs/nfsd   nfsd    defaults        0       0

server#> exportfs -v
/home/NFS4      
client.domain.fr(rw,wdelay,insecure,root_squash,no_subtree_check,fsid=0,anonuid=65534,anongid=65534)

server#> cat /etc/idmapd.conf
[General]
Verbosity = 1
Pipefs-Directory = /var/lib/nfs/rpc_pipefs
Domain = domain.fr
[Mapping]
Nobody-User = nobody
Nobody-Group = nogroup

when mount works fine (rare), we've got :
client#> mount -t nfs4 -v -o intr server:/ /mnt/NFS4
 server:/ on /mnt/NFS4 type nfs4 (rw,intr,addr=147.173.3.101)

but mostly we've got :
client#> mount -t nfs4 -v -o intr server:/  /mnt/NFS4
decode_getfattr: xdr error 10008!
nfs4_map_errors could not handle NFSv4 error 10008
mount: server:/: can't read superblock

(I have nothing on my logs and here is no filter between machines)

this bad mount can occur at first mount, when we try to swap client and 
server
(sometime necessary), or when we try to roll back, ...

In fact we can't work out what is the trick which triggers this strange 
behavior.
I have search accross the net and the documentations one week.
Do you have any hint about this ?

many thanks in advance and best regards
daniel

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Trond Myklebust <[email-masked]>
Date: Mon, 14 Mar 2005 10:39:16 -0500

> mount: server:/: can't read superblock

That bug is well known, and should be fixed in more recent kernels.

Cheers,
  Trond

-- 
Trond Myklebust <[email-masked]>