Subject: Re: [nfsv4] New I-D: draft-falkner-nfsv4-acls-00

From: [email-masked]
Date: Thu, 20 Oct 2005 17:19:52 -0700

At 11:11 AM -0700 10/19/05, Sam Falkner wrote:
>On Oct 18, 2005, at 12:14 PM, Andreas Gruenbacher wrote:

>>section 12 "ACE4_DELETE/ACE4_DELETE_CHILD Behavior" defines when files may be
>>deleted:

>>>       if ACE4_EXECUTE is denied by the parent directory ACL:
>>>          deny delete
>>>       else if ACE4_EXECUTE is unspecified by the parent directory ACL:
>>>          deny delete
>>>       else if ACE4_DELETE is allowed by the target object ACL:
>>>          allow delete
>>>       else if ACE4_DELETE_CHILD is allowed by the parent directory ACL:
>>>          allow delete
>>>       else if ACE4_DELETE_CHILD is denied by the parent directory ACL:
>>>          deny delete
>>>       else if ACE4_ADD_FILE is allowed by the parent directory ACL:
>>>          allow delete
>>>       else
>>>          deny delete

>>I'm surprised to see ACE4_ADD_FILE show up here. Would you mind explaining?
>>Thanks!

>Sure.  The idea is that ACE4_ADD_FILE is enabled (set on an ALLOW 
>ACE) whenever
>the directory is made writable (per section 5.3 of the draft). 
>Thus, if something like
>"chmod 777 <directory>" were done, then deletes on that directory 
>would be successful.

It looks as though making ACE4_DELETE denied on the target object will in no case alter the result.  That *is* surprising and if it is intentional I have to wonder why.

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Sam Falkner <[email-masked]>
Date: Thu, 27 Oct 2005 16:37:33 -0600

On Oct 20, 2005, at 6:19 PM, [email-masked] wrote:

> It looks as though making ACE4_DELETE denied on the target object  
> will in no case alter the result.  That *is* surprising and if it  
> is intentional I have to wonder why.

Yes, it is intentional.  It is the result of various emails and  
conversations at Bakeoff
and Connectathon.  It was believed to be compatible with Windows.   
Does anyone
think otherwise?

Regarding DELETE/DELETE_CHILD, I believe that this is how NetApp  
works today; can
anyone verify?  And I also think that although AIX does not work that  
way today, it might in
the future.  Note that I said DELETE/DELETE_CHILD; the bit about  
using ADD_FILE
is a new idea.

- Sam