Subject: RE: [nfsv4] exporting with multiple pNFS layout types

From: "Noveck, Dave" <[email-masked]>
Date: Mon, 9 Jan 2006 16:13:19 -0500

I would expect that clients will have a priority-ordered list
specified by the customer administrator based on hardware
installed, security preferenes, etc.  Some people will
have installed 4gb FC and want to use it if possible.
Some will prefer files if at all possible, due to issues
with the blocks security model.  So I would expect clients to 
simply go down the preference list and pick the first type
on the list that is supported by the server.

The customer could also express his preference by server
configuration, but that would only work if all clients supported
the layout type chosen.  If we are going to have situations
in which some clients only support A and some only support B then
the server has to export with both.  That means that, if there
are clients that support both, they have to be told by somebody
which one is to be preferred.  If the customer doesn't specify
a preference some default would have to be used.

-----Original Message-----
From: William A.(Andy) Adamson [mailto:[email-masked]] 
Sent: Monday, January 09, 2006 9:38 AM
To: Brent Welch
Cc: [email-masked]; [email-masked]
Subject: Re: [nfsv4] exporting with multiple pNFS layout types 

> 
> >>>"William A.(Andy) Adamson" said:
>  > 
>  > 
>  > do we really expect a file system to be exported with multiple
layout 
> types?
>       
>  > if so, how does a client choose which layout type to use?
>  > 
> 
> The client specifies the type in the "layout_type" parameter to
LAYOUTGET
> As noted by others, the client can query available types from
attributes.
> 
>      struct LAYOUTGET4args {
>              /* CURRENT_FH: file */
>              clientid4               clientid;
>              pnfs_layouttype4        layout_type;
>              pnfs_layoutiomode4      iomode;
>              offset4                 offset;
>              length4                 length;
>              length4                 minlength;
>              count4                  maxcount;
>      };
>  > 

this is how a client asks on the wire. my question is how does a client
choose 
between multiple available layouts for a given file. e.g. what criteria
do you 
have in mind that a client will use to choose between two valid and
available 
layout types?

say a client can use either block or file layout to access a file, and
that 
connectivity to all block/file data servers exists. which should a
client 
choose and why?

i'm just trying to get some background on the use cases that drive the
need 
for the added complexity of per file layout types.

-->Andy

>  > from draft-ietf-nfsv4-pnfs-00.txt:
>  > 
>  > 7.1  pnfs_layouttype4<> FS_LAYOUT_TYPES
>  > 
>  >    This attribute applies to a file system and indicates what
layout
>  >    types are supported by the file system.  We expect this
attribute to
>  >    be queried when a client encounters a new fsid.  This attribute
is
>  >    used by the client to determine if it has applicable layout
drivers.
>  > 
>  > 
>  > 7.2  pnfs_layouttype4<> FILE_LAYOUT_TYPES
>  > 
>  >    This attribute indicates the particular layout type(s) used for
a
>  >    file.  This is for informational purposes only.  The client
needs to
>  >    use the LAYOUTGET operation in order to get enough information
(e.g.,
>  >    specific device information) in order to perform I/O.
>  > 
>  > 
>  > 
>  > 
>  > 
>  > 
>  > _______________________________________________
>  > nfsv4 mailing list
>  > [email-masked]
>  > https://www1.ietf.org/mailman/listinfo/nfsv4
>  > 
>  > 
> 
> --
> Brent Welch
> Software Architect, Panasas Inc
> Accelerating Time to Results(tm) with Clustered Storage
> 
> www.panasas.com
> [email-masked]
> 

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: "J. Bruce Fields" <[email-masked]>
Date: Mon, 9 Jan 2006 17:01:32 -0500

On Mon, Jan 09, 2006 at 04:13:19PM -0500, Noveck, Dave wrote:
> So I would expect clients to simply go down the preference list and
> pick the first type on the list that is supported by the server.

That expectation needs to be mentioned in the spec, doesn't it?  (I
don't see it, at least in 7.1.)

--b.