Subject: RE: [nfsv4] pNFS - file commit

From: [email-masked]
Date: Fri, 17 Mar 2006 12:04:08 -0500

I just need a quick clarification:

If I understand the discussion correctly, the issue
centers around how to enhance the NFSv4 to make it
more efficient as a pNFS back-end storage protocol.
This sounds like a perfectly reasonable goal... but
if new operations are proposed as a result, how do we
classify them?  Are they a part of the generic pNFS
protocol?  Are they specific to the file layout?  Or
are they an optional part of the generic v4.1
enhancements, and independent of pNFS?

My concern is whether other types of servers (object,
block/volume, etc.) would be required to implement the
new operations, regardless of whether they add value for
that server's storage protocol.

-Steve  

> -----Original Message-----
> From: Dean Hildebrand [mailto:[email-masked]] 
> Sent: Friday, March 17, 2006 11:00 AM
> To: Marc Eshel
> Cc: Garth Goodson; [email-masked]
> Subject: Re: [nfsv4] pNFS - file commit
> 
> 
> >I really don't want get in to discussion of our server 
> internals. I don't 
> >think the rest of the people on the mailing list care how it 
> works or how 
> >it should work. If there is no one else out there that can 
> benefit from 
> >this proposal I will drop it. I though that PVFS2 can use it too.
> >
> >Marc.
> >  
> >
> The PVFS2 layout driver uses its own protocol for committing data.  
> Having said that, I think there are cases with every exported file 
> system where applications will want to use the file layout driver for 
> security reasons, etc, so it is an issue for most file systems that 
> wants to use pNFS.
> 
> Let me try to summarize the discussion so far (Let me know if 
> I'm wrong):
> "Data servers sometimes only manage data, and therefore would like a 
> commit operation that only commits data to stable storage.  Metadata 
> would be committed to disk by the MDS on layoutcommit."
> 
> Issues with allowing this way of syncing a file:
> 1) Will all data buffers need to be kept by the client until 
> layoutcommit?  I think this was another option and not part 
> of the above 
> scenario.
> 2) Certain vendors/file systems such as Netapp want to commit data + 
> metadata on each NFSv4 COMMIT operation to a data server.  How do we 
> distinguish what commit operation to use for each file system?  File 
> system attribute?
> 3) Does this scenario increase the number of required 
> layoutcommits?  I 
> don't think so.
> 
> Are the statement and the 3 issues correct?
> 
> -- 
> Dean Hildebrand
> Ph.D. Candidate
> University of Michigan
> 
> 
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nfsv4
> 

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Marc Eshel <[email-masked]>
Date: Fri, 17 Mar 2006 10:36:17 -0800

We should first agree that it is needed and than figure out how to add it 
to the protocol. In any case it would be optional information that the 
client gives the server. The server can make use of this information or 
ignore it without any impact to the client.
Marc.