Subject: RE: [nfsv4] ACCESS and the SYNCHRONIZE bit

From: Peter Varga <[email-masked]>
Date: Wed, 3 May 2006 10:52:26 -0400

It has meaning for local file access. Copying files over nfs should preserve
the ACL, and users should be able to view the ACLs of files over NFS.

Peter

> -----Original Message-----
> From: J. Bruce Fields [mailto:[email-masked]] 
> Sent: Wednesday, May 03, 2006 10:42 AM
> To: Peter Varga
> Cc: 'Yoder, Alan'; Lisa Week; [email-masked]
> Subject: Re: [nfsv4] ACCESS and the SYNCHRONIZE bit
> 
> 
> On Wed, May 03, 2006 at 10:44:28AM -0400, Peter Varga wrote:
> > As far as SYNCHRONIZE goes, it's meaningless over NFS. Look 
> at 5.11.2 in the
> > NFSv4 RFC:
> >  SYNCHRONIZE            Permission to access file locally at the
> >                           server with synchronous reads and writes
> > So, NFS just needs to save this bit when reading/writing 
> ACLs, it never
> > needs to evaluate the bit.
> 
> So no client *ever* needs to know whether the bit is permitted or not?
> Why are we bothering with it at all?
> 
> --b.
> 

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: "J. Bruce Fields" <[email-masked]>
Date: Wed, 3 May 2006 11:52:07 -0400

> the ACL, and users should be able to view the ACLs of files over NFS.

So in fact the only time the synchronize bit on an NFSv4 ACL is ever
used is after doing a

	cp /nfsv4_filesystem/file /local_filesystem/

and then doing something to /local_filesystem/file.

Which means the only time that NFSv4 ACL will ever be used is when it's
evaluated on the client (after the copy).

So SYNCHRONIZE is only ever used by clients evaluating the ACLs
themselves.  OK, OK, fair enough, I just find it amusing.

--b.

---

From: Spencer Shepler <[email-masked]>
Date: Wed, 3 May 2006 11:03:31 -0500

> themselves.  OK, OK, fair enough, I just find it amusing.

I believe the bit has the most significance when the file is 
being access locally at the server.  It will evaluate the bit
appropriately.

Spencer

---

From: "J. Bruce Fields" <[email-masked]>
Date: Wed, 3 May 2006 12:05:01 -0400

> being access locally at the server.  It will evaluate the bit

Oh, right, makes sense.--b.