Subject: RE: [nfsv4] Automatic inheritance of permissions

From: "Noveck, Dave" <[email-masked]>
Date: Tue, 20 Jun 2006 16:52:27 -0400

I would imagine that when permissions are changed within each
ancestor tree, the file would inherit those permissions, until
there was a change within the other ancestor tree.  It doesn't
sound like a good situation.  Windows I assume doesn't have
hard links so it isn't an issue for them.

-----Original Message-----
From: Jim Rees [mailto:[email-masked]] 
Sent: Tuesday, June 20, 2006 3:06 PM
To: Andreas Gruenbacher
Cc: [email-masked]
Subject: Re: [nfsv4] Automatic inheritance of permissions 

I can't imagine what would happen if a file had two sets of ancestors.

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Andreas Gruenbacher <[email-masked]>
Date: Thu, 22 Jun 2006 12:29:19 +0200

> hard links so it isn't an issue for them.

NTFS does have hard links, IIRC since forever. There is no way to create hard 
links in the standard GUI or with stock command-line utilities, but the 
Resource Kit has fsutil.exe, which allows to create hard links. (I didn't try 
fsutil.exe, but that's what a web search reveals.)

I don't know how clients are supposed to handle permission inheritance in the 
face of hardlinks; my guess would be that they ignore the potential 
inconsistencies. Which doesn't seem so bad an approach to me.

Andreas