Subject: [nfsv4] Issue 40: pNFS: DS and MDS with different security mechanisms in use

From: Mike Eisler <[email-masked]>
Date: Tue, 27 Jun 2006 10:06:17 -0700 (PDT)

Proposed text is at:

http://www.nfsv4-editor.org/cgi-bin/roundup/nfsv4/msg179

Let the discussion start now.

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Mike Eisler <[email-masked]>
Date: Wed, 28 Jun 2006 06:59:12 -0700 (PDT)

> Let the discussion start now.

For the purpose of archival (leaving aside the issue that
ietf.org's email archival is abysmal :-) the proposed text is:

Add to section 16.7 Security Considerations

-----------

The methods for authentication,
integrity, and privacy for file layout-based
data servers are the same as that used
for metadata servers. Metadata and data servers
use ONC RPC security flavors to 
authenticate, and SECINFO and SECINFO_NO_NAME
to negotiate the security mechanism and services
to be used.

For a given file object, a metadata server
MAY require different security parameters
(secinfo4 value) than the data server.
For a given file object with multiple data servers,
the secinfo4 value SHOULD be the same across
all data servers.

If an NFSv4.1 implementation supports parallel
NFS and supports file layouts, then the
implementation MUST support the SECINFO_NO_NAME operation,
on both the metadata and data servers.