Subject: [nfsv4] Bakeathon and NFSv4.1 testing

From: Lisa Week <[email-masked]>
Date: Tue, 15 Aug 2006 16:18:03 -0600

Hi,

For those attending Bakeathon and testing NFSv4.1 functionality, what dot-x file do people want to code to?

As you may have seen, dot-x file for NFSv4.1 has been posted at:
http://www.nfsv4-editor.org/draft05/nfs41_prot.x

Is this what people want to standardize on?

Thanks,
Lisa

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: "William A.(Andy) Adamson" <[email-masked]>
Date: Wed, 16 Aug 2006 13:45:43 -0400

hi lisa

we just had our linux pnfs client phone telecon, and we've agreed to 
investigate moving to http://www.nfsv4-editor.org/draft05/nfs41_prot.x. what 
we have now is a hodge-podge of pnfs features and xdr. we'll know early next 
week if we will move to the above nfs41_prot.x - it looks good.

are you bringing a Solaris pNFS client to test? any Solaris pNFS servers?

here is the list of pNFS bakeathon participants with basic funcitonality not 
including Solaris...

	- linux client (file layout, pvfs2 layout, some block layout)
	- PVFS2 server (file layout and pvfs2 layout)
	- GPFS server  (file layout)
	- NetApp server (file layout)
	- DESY/dCache server (file layout)
	- EMC server	(block layout)
	
any others?

basic functionality to test READ/WRITE
 	GETDEVICELIST, GETDEVICEINFO, LAYOUTGET, LAYOUTCOMMIT

we have not implemented any session code, and will not have any session code 
for pNFS bakeathon testing.

-->Andy

---

From: Benny Halevy <[email-masked]>
Date: Wed, 16 Aug 2006 21:01:14 +0300

> 	- EMC server	(block layout)
Panasas will be there too. (objects layout)

---

From: Benny Halevy <[email-masked]>
Date: Wed, 16 Aug 2006 22:18:30 +0300

We export the fs with linux-nfs so we depend on you folks for that :)

Benny

William A.(Andy) Adamson wrote:
> Great! can you update to http://www.nfsv4-editor.org/draft05/nfs41_prot.x in 
> time for the bakeathon?
>
> -->Andy
>
> [email-masked] said:
>

---

From: Lisa Week <[email-masked]>
Date: Wed, 16 Aug 2006 13:25:25 -0600

Hi Andy,

>week if we will move to the above nfs41_prot.x - it looks good.
Great!  Please keep us informed with what you decide.

>are you bringing a Solaris pNFS client to test? any Solaris pNFS servers?

Yes to both.  We will be bringing Solaris client and server (file 
layout) pNFS prototypes to test.

We have a little bit of work to do in order to change over to the agreed 
upon dot-x file, but it shouldn't be any different than what everyone 
else needs to do.

> 	GETDEVICELIST, GETDEVICEINFO, LAYOUTGET, LAYOUTCOMMIT
Got it!

>for pNFS bakeathon testing.

The Solaris protoype does not support sessions at this time so that is 
actually preferred for us. :)

Thanks,
Lisa

---

From: "William A.(Andy) Adamson" <[email-masked]>
Date: Wed, 16 Aug 2006 14:36:59 -0400

-->Andy

---

From: Spencer Shepler <[email-masked]>
Date: Wed, 16 Aug 2006 19:54:18 -0500

> > Panasas will be there too. (objects layout)

As a reminder, I am targeting the end of next week (Aug 24/25) for
another version of the I-D and corresponding nfs41_prot.x.

So, if updates need to be made we can get them in for that version...

Spencer

---

From: Garth Goodson <[email-masked]>
Date: Thu, 17 Aug 2006 09:39:39 -0700

Spencer,
One change that I would like to make is to go back to our old definition 
of newsize4.  It was:

union newsize4 switch (bool sizechanged) {
	case TRUE:
		length4	size;
	case FALSE:
		void;
};

Thanks,
-Garth

---

From: Spencer Shepler <[email-masked]>
Date: Thu, 17 Aug 2006 12:29:15 -0500

Okay.  Was there a mistake in editing or a change in semantics needed?

Spencer

On Thu, Garth Goodson wrote:
> >>Great! can you update to http://www.nfsv4-editor.org/draft05/nfs41_prot.x 
> >>in time for the bakeathon?
> >>
> >>-->Andy
> >>

---

From: Garth Goodson <[email-masked]>
Date: Thu, 17 Aug 2006 12:42:28 -0700

> Okay.  Was there a mistake in editing or a change in semantics needed?

I think newsize was never defined in the spec and I think I told you to 
just make it a length4 (however, I was wrong).  In the .x file there is 
a comment saying /* TEMPORARY definition */.  So I think it was just 
overlooked.  The intention is that it should be a switched union.

-Garth

---

From: Spencer Shepler <[email-masked]>
Date: Thu, 17 Aug 2006 22:13:54 -0500

Thanks, issue 106 will track this and it will be included in the next
draft update.

Spencer

On Thu, Garth Goodson wrote:
> >>>>Great! can you update to 
> >>>>http://www.nfsv4-editor.org/draft05/nfs41_prot.x in time for the 
> >>>>bakeathon?
> >>>>
> >>>>-->Andy
> >>>>

---

From: "William A.(Andy) Adamson" <[email-masked]>
Date: Mon, 28 Aug 2006 12:49:18 -0400

i just discoverd that the xdr definition of the fattr4_fs_layout_type:

enum layouttype4 {
	LAYOUT_NFSV4_FILES  = 1,
	LAYOUT_OSD2_OBJECTS = 2,
	LAYOUT_BLOCK_VOLUME = 3
};

typedef layouttype4	fattr4_fs_layout_type;

does not match the description in draft-06.

10.13.  fs_layout_type

This attribute applies to a file system and indicates what layout types are 
supported by the file system. We expect this attribute to be queried when a 
client encounters a new fsid. This attribute is used by the client to 
determine if it has applicable layout drivers.

fattr4_fs_layout_type should be a list of layouttype4.

perhaps an 's' should be added - fattr4_fs_layout_types

sorry i didn't catch this last week..

-->Andy

---

From: Spencer Shepler <[email-masked]>
Date: Mon, 28 Aug 2006 12:17:43 -0500

> perhaps an 's' should be added - fattr4_fs_layout_types

I have opened issue 117 for this.

This applies to the layout_type attribute as well, right?

so a diff for the dot-x might look like this?

*** 584,590 ****
  typedef nfstime4	fattr4_dir_notif_delay;
  typedef nfstime4	fattr4_dirent_notif_delay;
  typedef bool		fattr4_absent;
! typedef layouttype4	fattr4_fs_layout_type;
  /*
  typedef TBD		fattr4_fs_locations_info;
  */
--- 584,590 ----
  typedef nfstime4	fattr4_dir_notif_delay;
  typedef nfstime4	fattr4_dirent_notif_delay;
  typedef bool		fattr4_absent;
! typedef layouttype4	fattr4_fs_layout_types<>;
  /*
  typedef TBD		fattr4_fs_locations_info;
  */
***************
*** 592,598 ****
  typedef uint32_t	fattr4_layout_alignment;
  typedef uint32_t	fattr4_layout_blksize;
  typedef layouthint4	fattr4_layout_hint;
! typedef layouttype4	fattr4_layout_type;
  typedef nfs_impl_id4	fattr4_recv_impl_id;
  typedef impl_ident4	fattr4_send_impl_id;
  typedef mdsthreshold4	fattr4_mdsthreshold;
--- 592,598 ----
  typedef uint32_t	fattr4_layout_alignment;
  typedef uint32_t	fattr4_layout_blksize;
  typedef layouthint4	fattr4_layout_hint;
! typedef layouttype4	fattr4_layout_types<>;
  typedef nfs_impl_id4	fattr4_recv_impl_id;
  typedef impl_ident4	fattr4_send_impl_id;
  typedef mdsthreshold4	fattr4_mdsthreshold;

---

From: "William A.(Andy) Adamson" <[email-masked]>
Date: Mon, 28 Aug 2006 13:31:33 -0400

looks good. thanks

-->Andy