Subject: RE: [nfsv4] Automatic inheritance of permissions

From: "Yoder, Alan" <[email-masked]>
Date: Wed, 2 Aug 2006 09:09:28 -0700

I thought we were covered on this....

5.11.3.  ACE flag

   The "flag" field contains values based on the following descriptions.

   ACE4_FILE_INHERIT_ACE
      Can be placed on a directory and indicates that this ACE should be
      added to each new non-directory file created.

   ACE4_DIRECTORY_INHERIT_ACE
      Can be placed on a directory and indicates that this ACE should be
      added to each new directory created.

   ACE4_INHERIT_ONLY_ACE
      Can be placed on a directory but does not apply to the directory,
      only to newly created files/directories as specified by the above
      two flags.

   ACE4_NO_PROPAGATE_INHERIT_ACE
      Can be placed on a directory. ... 

Alan

===============================================================
Alan G. Yoder                                    [email-masked]
Technical Staff                           
Network Appliance, Inc.                            408-822-6919
=============================================================== 

> -----Original Message-----
> From: Spencer Shepler [mailto:[email-masked]] 
> Sent: Wednesday, August 02, 2006 9:01 AM
> To: [email-masked]
> Subject: Re: [nfsv4] Automatic inheritance of permissions
> 
> On Wed, Andreas Gruenbacher wrote:
> > On Wednesday, 02 August 2006 17:42, J. Bruce Fields wrote:
> > > > I disagree.  The impression I had from your previous 
> thread about this
> > > > was that it was up to the client application (the acl manageer
> > > > application) to push the inheritance through the descendants.
> > > >
> > > > As I mentioned at the time, there have been 2-3 threads 
> on this topic
> > > > in the past and they all seemed to result in the same 
> conslusion that
> > > > dynamic inheritance was part of the application not the 
> protocol.
> > >
> > > Right, that's what I remember to: it's client appliations that are
> > > responsible for propogating changes in inherited ACLs, 
> not servers.
> > 
> > Agreed.
> > 
> > > But that wasn't what Andreas was asking for; if I 
> remember correctly, he
> > > was just asking for another inheritance flag or two which 
> are used by
> > > those applications when doing the propogation.
> > 
> > It at least takes a new flag in the ACE flags field, and a 
> file attribute that 
> > indicates protected ACLs for clients to be able to 
> implement automatic 
> > inheritance. So even though the client should/may implement 
> this behavior, 
> > the protocol must be able to carry this information.
> 
> Okay, but Hummingbird, who have had an NFSv4 implementation 
> for awhile,
> have not mentioned the need for these features.  Hence, my request
> that someone from that team contribute to this thread.
> 
> Spencer
> 
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nfsv4
> 

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Andreas Gruenbacher <[email-masked]>
Date: Wed, 2 Aug 2006 18:19:24 +0200

> I thought we were covered on this....

Could you please check the thread starting with this message:

http://www1.ietf.org/mail-archive/web/nfsv4/current/msg03135.html

This will explain what automatic inheritance is, and hopefully why it would be 
a good idea to have it.

Andreas