Subject: RE: [nfsv4] Automatic inheritance of permissions

From: [email-masked]
Date: Wed, 2 Aug 2006 13:05:51 -0400

>> -----Original Message-----
>> From: Spencer Shepler [mailto:[email-masked]] 
>> Sent: Wednesday, August 02, 2006 11:38
>> To: Andreas Gruenbacher
>> Cc: [email-masked]
>> Subject: Re: [nfsv4] Automatic inheritance of permissions
>> 
>> On Wed, Andreas Gruenbacher wrote:
>> > Hello,
>> > 
>> > On Tuesday, 20 June 2006 20:55, Andreas Gruenbacher wrote:
>> > > I would like to propose to add a dynamic permission 
>> inheritance scheme to
>> > > the NFSv4 specification similar to Windows's automatic 
>> inheritance: as far
>> > > as I can tell, the NFSv4 ACL model is based on the 
>> Windows NT ACL model.
>> > 
>> > I think this detail deserves fixing in 4.1. Can anybody 
>> direct me what needs 
>> > to be done in order to have this extension proposed at the 
>> next WG meeting 
>> > (besides a proper specification what to implement how and why)?
>> 
>> I disagree.  The impression I had from your previous thread 
>> about this
>> was that it was up to the client application (the acl 
>> manageer application)
>> to push the inheritance through the descendants.
>> 
>> As I mentioned at the time, there have been 2-3 threads on this topic
>> in the past and they all seemed to result in the same conslusion that
>> dynamic inheritance was part of the application not the protocol.

At least this is how propagation works in Windows. When the ACL of a 
parent is modified, the client application traverses the tree and
propagates the changes.

>> 
>> Spencer
>> 
>> _______________________________________________
>> nfsv4 mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/nfsv4
>> 

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: "Yoder, Alan" <[email-masked]>
Date: Thu, 3 Aug 2006 14:40:36 -0700

> INHERITED_ACE =>
> 	*missing in NFSv4*
...
> The INHERITED_ACE flag is the one ACE flag neede for 
> Automatic Inheritance.

   Ah.  Okay, that needs to be fixed.  Sorry I wasn't
able to infer that from the long thread.  There are 
actually a number of flags needed for automatic
inheritance, AFAIK; I didn't realize you meant that 
INHERITED_ACE is the one flag *missing*.

> > Netapp's server supports automatic inheritance using these bits.
> 
> Counter question then: which flag does Netapp use as the 
> equivalent of the 
> Windows INHERITED_ACE flag then? NFSv4 does not have 
> Automatic Inheritance, 
> it only has inheritance at file/directory create time.

   I don't know which bit we use internally, but I doubt
we've tested automatic inheritance yet on v4, as the client
side support isn't there.  Our implementation works fine 
with Windows clients running over CIFS.

Alan