Subject: RE: [nfsv4] parallel opens in NFSv4.1 ?

From: Peter Varga <[email-masked]>
Date: Wed, 16 Aug 2006 11:22:58 -0400

> 
> On Tue, 2006-08-15 at 14:15 -0500, Spencer Shepler wrote:
> > It would likely ease the client implementation if it could 
> count on the 
> > server returning a different stateid (seqid++) at each 
> state changing
> > operation.  Is there interest in enforcing this stateid behavior so
> > the client's can have multiple OPENs in flight?
> 
> That would certainly resolve the ambiguity.
> 
> Cheers,
>   Trond

This should only be a requirement if the server returns different stateids
for the simulatenous OPENs. If the stateid is the same for all pending OPENs
for <open owner, file handle>, there is no concept of 'recent'. Aside from
the stateid.seqid field, I think most servers already return the same
stateid in 4.0.

Peter

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Spencer Shepler <[email-masked]>
Date: Wed, 16 Aug 2006 10:44:19 -0500

> the stateid.seqid field, I think most servers already return the same

In this case, the Solaris server is not "most"; it changes the stateid.

Spencer