Subject: [nfsv4] pnfs issue 57: private layout range

From: Garth Goodson <[email-masked]>
Date: Tue, 01 Aug 2006 16:17:58 -0700

I've created a paragraph on private vs standardized layout ranges.  I 
added it to the layouttype4 description, but am not sure if this is the 
best place.  It should reference the section describing the method for 
adding new layout types (issue 102).

-Garth

1.2.17.  layouttype4

    enum layouttype4 {
        LAYOUT_NFSV4_FILES  = 1,
        LAYOUT_OSD2_OBJECTS = 2,
        LAYOUT_BLOCK_VOLUME = 3
    };

    A layout type specifies the layout being used.  The implication is
    that clients have "layout drivers" that support one or more layout
    types.  The file server advertises the layout types it supports
    through the LAYOUT_TYPES file system attribute.  A client asks for
    layouts of a particular type in LAYOUTGET, and passes those layouts
    to its layout driver.

+  The layouttype4 structure is 32 bits in length.  The range
+  represented by the layout type is split into two parts.  Types
+  within the range 0x00000000-0x7FFFFFFF are globally unique and are
+  assigned according to the description in Section ??; they are
+  maintained by IANA.  Types within the range 0x8000000-0xFFFFFFFF are
+  site specific and for "private use" only [RFC2434].

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: [email-masked]
Date: Sun, 13 Aug 2006 19:58:15 -0400

Editors need to make sure that text such as this is also
reflected in the IANA Considerations section.  Don't remove
the text from its original location, as that's where non-IANA
readers will expect to find it.

Thanks,
--David

> -----Original Message-----
> From: Garth Goodson [mailto:[email-masked]] 
> Sent: Tuesday, August 01, 2006 7:18 PM
> To: [email-masked]
> Subject: [nfsv4] pnfs issue 57: private layout range
>