Subject: RE: [nfsv4] Automatic inheritance of permissions

From: "Yoder, Alan" <[email-masked]>
Date: Wed, 2 Aug 2006 09:50:21 -0700

They're copied and pasted out of RFC 3530.

Alan 

> -----Original Message-----
> From: Andreas Gruenbacher [mailto:[email-masked]] 
> Sent: Wednesday, August 02, 2006 9:39 AM
> To: Yoder, Alan
> Cc: [email-masked]
> Subject: Re: [nfsv4] Automatic inheritance of permissions
> 
> On Wednesday, 02 August 2006 18:27, Yoder, Alan wrote:
> > What I am saying is that I can't figure out why you think 
> it is missing.
> > The only other things you mention in your original post are included
> > in this list:
> >
> >    const ACE4_FILE_INHERIT_ACE             = 0x00000001;
> >    const ACE4_DIRECTORY_INHERIT_ACE        = 0x00000002;
> >    const ACE4_NO_PROPAGATE_INHERIT_ACE     = 0x00000004;
> >    const ACE4_INHERIT_ONLY_ACE             = 0x00000008;
> >    const ACE4_SUCCESSFUL_ACCESS_ACE_FLAG   = 0x00000010;
> >    const ACE4_FAILED_ACCESS_ACE_FLAG       = 0x00000020;
> >    const ACE4_IDENTIFIER_GROUP             = 0x00000040;
> 
> Huh? 
> http://www1.ietf.org/mail-archive/web/nfsv4/current/msg03135.h
> tml doesn't 
> mention these flags at all.
> 
> > What exactly are you proposing to add?
> 
> So the posting I pointed you at mentions the INHERITED_ACE 
> ACE flag, and the 
> SE_DACL_PROTECTED ACL flag. They are not included in the 
> NFSv4 or NFSv4.1 
> draft specifications, but they are necessary parts of 
> Automatic Inheritance, 
> which we currently can't express or implement. Just read the 
> thread; it 
> should be all there.
> 
> Andreas
> 

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Andreas Gruenbacher <[email-masked]>
Date: Wed, 2 Aug 2006 19:00:39 +0200

> They're copied and pasted out of RFC 3530.

Thanks, I could see that. I don't see what your argument is though: I'm 
talking about Automatic Inheritance while you're talking about the 
inheritance mechanisms defined in RFC3530, which is something completely 
different. I pointed you at the posting which explains what Automatic 
Inheritance is, and you again point me at RFC3530 --- so please, what's your 
point?

Thanks,
Andreas