Subject: RE: [nfsv4] Automatic inheritance of permissions

From: "Yoder, Alan" <[email-masked]>
Date: Wed, 2 Aug 2006 09:27:18 -0700

What I am saying is that I can't figure out why
you think it is missing.  The only other things
you mention in your original post are included
in this list:

   const ACE4_FILE_INHERIT_ACE             = 0x00000001;
   const ACE4_DIRECTORY_INHERIT_ACE        = 0x00000002;
   const ACE4_NO_PROPAGATE_INHERIT_ACE     = 0x00000004;
   const ACE4_INHERIT_ONLY_ACE             = 0x00000008;
   const ACE4_SUCCESSFUL_ACCESS_ACE_FLAG   = 0x00000010;
   const ACE4_FAILED_ACCESS_ACE_FLAG       = 0x00000020;
   const ACE4_IDENTIFIER_GROUP             = 0x00000040;

What exactly are you proposing to add?

Alan

===============================================================
Alan G. Yoder                                    [email-masked]
Technical Staff                           
Network Appliance, Inc.                            408-822-6919
=============================================================== 

> -----Original Message-----
> From: Andreas Gruenbacher [mailto:[email-masked]] 
> Sent: Wednesday, August 02, 2006 9:19 AM
> To: [email-masked]
> Cc: Yoder, Alan
> Subject: Re: [nfsv4] Automatic inheritance of permissions
> 
> On Wednesday, 02 August 2006 18:09, Yoder, Alan wrote:
> > I thought we were covered on this....
> 
> Could you please check the thread starting with this message:
> 
> http://www1.ietf.org/mail-archive/web/nfsv4/current/msg03135.html
> 
> This will explain what automatic inheritance is, and 
> hopefully why it would be 
> a good idea to have it.
> 
> Andreas
> 

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Andreas Gruenbacher <[email-masked]>
Date: Wed, 2 Aug 2006 18:38:50 +0200

On Wednesday, 02 August 2006 18:27, Yoder, Alan wrote:
> What I am saying is that I can't figure out why you think it is missing.
> The only other things you mention in your original post are included
> in this list:
>

Huh? http://www1.ietf.org/mail-archive/web/nfsv4/current/msg03135.html doesn't 
mention these flags at all.

> What exactly are you proposing to add?

So the posting I pointed you at mentions the INHERITED_ACE ACE flag, and the 
SE_DACL_PROTECTED ACL flag. They are not included in the NFSv4 or NFSv4.1 
draft specifications, but they are necessary parts of Automatic Inheritance, 
which we currently can't express or implement. Just read the thread; it 
should be all there.

Andreas