Subject: RE: [nfsv4] Raw notes from today's ACL meeting

From: "Yoder, Alan" <[email-masked]>
Date: Wed, 9 Aug 2006 18:35:58 -0700

> Stupid question of the thread:  How many people still use NFS V2?

Enough people to get us to change our server's behavior
in the past year.

Correction.  Enough INFLUENTIAL people. 

I don't like it either, but when some especially well-
funded customers say jump, you ask how high.

All that said, this was done for our v3 server.  It's probably
a worthwhile question to ask, should v2 be supported in v4?
What's the downside, these v2 people don't adopt v4?  ;>

And that said, if we decide not to support v2 clients, I'll ask
why POSIX ACL support is so important.  Netapp hasn't worried
about this--it's a good bit lower on our worry list than v2 
even, to my knowledge--and it hasn't hurt us much, if at all.

<somewhat tongue in cheek>

Alan

===============================================================
Alan G. Yoder                                    [email-masked]
Technical Staff                           
Network Appliance, Inc.                            408-822-6919
===============================================================

> -----Original Message-----
> From: Eric Werme USG [mailto:[email-masked]] 
> Sent: Wednesday, August 09, 2006 3:38 PM
> To: Yoder, Alan
> Cc: [email-masked]
> Subject: Re: [nfsv4] Raw notes from today's ACL meeting 
> 
> 
>    > Enable POSIX compliance
> 
> Alan  Yoder noted:
> 
>    This needs to be optional to support if it involves any 
> unnatural acts.
> 
> It may be worthwhile to consider NFS V2 an unnatural act.  (I just
> noticed a bug yesterday in the "static pathconf kludge" that was in
> ONC 4.2 and has faithfully shipped in Tru64 Unix since 1993.  Sigh.)
>    
>    > - Bruce said to add: "Don't allow the the permissions to be more
>    permissive than what would be given when setting the 
> mode."  This was
>    agreed to be a good thing.
>    
>    Caveat: as I said before, this can cause v2 clients to mistakenly
>    assume they can't access a file in some cases, when they 
> actually could.
>    That's because you end up using a mode less permissive 
> than the ACL,
>    if you've been told not to use one that's more permissive.
>    I'd like to see the standard allow more permissive modes in v2 stat
>    calls to work around this issue.
> 
> A problem in well behaved V2 clients is that the two levels of access
> checking (mode bits on the client, anything at all on the 
> server) isn't
> always applied.  If someone with access to a file reads it, and the
> data is left in the client cache, someone else who tries to read it
> will have only the client mode check applied.  While this might
> argue for the more restrictive bits, that leaves Alan's concern.
> Recommend against caching V2 data?  Gack!  Warn people of the problem
> and tell them to disable V2?
> 
> Stupid question of the thread:  How many people still use NFS V2?
> And are they all Cobol programmers?  And please don't forget the Cobol
> program that actually used "Unix file record locking" to lock offset
> 5-6 to refer to bytes 400-560.  (80 column fixed length 
> records and all
> that - as Ric types into his 80 column emacs window.)
> 
> 	-Ric Werme
> 

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Spencer Shepler <[email-masked]>
Date: Wed, 9 Aug 2006 23:36:37 -0500

> even, to my knowledge--and it hasn't hurt us much, if at all.

Moving forward, I am not very interested in NFSv2 clients and
am certainly willing to make the suggestion that customers 
finally move forward and disable NFSv2 access.

I am also not interested much in draft-Posix ACL support.
We have the best chance in recent history to pull together the
NFS community around NFSv4 ACLs and it seems to be moving forward;
let's make it work (rah, rah, go team :-)).

Resolve the issues of NFSv4 ACLs in a Posix environment and
let's move forward to other problems that need to be addressed.

Spencer