Subject: RE: [nfsv4] Automatic inheritance of permissions

From: "Yoder, Alan" <[email-masked]>
Date: Wed, 2 Aug 2006 10:57:44 -0700

My point is that, to my knowledge, these are the
same bits used by Windows to do automatic inheritance;
Carl derived them from Microsoft documents.  Netapp's
server supports automatic inheritance using these
bits.  So I'm not sure what you're asking for that's
not already in the spec.  The explanation you pointed
me to just describes what we already have, in my eyes.

We may need language to describe the role of clients
in automatic inheritance.  Is that what you're asking
for?  Sorry if I'm missing something else, but I'm 
REALLY missing it.

Alan 

> -----Original Message-----
> From: Andreas Gruenbacher [mailto:[email-masked]] 
> Sent: Wednesday, August 02, 2006 10:01 AM
> To: Yoder, Alan
> Cc: [email-masked]
> Subject: Re: [nfsv4] Automatic inheritance of permissions
> 
> On Wednesday, 02 August 2006 18:50, Yoder, Alan wrote:
> > They're copied and pasted out of RFC 3530.
> 
> Thanks, I could see that. I don't see what your argument is 
> though: I'm 
> talking about Automatic Inheritance while you're talking about the 
> inheritance mechanisms defined in RFC3530, which is something 
> completely 
> different. I pointed you at the posting which explains what Automatic 
> Inheritance is, and you again point me at RFC3530 --- so 
> please, what's your 
> point?
> 
> Thanks,
> Andreas
> 

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Andreas Gruenbacher <[email-masked]>
Date: Wed, 2 Aug 2006 22:59:38 +0200

> same bits used by Windows to do automatic inheritance;

That's simply not the case. Please check the references in 
http://www1.ietf.org/mail-archive/web/nfsv4/current/msg03174.html; that's why 
I pointed you at this [email-masked] thread. Windows has the following ACE 
flags (found in the first of those references):

CONTAINER_INHERIT_ACE =>
	ACE4_DIRECTORY_INHERIT_ACE
FAILED_ACCESS_ACE_FLAG =>
	ACE4_FAILED_ACCESS_ACE_FLAG
INHERIT_ONLY_ACE =>
	ACE4_INHERIT_ONLY_ACE
INHERITED_ACE =>
	*missing in NFSv4*
NO_PROPAGATE_INHERIT_ACE =>
	ACE4_NO_PROPAGATE_INHERIT_ACE
OBJECT_INHERIT_ACE =>
	ACE4_FILE_INHERIT_ACE
SUCCESSFUL_ACCESS_ACE_FLAG =>
	ACE4_SUCCESSFUL_ACCESS_ACE_FLAG

The INHERITED_ACE flag is the one ACE flag neede for Automatic Inheritance.

> Carl derived them from Microsoft documents.

Automatic Inheritance was added in Windows 2000, and this feature definitely 
is not supported in NFSv4, no matter who derived what from where.

> Netapp's server supports automatic inheritance using these bits.

Counter question then: which flag does Netapp use as the equivalent of the 
Windows INHERITED_ACE flag then? NFSv4 does not have Automatic Inheritance, 
it only has inheritance at file/directory create time.

Andreas