Subject: RE: [nfsv4] NFSv4.1 retention attribute proposal (Yoder / Black)

From: "Yoder, Alan" <[email-masked]>
Date: Tue, 5 Sep 2006 10:05:40 -0700

Unfortunately, XAM is being developed inside
of SNIA, which makes it inaccessible to non-SNIA
members.  

XAM is a management and access protocol for fixed
content storage devices, the most well-known of
which is EMC's Centera.

If your company is a member of SNIA, you can join
the FCAS Technical Working Group and read all about
it in the Documents section of the group web pages.
Otherwise, please just ask questions to be answered
here.

Cheers,

Alan

===============================================================
Alan G. Yoder                                    [email-masked]
Technical Staff                           
Network Appliance, Inc.                            408-822-6919
===============================================================

> -----Original Message-----
> From: Peter Staubach [mailto:[email-masked]] 
> Sent: Tuesday, September 05, 2006 7:49 AM
> To: Yoder, Alan; [email-masked]
> Cc: [email-masked]
> Subject: Re: [nfsv4] NFSv4.1 retention attribute proposal 
> (Yoder / Black)
> 
> Spencer Shepler wrote:
> > Alan Yoder and David Black have submitted an individual draft
> > outlining a proposal for retention attributes for NFSv4.1.
> >
> > You will find the draft here:
> >
> > 
> http://www.ietf.org/internet-drafts/draft-yoder-nfsv4-retention-00.txt
> 
> Hi.
> 
> There seems to be lots of references to "XAM", but without an 
> explanation
> of what XAM is or a pointer to it.  Would it be possible to 
> add this to
> this document?
> 
>     Thanx...
> 
>        ps
> 

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Peter Staubach <[email-masked]>
Date: Tue, 05 Sep 2006 13:32:47 -0400

> of SNIA, which makes it inaccessible to non-SNIA

Unfortunate.  This will slow down the development of an open source
implementation.  :-)

Just for grins, what do XAM and FCAS stand for?

> Otherwise, please just ask questions to be answered
  
I don't know whether we are members or not.

Perhaps it would be sufficient to remove paragraphs like: "Setting the
ebtime is the equivalent to an event notification operation in XAM.".

I also found the references to "TWG" slightly confusing as it took a
little work to figure out that they referred to the SNIA technical
working group instead of the IETF NFSv4 working group.  (Or The
Wollongong Group.)

---

Although this sort of thing sounds like it could be useful, adding
support to the protocol for proprietary support seems less than
optimal to me.  Are there other data retention architectures being
proposed in the industry and will this support work for all of them
as well?

    Thanx...

       ps

---

From: Spencer Shepler <[email-masked]>
Date: Tue, 5 Sep 2006 13:33:02 -0500

> proposed in the industry and will this support work for all of them

Although the I-D didn't provide additional context, the intent of the 
proposal it to suggest a framework that acknowledges existing NFS
retention products.  

Most/all? of those products provide retention capabilities by 
overloading existing NFS attributes.  Instead of overloading 
existing attributes, it seems prudent to make an attempt to define 
a set of NFSv4.1 attributes that can encompass today's existing practice.

Given SNIA's existing discussion of this topic, it seemed worthwhile
to understand if something could be used from that effort in a way
that defines an openly defined set of retention attributes in NFSv4.1.

Spencer