Subject: [nfsv4] pNFS and metadata-intensive environments

From: "Touretsky, Gregory" <[email-masked]>
Date: Thu, 21 Sep 2006 21:28:09 +0300

Hi,

  pNFS architecture seems to be great solution for IO-intensive flows.
However, considering metadata-intensive environment (80% of NFSops are
getattr/lookup/access) and zillions of very small files (<10KB) - single
MD server would become a bottleneck. Are there thoughts to overcome such
a bottleneck, or it's considered too niche situation to deal with?

Gregory Touretsky
Intel IT - PCAM/EC EPT
Compute & Storage Platforms Technical Engineering Mgr
gregory.touretsky AT intel.com
> (+) 972-4-865-6377, Fax: 04-865-5999
iNET: 465-6377, M/S: IDC-1B

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: "Noveck, Dave" <[email-masked]>
Date: Thu, 21 Sep 2006 17:03:48 -0400

Actually I wasn't suggesting dynamic load-balancing but using a more
static allocation using referrals.  With clustered filesystems there 
are a number options that do allow you to be more dynamic, though.

I do have a slight terminological quibble.  Although it is true that 
in the load-balancing scenario that Marc is talking about, clients
will be "referred to" other servers in the normal sense of those words,
for v4 we reserve the use of "referrals" for those case in which a 
client, who does not have any state or knowledge of a particular fs,
is referred to its location.  Where there is existing state on 
the client we typically refer to this as "migration", even in cases
where the servers front-end a clustered fs and no data actually moves 
at all.  From the client's point of view, what is important is that
the responsiblity for handling a given part of the namespace has
been transferred or migrated between (MD) servers and that is what 
is significant from his point of view. 

-----Original Message-----
From: Marc Eshel [mailto:[email-masked]] 
Sent: Thursday, September 21, 2006 4:46 PM
To: Touretsky, Gregory; [email-masked]
Subject: RE: [nfsv4] pNFS and metadata-intensive environments

With a cluster file system at the backend you can run MD servers on each

node in the cluster. You can distribute you clients among the MD servers

using a  something like DSN round robin or a more dynamic solution with 
referrals (like Dave's suggested) that allows you to move clients from 
loaded MD server to a less loaded one.
Marc. 

"Noveck, Dave" <[email-masked]> 
09/21/2006 11:52 AM

To
"Touretsky, Gregory" <[email-masked]>, <[email-masked]>
cc

Subject
RE: [nfsv4] pNFS and metadata-intensive environments

If you can tolerate dividing your zillions of small files into multiple 
directories then the answer is put those directories on multiple
metadata 
servers and tie them into a single multi-server namespace via referrals.

V4.0 had support for this but v4.1 is more explicit about this.  Only in

the case of zillions of small files in a single directory do you have 
something that v4.1 won't be able to deal with.
-----Original Message-----
From: Touretsky, Gregory [mailto:[email-masked]] 
Sent: Thursday, September 21, 2006 2:28 PM
To: [email-masked]
Subject: [nfsv4] pNFS and metadata-intensive environments

Hi,

MD server would become a bottleneck. Are there thoughts to overcome such
a 
bottleneck, or it's considered too niche situation to deal with?
Gregory Touretsky
Intel IT - PCAM/EC EPT
Compute & Storage Platforms Technical Engineering Mgr
gregory.touretsky AT intel.com
(+) 972-4-865-6377, Fax: 04-865-5999
iNET: 465-6377, M/S:
IDC-1B_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4