Subject: [nfsv4] layoutreturn4 missing in draft-07

From: Benny Halevy <[email-masked]>
Date: Mon, 23 Oct 2006 18:16:02 +0200

Spencer,

It looks like the definition of layoutreturn4 is missing from section 16.44
in draft-07. It was included in draft-05 as part of fixing issue 58 and is
still in the .x file.

I think that the following section was moved to the front of nfsv41.x
as part of "data structures new to NFSv4.1" and therefore
it's not automatically generated by your scripts...

Benny

enum layoutreturn_type4 {
	LAYOUTRETURN_FILE = 1,
	LAYOUTRETURN_FSID = 2,
	LAYOUTRETURN_ALL  = 3
};

struct layoutreturn_file4 {
	offset4		lrf_offset;
	length4		lrf_length;
};

union layoutreturn4 switch(layoutreturn_type4 returntype) {
	case LAYOUTRETURN_FILE:
		layoutreturn_file4	lr_layout;
	default:
		void;
};

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Spencer Shepler <[email-masked]>
Date: Mon, 23 Oct 2006 11:39:55 -0500

Thanks for pointing this out, Benny.

I have created issue 137 to track the correction.

Spencer