Subject: RE: [nfsv4] SEQUENCE and lease renewal clarification

From: "Noveck, Dave" <[email-masked]>
Date: Wed, 8 Nov 2006 15:28:30 -0500

> nit: except for the instance that SEQUENCE returns one of the
*_STATE_REVOKED
> values in sr_status.

I don't agree.  For the cases where * is one of SOME, ADMIN, RECALLABLE,
it is not the case that all of the locking state be gone.  It is quite
possible that one or more locks have been revoked but that others have
not been.  In this case, if SEQUENCE doe snot return an error, then the
lease, including all locks not revoked should be renewed.

In the ALL_STATE_REVOKED case and in the other case in which one or more
locks were revoked and there were none left unrevoked, then you could 
argue that there would be no lease to renew but I'm inclined to say
that the fact that you have still have pedning state to be reaped by
FREE_BADLOCK constitutes leasable state, and so there doesn't need to
be an exception even in these cases.

-----Original Message-----
From: Spencer Shepler [mailto:[email-masked]] 
Sent: Thursday, November 02, 2006 12:26 PM
To: [email-masked]
Subject: Re: [nfsv4] SEQUENCE and lease renewal clarification

On Thu, Mike Eisler wrote:
> 
> > -----Original Message-----
> > From: Karen Rochford [mailto:[email-masked]] 
> > Sent: Thursday, November 02, 2006 10:14 AM
> > To: [email-masked]; [email-masked]
> > Subject: [nfsv4] SEQUENCE and lease renewal clarification
> > 
> > Hi,
> > 
> > Need some clarification on SEQUENCE and lease renewal, can not find
> > this
> > 
> > info in the current draft-ietf-nfsv4-minorversion1-08 draft.
> > 
> > I'm assuming, that if a SEQUENCE op fails (say due to 
> > NFS4ERR_SEQ_MISORDERED), the lease is NOT renewed, and I'm also
> > assuming
> > 
> > that if the SEQUENCE is completed from the replay cache, that the
> > lease 
> > IS renewed?  However I do not see clear indicated of this in the
> > draft. 
> >   I do see, "Each time a session is used, the state leased to it 
> > associated clientid is automatically renewed".  However its not
clear
> > 
> > what "used" really means.
> 
> Karen, (and Thomas),
> 
> Thanks for raising some excellent points.
> 
> One of the things that was difficult about NFSv4.0 was that
> some errors caused the sequence number to be bumped, and
> others resulted in no change in sequence number. And I
> have no idea whether some errors updated the lease or not.
> 
> I propose we keep it very simple: 
>   If SEQUENCE returns NFS4_OK, the lease is updated (and the session
>   is also kept alive)
> 
>   If SEQUENCE returns anything other that NFS4_OK, the lease is not
>   updated (and the session continues to be idle).

nit: except for the instance that SEQUENCE returns one of the
*_STATE_REVOKED
values in sr_status.

Spencer

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Spencer Shepler <[email-masked]>
Date: Thu, 9 Nov 2006 02:21:20 -0600

> be an exception even in these cases.

Okay, that discussion should be placed in the I-D.

Spencer