Subject: RE: [nfsv4] ACL discussion wrapup

From: "Yoder, Alan" <[email-masked]>
Date: Sun, 12 Nov 2006 16:09:18 -0800

Yeah, it's fine with me, with a couple twiddles:

	In the case where the request that creates a new file or
	directory does not also set permissions for that file or
	directory, and there are also no ACEs inherited from the
	parent's directory, then the server's choice of ACL for the new
	object is implementation-dependent.  In this case, the server
	SHOULD set the DEFAULTED flag on the ACL it chooses for the new
	object.  An application performing automatic inheritance takes
	the DEFAULTED flag as a sign that the ACL should be completely
	replaced by one generated using the auto inheritance rules.

(changed should to SHOULD, changed last line).

Alan 

> -----Original Message-----
> From: J. Bruce Fields [mailto:[email-masked]] 
> Sent: Sunday, November 12, 2006 3:59 PM
> To: Yoder, Alan
> Cc: Khan, Saadia; [email-masked]; Andreas Gruenbacher
> Subject: Re: [nfsv4] ACL discussion wrapup
> 
> On Sun, Nov 12, 2006 at 03:18:59PM -0500, J. Bruce Fields wrote:
> > On Sun, Nov 12, 2006 at 12:05:32PM -0800, Yoder, Alan wrote:
> > > > Setting the DEFAULTED flag on an ACL is then 
> effectively equivalent to
> > > > setting the INHERITED bit on every ACE in the ACL. 
> > > 
> > > No it is not.  The INHERITED bit should only be set on ACEs
> > > that are actually inherited when a client does an auto
> > > inherit pass through the directory tree that includes
> > > the file or directory in question.
> > 
> > Right.  But in terms of *effect*, the two situations are
> > identical--either way every ACE in the ACL is discarded 
> when automatic
> > inheritance is performed.
> 
> But I suppose that doesn't mean it couldn't be useful as some sort of
> documentation of where the ACL came from?
> 
> I don't know.  Does the language I suggested sound OK?
> 
> --b.
> 

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: "J. Bruce Fields" <[email-masked]>
Date: Mon, 13 Nov 2006 12:06:03 -0500

> (changed should to SHOULD, changed last line).

OK.  I'll wait for any more feedback, then try to put out an updated
version of the proposed automatic inheritance language next week, with
the addition of this flag.

And thanks for the review.

The one last thing I really wish someone could do would be to run some
tests on a recent version of Windows to make sure it actually behaves as
documented.  I'm probably not going to have the chance any time soon.

--b.