Subject: [nfsv4] OWNER@/GROUP@ discussion

From: "J. Bruce Fields" <[email-masked]>
Date: Fri, 8 Dec 2006 13:23:36 -0500

There's at least one server implementation that emulates OWNER@/GROUP@;
is this worth documenting?

--b.

diff --git a/nfsv41_middle_fileattributes_acls.xml b/nfsv41_middle_fileattributes_acls.xml
index 7a34239..554b74f 100755
--- a/nfsv41_middle_fileattributes_acls.xml
+++ b/nfsv41_middle_fileattributes_acls.xml
@@ -790,7 +790,14 @@
                     form "xxxx@" (note: no domain name after the "@"). For
                     example: ANONYMOUS@.
                 </t>
-
+		<t>
+		    Servers SHOULD store OWNER@ and GROUP@ ACEs in such a way
+		    that they will continue to apply to the file's owner and
+		    owner_group even after those attributes change.  Some
+		    servers may, however, map OWNER@ and GROUP@ to the user
+		    and group that are the file's owner and owner_group at
+		    the time the ACL is set.
+		</t>
                 <section title="Discussion of EVERYONE@">
                     <t>
                         It is important to note that "EVERYONE@" is not

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Sam Falkner <[email-masked]>
Date: Sun, 10 Dec 2006 20:53:01 -0700

> is this worth documenting?

Yes -- I think it's worth documenting.  I think your text (below) is  
good.

- Sam