Subject: [nfsv4] sr_status_flags.

From: Robert Gordon <[email-masked]>
Date: Wed, 1 Aug 2007 04:11:17 -0500

Should be (if not already) bumped to a 64 bit value.

Draft 12:

> struct SEQUENCE4resok {
>         sessionid4      sr_sessionid;
>         sequenceid4     sr_sequenceid;
>         slotid4         sr_slotid;
>         slotid4         sr_highest_slotid;
>         slotid4         sr_target_highest_slotid;
>         uint32_t        sr_status_flags;
> };

-- Robert.

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: "Noveck, Dave" <[email-masked]>
Date: Wed, 1 Aug 2007 09:16:46 -0400

Why?  We are only using 11 bits now.  Maybe there will be a few more in
4.1.  I can see that bits might be added in future minor versions but
for any minor version we have the option of creating a NEW_SEQUENCE op.
So is it really worth it to expand it now?  Also, with 64 bits, I have a
fear that this feature will be overused.  In fact, we might run out just
as soon with 64 bits as we would have with 32. 

-----Original Message-----
From: Robert Gordon [mailto:[email-masked]] 
Sent: Wednesday, August 01, 2007 5:11 AM
To: NFSv4
Subject: [nfsv4] sr_status_flags.

-- Robert.

---

From: Robert Gordon <[email-masked]>
Date: Wed, 1 Aug 2007 10:18:51 -0500

On Aug 1, 2007, at 8:16 AM, Noveck, Dave wrote:

> Why?

I was anticipating further overuse/abuse :-) .. We can leave it as is.

Robert.