Subject: [nfsv4] draft13 nfsv41.x fattr4 naming inconsistencies

From: Fredric Isaman <[email-masked]>
Date: Mon, 10 Sep 2007 16:00:12 -0400 (EDT)

Comparing the fattr4_* types with the FATTR4_* constants
(which should be identical but for case)...

fattr4_fs_layout_types vs FATTR4_FS_LAYOUT_TYPE
fattr4_layout_types vs FATTR4_LAYOUT_TYPE
   (given they are arrays, the plural form seems better)

fattr4_layout1_blksize vs FATTR4_LAYOUT_BLKSIZE
   (I assume the '1' is a typo)

fattr4_recv_impl_id vs ??? (not used/mentioned anywhere)
fattr4_send_impl_id vs ??? (not used/mentioned anywhere)

 	Fred

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Spencer Shepler <[email-masked]>
Date: Tue, 11 Sep 2007 17:54:44 -0500

>   (given they are arrays, the plural form seems better)

Agreed.  Will change.

> fattr4_send_impl_id vs ??? (not used/mentioned anywhere)

Should be removed given the functionality has moved
to the EXCHANGE_ID operation.

Updates in draft14

Spencer