Subject: [nfsv4] I-D Action:draft-ietf-nfsv4-minorversion1-17.txt

From: [email-masked]
Date: Mon, 19 Nov 2007 03:50:02 -0500

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network File System Version 4 Working Group of the IETF.

	Title           : NFSv4 Minor Version 1
	Author(s)       : S. Shepler, et al.
	Filename        : draft-ietf-nfsv4-minorversion1-17.txt
	Pages           : 538
	Date            : 2007-11-19

This Internet-Draft describes NFSv4 minor version one, including
features retained from the base protocol and protocol extensions made
subsequently.  The current draft includes description of the major
extensions, Sessions, Directory Delegations, and parallel NFS (pNFS).
This Internet-Draft is an active work item of the NFSv4 working
group.  Active and resolved issues may be found in the issue tracker
at: http://www.nfsv4-editor.org/cgi-bin/roundup/nfsv4.  New issues
related to this document should be raised with the NFSv4 Working
Group [email-masked].

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-nfsv4-minorversion1-17.txt

To remove yourself from the I-D Announcement list, send a message to
[email-masked] with the word unsubscribe in the body of 
the message.
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the 
username "anonymous" and a password of your e-mail address. After 
logging in, type "cd internet-drafts" and then
	"get draft-ietf-nfsv4-minorversion1-17.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-nfsv4-minorversion1-17.txt".

NOTE:   The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Benny Halevy <[email-masked]>
Date: Mon, 19 Nov 2007 20:27:22 +0200

a few typo fixes below...

Benny

--- a/nfsv41_middle_errors.xml
+++ b/nfsv41_middle_errors.xml
@@ -418,7 +418,7 @@ request will be terminated.

       <c>NFS4ERR_RECALLCONFLICT</c>
       <c>10061</c>
-      <c>A layout, delgation, or device map is unavailable due to a
+      <c>A layout, delegation, or device map is unavailable due to a
       conflicting recall operation that is in
       progress.</c>

@@ -558,7 +558,7 @@ request will be terminated.

       <c>NFS4ERR_WRONG_CRED</c>
       <c>10082</c>
-      <c>An operation mannipulating state was performed by a principal
+      <c>An operation manipulating state was performed by a principal
       that was not allowed to modify that piece of state.</c>

       <c>NFS4ERR_WRONG_TYPE</c>
--- a/nfsv41_middle_file_layout.xml
+++ b/nfsv41_middle_file_layout.xml
@@ -273,7 +273,7 @@
     COMMIT operations to the metadata server or data server, and the
     stripe unit size. If a server returns two or
     more overlapping layouts, each stripe unit size in
-    each overlapper layout MUST be the same.
+    each overlapping layout MUST be the same.
    </t>

    <t>
--- a/nfsv41_middle_iana_considerations.xml
+++ b/nfsv41_middle_iana_considerations.xml
@@ -29,7 +29,7 @@
  </section>
  <section anchor="netid_iana" title="ONC RPC Network Identifiers (netids)">
    <t>
-     The sub-section on the netaddr4 data srucure within the section
+     The sub-section on the netaddr4 data structure within the section
      "Structured Data Types" (<xref target="netaddr4" />)
      discussed the r_netid field and
      the corresponding r_addr field within a netaddr4 structure.  The NFS
--- a/nfsv41_middle_op_layoutreturn.xml
+++ b/nfsv41_middle_op_layoutreturn.xml
@@ -33,9 +33,9 @@
     </t>
     <t>
       If the set of layouts designated in the case of
-      LAYOUTRETURN4_FSID or LAYOUTRETURN4_ALL is empty, than no error
+      LAYOUTRETURN4_FSID or LAYOUTRETURN4_ALL is empty, then no error
       results.  In the case of LAYOUTRETURN4_FILE, the byte range
-      specified is return evened if that is a subdivision of a layout
+      specified is returned even if that is a subdivision of a layout
       previously obtained with LAYOUTGET, a combination of multiple
       layouts previously obtained with LAYOUTGET, or a combination
       including some layouts previously obtained with LAYOUTGET,
@@ -129,10 +129,10 @@
       updated for this operation's processing; the current stateid
       will also be updated to match the returned value.  If the
       last byte of any layout for the current file, client ID, and
-      layout type is being return and there are not remaining
-      pending CB_LAYOUTRECALL operation for which a LAYOUTRETURN
-      operation must be done as a completing operation, this satteid
-      value may be the speical stateid consisting of all zeros.
+      layout type is being returned and there are no remaining
+      pending CB_LAYOUTRECALL operations for which a LAYOUTRETURN
+      operation must be done as a completing operation, this stateid
+      value may be the special stateid consisting of all zeros.
     </t>
     <t>
       On success, the current filehandle retains its value.

[email-masked] wrote:
> ------------------------------------------------------------------------
>

---

From: "Noveck, Dave" <[email-masked]>
Date: Mon, 19 Nov 2007 15:35:31 -0500

Done.  Thanks.

-----Original Message-----
From: Benny Halevy [mailto:[email-masked]] 
Sent: Monday, November 19, 2007 1:27 PM
To: [email-masked]
Subject: Re: [nfsv4] I-D Action:draft-ietf-nfsv4-minorversion1-17.txt

Benny

    <t>
  <section anchor="netid_iana" title="ONC RPC Network Identifiers
(netids)">
      the corresponding r_addr field within a netaddr4 structure.  The
NFS

> A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-nfsv4-minorversion1-17.tx
t