Subject: Re: [nfsv4] Layout Range.

From: Mike Eisler <[email-masked]>
Date: Thu, 8 Nov 2007 00:55:05 -0800 (PST)

I see consensus for changing LAYOUTGET to return an array of patterns.

--- Benny Halevy <[email-masked]> wrote:

> On Oct. 24, 2007, 23:37 +0200, Garth Goodson
> <[email-masked]> wrote:
> > 
> > Robert Gordon wrote:
> >> On Oct 24, 2007, at 11:21 AM, Garth Goodson wrote:
> >>
> >>> Right.  LAYOUTGET was designed to return a single range starting
> >>> at the offset returned covering the length returned.  I believe
> >>> it is stated that the returned layout must overlap by at least
> >>> loga_minlength bytes (which must be at least 1) the requested
> range.
> >>> If the minlength requirement can not be met in a single layout an
> >>> error is returned and the client is currently responsible for
> splitting
> >>> that range and retrying.
> >> I think that error would be NFS4ERR_LAYOUTTRYLATER, however we
> >> do not indicate it this is a transient issue or if the client
> >> needs to split the range and try again.
> >>
> > TRYLATER is a transient error and I think should not be returned if
> a 
> > range needs to be split due to striping issues, rather than some
> type of 
> > locking issue over a portion of the range.
> > 
> >>> If there are different striping patterns these should be returned
> >>> via multiple layoutgets in separate layouts.
> >> It would seem easier to make LAYOUTGET4resok.logr_layout an array,
> >> as mike suggested.
> >>
> > 
> > I have no objection to returning an array, however I believe that a
> 
> > client will still have to handle the corner case of not retrieving
> the 
> > entire range at once (even if multiple layouts are returned), since
> 
> > there could be other factors; e.g., max_count is too small to
> return all 
> > layouts that cover that range.
> 
> Agreed.
> 
> Benny
> 
> > 
> > -Garth
> > 
> >> Robert.
> >> _______________________________________________
> 
> 
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nfsv4
> 

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Dean Hildebrand <[email-masked]>
Date: Thu, 08 Nov 2007 11:36:52 -0800

> I see consensus for changing LAYOUTGET to return an array of patterns.
Sounds like a good feature for NFSv4.2. (or .3 or .4 or ...)

I believe we need real world experience with pNFS before we start 
guessing about how people might use it and what "may" give better 
performance and what "may" be useful.  I would prefer to see an 
implementation of this (and many other things) before we start extending 
an already pork barreled minor extension.

Dean