Subject: [nfsv4] Question about layout hints & persistent session reply cache

From: Bill Baker <[email-masked]>
Date: Tue, 13 Nov 2007 15:31:28 -0600

Greetings,

I was reviewing the spec regarding the client's use of
a layout_hint during file creation.  The wording in section
12.5.2 is clear:

"a metadata server that supports the layout_hint attribute
    MUST support a persistent session reply cache"

This is not consistent with the apparent consensus on the
wg alias, initially raised on 06/20/07, "pNFS: Open issues (from
chapter 12 & 13 reviews)" and then further discussed on 7/16/07.

...

Garth Goodson wrote:
* Open Issue 1: Layout hint attribute on OPEN (or a later SETATTR)

   (Line 12890 of draft 10)
   - Dictates the use of a persistent reply cache if layout hints are to
     be used. General agreement that this is not good.
   - SETATTR after an exclusive create may be a viable option (servers
    may be fine with this)

Noveck's proposed solution: Encourage, but not require a persistent 
reply cache for layout_hint.  (additional text elided)

...

The discussion that followed appeared to accept Noveck's proposal, yet
section 12.5.2 was never updated.

-- 
Bill Baker, 512-401-1081, x64081

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Mike Eisler <[email-masked]>
Date: Thu, 15 Nov 2007 05:48:19 -0800 (PST)

> chapter 12 & 13 reviews)" and then further discussed on 7/16/07.

Agreed. I will fix this now.