Subject: [nfsv4] Issue 165: should we adopt a convention for so_major_ids ?

From: Mike Eisler <[email-masked]>
Date: Wed, 7 Nov 2007 12:00:24 -0800 (PST)

http://www.nfsv4-editor.org/cgi-bin/roundup/nfsv4/issue165

Benny wrote for this issue:

I think that the rfc should recommend a naming convention that will
help to
prevent so_major_id collisions, especially when using servers from
different
vendors.  For example, iscsi (rfc3720) specifies iqn and eui formats,
the former
requires a registered domain name, the latter a IEEE EUI-64 world-wide
unique name

-----------------------------

So three questions:

- do we want to RECOMMEND a format for so_major_id?
- do we want to mandate a format for so_major_id?
- should the mandated or recommended format be a DNS FQDN?

My answers are:
  no, yes, yes.

Discussion welcome. If no consensus observed, then the issue will
be deferred (to NFSv4.2).

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Benny Halevy <[email-masked]>
Date: Thu, 08 Nov 2007 17:02:16 +0200

> requires a registered domain name, the latter a IEEE EUI-64 world-wide

Agreed.

-- 
Benny Halevy
Software Architect
Tel/Fax: +972-3-647-8340
Mobile: +972-54-802-8340
US:      +1-412-203-3187
[email-masked]
 
Panasas, Inc.
Leader in Parallel Storage
www.panasas.com