Subject: [nfsv4] Synopsis + OP description missing for RELEASE_LOCKOWNER

From: Trond Myklebust <[email-masked]>
Date: Fri, 09 Nov 2007 15:36:56 -0500

It appears to have been lost between RFC3530 and draft 15.

Cheers
  Trond

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Spencer Shepler <[email-masked]>
Date: Fri, 09 Nov 2007 14:49:44 -0600

> It appears to have been lost between RFC3530 and draft 15.

This section:

8.8.  Vestigial Locking Infrastructure From V4.0

covers the removal of RELEASE_LOCKOWNER from NFSv4.1.
It is now mandatory not to implement and therefore not
specified in the draft.

Spencer

---

From: Trond Myklebust <[email-masked]>
Date: Fri, 09 Nov 2007 16:04:54 -0500

> It is now mandatory not to implement and therefore not

Err... So why are we concerned about which error values it should
return?

Trond

---

From: "Noveck, Dave" <[email-masked]>
Date: Fri, 9 Nov 2007 16:18:13 -0500

The short, but not very good answer, is "because it was in the xml 
table we started with."

In my version, I've deleted all the errors for it except NFS4ERR_NOTSUPP

which is what I think we should return given it mandatory to not
implement.

-----Original Message-----
From: Trond Myklebust [mailto:[email-masked]] 
Sent: Friday, November 09, 2007 4:05 PM
To: Spencer Shepler
Cc: [email-masked]
Subject: Re: [nfsv4] Synopsis + OP description missing for
RELEASE_LOCKOWNER

Trond

---

From: Trond Myklebust <[email-masked]>
Date: Fri, 09 Nov 2007 16:26:59 -0500

> which is what I think we should return given it mandatory to not

Agreed