Subject: [nfsv4] connectathon tests

From: Benny Halevy <[email-masked]>
Date: Sun, 20 Jan 2008 21:12:56 +0200

I hit a fundamental bug in the linux pnfs implementation that was not
caught by the connectathon tests.  Probably due to a problem with
not issuing layoutcommit on time files copied into the mounted file system
end up with size 0.  In particular, the runtests.wrk script.
This empty script is considered valid by the tests since executing it
happily completes successfully :-/

I suggest the following change that checks that runtests.wrk exists and not
empty before executing it.

Benny

P.S.: who's maintaining these tests?

diff -Npu a/general/runtests b/general/runtests
--- a/general/runtests
+++ b/general/runtests
@@ -34,4 +34,9 @@ else
 	make
 fi
 
+if ! test -s runtests.wrk; then
+	echo runtests.wrk does not exist or is empty
+	exit 1
+fi
+
 exec sh runtests.wrk FROM_RUNTESTS
diff -Npu a/special/runtests b/special/runtests
--- a/special/runtests
+++ b/special/runtests
@@ -36,4 +36,9 @@ else
 	echo "SPECIAL TESTS: directory $NFSTESTDIR"
 fi
 
+if ! test -s runtests.wrk; then
+	echo runtests.wrk does not exist or is empty
+	exit 1
+fi
+
 MNTOPTIONS=$mntopts exec sh runtests.wrk FROM_RUNTESTS

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Mahesh Siddheshwar <[email-masked]>
Date: Mon, 21 Jan 2008 12:46:26 -0800

> happily completes successfully :-/
:)  instant results.
> P.S.: who's maintaining these tests?
thanks for submitting the changes. We'll add this and a couple of
pending ones and publish it to the connectathon website -- 
http://www.connectathon.org/nfstests.html
before bakethon.

Mahesh

---

From: Marc Eshel <[email-masked]>
Date: Mon, 21 Jan 2008 13:06:51 -0800

Do you happen to have also some new test cases that test exclusive locks ? 
the current version tests only read locks.
Marc.

Mahesh Siddheshwar <[email-masked]> 
01/21/2008 12:46 PM

To
Benny Halevy <[email-masked]>
cc
nfsv4 <[email-masked]>
Subject
Re: [nfsv4] connectathon tests

:)  instant results.

Mahesh

---

From: Benny Halevy <[email-masked]>
Date: Tue, 22 Jan 2008 10:46:28 +0200

> http://www.connectathon.org/nfstests.html

Thanks!

---

From: Mahesh Siddheshwar <[email-masked]>
Date: Tue, 22 Jan 2008 15:52:27 -0800

> the current version tests only read locks.
um.. not sure what you mean. The tests do use F_WRLCK.
May be something in your environment is not setup properly?

Mahesh

---

From: "J. Bruce Fields" <[email-masked]>
Date: Tue, 22 Jan 2008 21:44:44 -0500

On Tue, Jan 22, 2008 at 03:52:27PM -0800, Mahesh Siddheshwar wrote:
> Marc Eshel wrote:
>> Do you happen to have also some new test cases that test exclusive 
>> locks ? the current version tests only read locks.
>> Marc.
>>  
>>
>>   

It's RDLCK that it doesn't test, I think.

--b.

---

From: Marc Eshel <[email-masked]>
Date: Tue, 22 Jan 2008 19:07:24 -0800

Yes, I just remembered it was one of the lock type, but yes you are right 
it is F_RDLCK that is not tested.
Marc.

"J. Bruce Fields" <[email-masked]> 
01/22/2008 06:44 PM

To
Mahesh Siddheshwar <[email-masked]>
cc
Marc Eshel <[email-masked]>, nfsv4 <[email-masked]>
Subject
Re: [nfsv4] connectathon tests

--b.

---

From: Mahesh Siddheshwar <[email-masked]>
Date: Wed, 23 Jan 2008 12:26:13 -0800

> it is F_RDLCK that is not tested.

Just to provide closure on this thread -- no, there are no new changes
introducing tests with F_RDLCK.

Mahesh

---

From: "J. Bruce Fields" <[email-masked]>
Date: Wed, 23 Jan 2008 15:37:46 -0500

On Wed, Jan 23, 2008 at 12:26:13PM -0800, Mahesh Siddheshwar wrote:
> Marc Eshel wrote:
>> Yes, I just remembered it was one of the lock type, but yes you are 
>> right it is F_RDLCK that is not tested.
>>   
>

OK.  It would be a nice thing to have some day.  (Noticed because when
we submitted some recent changes to the linux kernel we introduced a bug
into F_GETLK that caused it to no longer notice conflicts involving read
locks.  It was caught soon enough by someone else before release, so no
great harm done, but it would be helpful if cthon (which we were using
as part of our testing) noticed that kind of mistake.)

--b.