Subject: [nfsv4] draft-18 xml sources

From: Benny Halevy <[email-masked]>
Date: Wed, 09 Jan 2008 11:13:58 +0200

It seems like the nfsv4-editor.org site is down (dismantled?)
and I didn't downloaded the sources for draft-18 from the draft/
area on time.

Can you please provide a pointer to or send the xml sources of
draft-18 so I can update my repository?

Thanks,

Benny

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: "Noveck, Dave" <[email-masked]>
Date: Wed, 9 Jan 2008 11:55:39 -0500

If it will make you feel any better, I don't think that being quicker
would have helped.  When I last looked at the site, it was still working
but the latest sources were for draft-17.  I'm not sure the draft-18
sources were ever put there.  

We still have the CVS repository but that has been updated after
draft-18 to fix isues that people have noted.  I'm sure there is a way
to retrieve the sources as of a given date if there is no other way to
get them.

-----Original Message-----
From: Benny Halevy [mailto:[email-masked]] 
Sent: Wednesday, January 09, 2008 4:14 AM
To: spencer Shepler; Mike Eisler; Noveck, Dave
Cc: nfsv4
Subject: draft-18 xml sources

Thanks,

Benny

---

From: Mike Eisler <[email-masked]>
Date: Wed, 9 Jan 2008 17:15:03 -0800 (PST)

I went to the web site just now and it is up and draft-18 sources are
there.

---

From: Benny Halevy <[email-masked]>
Date: Thu, 10 Jan 2008 12:01:16 +0200

Unfortunately, one file still seems to be missing: dotx.d/open_args.x

Thanks,

Benny

---

From: Mike Eisler <[email-masked]>
Date: Thu, 10 Jan 2008 08:31:48 -0800 (PST)

> Unfortunately, one file still seems to be missing: dotx.d/open_args.x

Sorry about that. My fault.

The attached diff will allow you to construct open_args.x from
open_args_gen.x.

--- open_args_gen.x	2007-12-31 14:53:57.478733500 -0800
+++ open_args.x	2007-12-16 18:46:19.909892500 -0800
@@ -65,15 +65,7 @@
 /*
  * Share Access and Deny constants for open argument
  */
-const OPEN4_SHARE_ACCESS_READ	= 0x00000001;
-const OPEN4_SHARE_ACCESS_WRITE	= 0x00000002;
-const OPEN4_SHARE_ACCESS_BOTH	= 0x00000003;
-
-const OPEN4_SHARE_DENY_NONE	= 0x00000000;
-const OPEN4_SHARE_DENY_READ	= 0x00000001;
-const OPEN4_SHARE_DENY_WRITE	= 0x00000002;
-const OPEN4_SHARE_DENY_BOTH	= 0x00000003;
-
+include(const_access_deny.x)
 
 /* new flags for share_access field of OPEN4args */
 const OPEN4_SHARE_ACCESS_WANT_DELEG_MASK	= 0xFF00;
_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: "J. Bruce Fields" <[email-masked]>
Date: Thu, 10 Jan 2008 12:18:43 -0500

> The attached diff will allow you to construct open_args.x from

Thanks!  By the way, I've been keeping a git repository, browsable here:

	http://git.linux-nfs.org/?p=bfields/nfsv41.git;a=summary

I update a .gitignore and fix up the occasional build nit before
importing, so it doesn't have pristine snapshots of the tarballs.

Probably not of any use to anybody else, but sounds like Benny's doing
something similar (and I think Sam was for a while too), so who knows.

There's also a topic branch or two with some typo fixes which I should
send in some day, apologies....

--b.

---

From: Benny Halevy <[email-masked]>
Date: Fri, 11 Jan 2008 12:47:55 +0200

> The attached diff will allow you to construct open_args.x from

That fixed the problem, thanks!

Benny

---

From: Benny Halevy <[email-masked]>
Date: Fri, 11 Jan 2008 12:49:36 +0200

> 	http://git.linux-nfs.org/?p=bfields/nfsv41.git;a=summary

Cool, thanks for the pointer!

> something similar (and I think Sam was for a while too), so who knows.

Yup, my repository can be see here:
http://www.bhalevy.com/perforce/bin/branchView.cgi?BRANCH=pub%2dnfsv41%2ddraft

(For perforce lovers :)