Subject: [nfsv4] -19 typo fixes

From: "J. Bruce Fields" <[email-masked]>
Date: Tue, 29 Jan 2008 18:07:19 -0500

A couple minor typo fixes in -19:

--b.

diff --git a/nfsv41_middle_core_infrastructure.xml b/nfsv41_middle_core_infrastructure.xml
index 6d010d4..dc32a92 100755
--- a/nfsv41_middle_core_infrastructure.xml
+++ b/nfsv41_middle_core_infrastructure.xml
@@ -440,7 +440,7 @@
           <t>
             A true random number. However since this number ought to be the same
             between client incarnations, this shares the same problem as that of
-            the using the timestamp of the software installation.
+            using the timestamp of the software installation.
           </t>
         </list>
       </t>
diff --git a/nfsv41_middle_op_layoutget.xml b/nfsv41_middle_op_layoutget.xml
index 92c4bc5..9e09b81 100755
--- a/nfsv41_middle_op_layoutget.xml
+++ b/nfsv41_middle_op_layoutget.xml
@@ -106,7 +106,7 @@
       in the case the client fails to return the layout before close.
       For the server that knows a layout must be returned before a
       close of the file, this return value can be used to communicate
-      the desired behavior to the client and thus removing one extra
+      the desired behavior to the client and thus remove one extra
       step from the client's and server's interaction.
     </t>
     <t>

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: "J. Bruce Fields" <[email-masked]>
Date: Tue, 29 Jan 2008 18:11:16 -0500

> A couple minor typo fixes in -19:

And another--the use of "delegations" in the definition here seems
circular; make the definition consistent with the definition of file
delegations instead.

diff --git a/nfsv41_middle_introduction.xml b/nfsv41_middle_introduction.xml
index 159b672..8bdca79 100755
--- a/nfsv41_middle_introduction.xml
+++ b/nfsv41_middle_introduction.xml
@@ -485,7 +485,7 @@
             occur so long as the delegation is held.  
           </t>
           <t>
-            Directory delegations, which are recallable delegations
+            Directory delegations, which are recallable locks
             that assure the holder that inconsistent directory 
             modifications cannot occur so long as the delegation 
             is held.

---

From: "J. Bruce Fields" <[email-masked]>
Date: Tue, 29 Jan 2008 18:19:47 -0500

I think this one got dropped last time I sent it in--seems like an
obvious fix to me, but maybe I'm missing something:

The current draft has a couple sentences like:

	By rule (see Section 2.6.3.1.5), neither PUTFH nor SECINFO...

After the following the generated text looks like:

    	By the rule of Section 2.6.3.1.5, neither PUTFH nor SECINFO...

--b.
    
diff --git a/nfsv41_middle_core_infrastructure.xml b/nfsv41_middle_core_infrastructure.xml
index 0a7bd90..6fae537 100755
--- a/nfsv41_middle_core_infrastructure.xml
+++ b/nfsv41_middle_core_infrastructure.xml
@@ -930,10 +930,10 @@
      containing the series SEQUENCE, PUTFH,
      SECINFO_NONAME, READ, and suppose the security tuple
      used does not match that required for the target
-     file. By rule (see <xref target="PUTFH+SECINFO"/>),
+     file. By the rule of <xref target="PUTFH+SECINFO"/>,
      neither PUTFH nor SECINFO_NO_NAME can
-     return NFS4ERR_WRONGSEC. By rule (see <xref
-     target="PUTFH+AnythingElse"/>), READ cannot return
+     return NFS4ERR_WRONGSEC. By the rule of <xref
+     target="PUTFH+AnythingElse"/>, READ cannot return
      NFS4ERR_WRONGSEC. The issue is resolved by the fact
      that SECINFO and SECINFO_NO_NAME consume the current
      filehandle. This leaves no current filehandle for

---

From: Mike Eisler <[email-masked]>
Date: Tue, 29 Jan 2008 15:26:55 -0800 (PST)

I didn't see the point. I believe an article is not required
before "rule" in the sentence.

---

From: Mike Eisler <[email-masked]>
Date: Tue, 29 Jan 2008 20:13:02 -0800 (PST)

these changes plus the ones from the email that started this thread
have been checked in.