Subject: [nfsv4] Create - typename

From: "Sandeep Joshi" <[email-masked]>
Date: Wed, 13 Feb 2008 14:51:52 -0800

I was reading description section of "CREATE" operation. CREATE
operation takes objname, objtype, attrs as input parameters.  But,
description section refers to typename. It is not clear how "typename"
is derived/found.

Here is the line that mentions it. (section 18.4.3)

 "The objname specifies the name for the new object. The objtype
determines the type of object to be created: directory, symlink, etc. If
the typename is that of an ordinary file, a named attribute, or a named
attribute directory, the error NFS4ERR_WRONG_TYPE results. "

More explaination will help.

I have two typos to report.

1. "<" sign after "to".

Section 8.4.2.1

 allowed, unless the server is able *to<* reliably determine

2. "Givem" instead of "Given"

2.10.5.1.  Slot Identifiers and Reply Cache

**Givem** that well formulated XIDs continue to be required,

 --

Sandeep

_______________________________________________
nfsv4 mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/nfsv4

---

From: "Noveck, Dave" <[email-masked]>
Date: Thu, 14 Feb 2008 09:15:41 -0500

>  "The objname specifies the name for the new 
> object. The objtype determines the type of 
> object to be created: directory, symlink, etc. 
> If the typename is that of an ordinary file, a 
> named attribute, or a named attribute directory, 
? the error NFS4ERR_WRONG_TYPE results. "

How about:

    The objname specifies the name for the new object. 
    The objtype determines the type of object to be 
    created: directory, symlink, etc. If the object 
    type specified is that of an ordinary file, a 
    named attribute, or a named attribute directory, 
    the error NFS4ERR_WRONG_TYPE results. 

>  allowed, unless the server is able *to<* reliably determine

Already fixed in the CVS repository.

> **Givem** that well formulated XIDs continue to be required,

I'll fix it.

-----Original Message-----
From: Sandeep Joshi [mailto:[email-masked]] 
Sent: Wednesday, February 13, 2008 5:52 PM
To: [email-masked]
Subject: [nfsv4] Create - typename

 
1. "<" sign after "to".
 
Section 8.4.2.1