Subject: [nfsv4] I-D ACTION:draft-ietf-nfsv4-pnfs-obj-05.txt

From: [email-masked]
Date: Mon, 25 Feb 2008 15:00:01 -0800 (PST)

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.
This draft is a work item of the Network File System Version 4 Working Group of the IETF.

	Title		: Object-based pNFS Operations
	Author(s)	: B. Halevy
	Filename	: draft-ietf-nfsv4-pnfs-obj-05.txt
	Pages		: 35
	Date		: 2008-2-25
	
This Internet-Draft provides a description of the object-based pNFS
   extension for NFSv4.  This is a companion to the main pnfs
   specification in the NFSv4 Minor Version 1 Internet Draft, which is
   currently draft-ietf-nfsv4-minorversion1-20.txt.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-nfsv4-pnfs-obj-05.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of 
the message. 
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the 
username "anonymous" and a password of your e-mail address. After 
logging in, type "cd internet-drafts" and then 
"get draft-ietf-nfsv4-pnfs-obj-05.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

_______________________________________________
nfsv4 mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/nfsv4

---

From: Benny Halevy <[email-masked]>
Date: Mon, 25 Feb 2008 16:46:18 -0800

Here's a summary of what has changed in draft-05 vs. draft-04:

- Updated protocol data types as per draft-ietf-nfsv4-minorversion-20,
  specifically move the error reporting part of pnfs_osd_layoutupdate4
  to pnfs_osd_layoutreturn4

- Make the system ID mandatory for the server to return on GETDEVICEINFO, and
  to OSD Name optional.

- Provide for returning layout only for a nested stripe.

- Fix specification for client response when accessing an unavailable
  component object over RAID-0.

- Remove PNFS_OSD_RCA4_TYPE_MASK_ANY, this can be represented by setting both
  PNFS_OSD_RCA4_TYPE_MASK_READ | PNFS_OSD_RCA4_TYPE_MASK_RW.

- Add XDR description of the pnfs-obj protocol.

- Add informative reference for RAID-6 description.

- Acknowledge draft reviewers

Benny

-- 
Benny Halevy
Software Architect
Tel/Fax: +972-3-647-8340
Mobile: +972-54-802-8340
US:      +1-412-203-3187
[email-masked]
 
Panasas, Inc.
Leader in Parallel Storage
www.panasas.com
_______________________________________________
nfsv4 mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/nfsv4