Subject: [nfsv4] I-D Action:draft-ietf-nfsv4-pnfs-obj-08.txt

From: [email-masked]
Date: Sun, 18 May 2008 06:30:02 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network File System Version 4 Working Group of the IETF.

	Title           : Object-based pNFS Operations
	Author(s)       : B. Halevy, et al.
	Filename        : draft-ietf-nfsv4-pnfs-obj-08.txt
	Pages           : 35
	Date            : 2008-05-18

This Internet-Draft provides a description of the object-based pNFS
extension for NFSv4.  This is a companion to the main pnfs
specification in the NFSv4 Minor Version 1 Internet Draft, which is
currently draft-ietf-nfsv4-minorversion1-23.Requirements Language

The key words "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT",
"SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY", and "OPTIONAL" in this
document are to be interpreted as described in RFC 2119 [1].

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-nfsv4-pnfs-obj-08.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
nfsv4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nfsv4

---

From: Benny Halevy <[email-masked]>
Date: Sun, 18 May 2008 20:24:22 +0300

Version 08 of this draft contains a few nit picks:

* fixed pnfs_osd_deltaspaceused4 union type member name
* fixed xdr extract command and definitions
* updated references

Benny

And the full diff for your convenience:

diff -Nurp -u draft-ietf-nfsv4-pnfs-obj-07.xml draft-ietf-nfsv4-pnfs-obj-08.xml
--- draft-ietf-nfsv4-pnfs-obj-07.xml	2008-04-01 21:35:10.000000000 +0300
+++ draft-ietf-nfsv4-pnfs-obj-08.xml	2008-05-18 16:07:06.000000000 +0300
@@ -47,7 +47,7 @@
 <rfc
     category="std"
     ipr="full3978"
-    docName="draft-ietf-nfsv4-pnfs-obj-07">
+    docName="draft-ietf-nfsv4-pnfs-obj-08">
 
 <front>
     <title abbrev="pnfs objects">Object-based pNFS Operations</title>
@@ -106,7 +106,7 @@
         </address>
     </author>
 
-    <date year="2008" month="April" day="01"/>
+    <date year="2008" month="May" day="18"/>
 
     <area>Transport</area>
     <workgroup>NFSv4</workgroup>
@@ -116,7 +116,7 @@
       This Internet-Draft provides a description of the object-based
       pNFS extension for NFSv4.  This is a companion to the main
       pnfs specification in the NFSv4 Minor Version 1 Internet Draft,
-      which is currently draft-ietf-nfsv4-minorversion1-21.
+      which is currently draft-ietf-nfsv4-minorversion1-23.
       </t>
     </abstract>
 
@@ -175,7 +175,7 @@ the machine readable XDR description of 
  <figure>
   <artwork>
 #!/bin/sh
-grep "^  *///" | sed 's?^  *///??'
+grep '^ *///' $* | sed 's?^ *///??'
   </artwork>
  </figure>
  <t>
@@ -207,8 +207,8 @@ as well as more generic types such as ui
   <artwork>
 ////*
 /// * This file was machine generated for
-/// * draft-ietf-nfsv4-pnfs-obj-07
-/// * Last updated Tue Apr  1 21:35:08 IDT 2008
+/// * draft-ietf-nfsv4-pnfs-obj-08
+/// * Last updated Sun May 18 13:07:05 UTC 2008
 /// *
 /// * Copyright (C) The IETF Trust (2007-2008)
 /// * All Rights Reserved.
@@ -307,7 +307,7 @@ However, it seems most robust to call ou
    <artwork>
 ///enum pnfs_osd_cap_key_sec4 {
 ///    PNFS_OSD_CAP_KEY_SEC_NONE = 0,
-///    PNFS_OSD_CAP_KEY_SEC_SSV  = 1,
+///    PNFS_OSD_CAP_KEY_SEC_SSV  = 1
 ///};
 ///
 ///struct pnfs_osd_object_cred4 {
@@ -1070,7 +1070,7 @@ and to indicate that I/O errors were enc
  <section anchor="pnfs_osd_deltaspaceused4" title="pnfs_osd_deltaspaceused4">
   <figure>
    <artwork>
-///union pnfs_osd_deltaspaceused4 switch (bool valid) {
+///union pnfs_osd_deltaspaceused4 switch (bool dsu_valid) {
 ///    case TRUE:
 ///        int64_t     dsu_delta;
 ///    case FALSE:
@@ -1535,7 +1535,7 @@ the following types:
   <figure>
    <artwork>
 const RCA4_TYPE_MASK_OBJ_LAYOUT_MIN     = 8;
-const RCA4_TYPE_MASK_OBJ_LAYOUT_MAX     = 11;
+const RCA4_TYPE_MASK_OBJ_LAYOUT_MAX     = 9;
 
 struct  CB_RECALL_ANY4args      {
     uint32_t        craa_objects_to_keep;
@@ -1558,8 +1558,10 @@ keeping at most craa_objects_to_keep obj
   </t>
   <figure>
    <artwork>
-///const PNFS_OSD_RCA4_TYPE_MASK_READ = RCA4_TYPE_MASK_OBJ_LAYOUT_MIN;
-///const PNFS_OSD_RCA4_TYPE_MASK_RW   = RCA4_TYPE_MASK_OBJ_LAYOUT_MIN+1;
+///enum pnfs_osd_cb_recall_any_mask {
+///    PNFS_OSD_RCA4_TYPE_MASK_READ = 8,
+///    PNFS_OSD_RCA4_TYPE_MASK_RW   = 9
+///};
 ///
    </artwork>
   </figure>
@@ -1972,7 +1974,7 @@ actions for IANA.
 <references title="Informative References">
 
   <reference anchor='NFSv4.1' 
-             target='http://www.ietf.org/internet-drafts/draft-ietf-nfsv4-minorversion1-21.txt'>
+             target='http://www.ietf.org/internet-drafts/draft-ietf-nfsv4-minorversion1-23.txt'>
     <front>
       <title>NFSv4 Minor Version 1</title>
       <author initials="S." surname="Shepler" fullname="Spencer Shepler">
@@ -1984,12 +1986,12 @@ actions for IANA.
       <author initials="D." surname="Noveck" fullname="David Noveck">
         <organization abbrev="Netapp">Network Appliance, Inc.</organization>
       </author>
-      <date month="February" year="2008"/>
+      <date month="May" year="2008"/>
     </front>
   </reference>
 
   <reference anchor='NFS41_DOT_X' 
-             target='http://www.ietf.org/internet-drafts/draft-ietf-nfsv4-minorversion1-dot-x-04.txt'>
+             target='http://www.ietf.org/internet-drafts/draft-ietf-nfsv4-minorversion1-dot-x-06.txt'>
     <front>
       <title>NFSv4 Minor Version 1 XDR Description</title>
       <author initials="S." surname="Shepler" fullname="Spencer Shepler">
@@ -2001,7 +2003,7 @@ actions for IANA.
       <author initials="D." surname="Noveck" fullname="David Noveck">
         <organization abbrev="Netapp">Network Appliance, Inc.</organization>
       </author>
-      <date month="February" year="2008"/>
+      <date month="May" year="2008"/>
     </front>
   </reference>

On May. 18, 2008, 16:30 +0300, [email-masked] wrote:
> ------------------------------------------------------------------------
>