Subject: Re: [nfsv4] [pnfs] filehandles and GETDEVICELIST/GETDEVICEINFO

From: Benny Halevy <[email-masked]>
Date: Thu, 01 May 2008 18:36:18 +0300

On May. 01, 2008, 16:56 +0300, "david m. richter" <[email-masked]> wrote:
> hello,
> 
> i found in the server code that both GETDEVICELIST and GETDEVICEINFO
> get a flag set that permits the operation to proceed without a current
> filehandle.

Can you please be more specific.
I'm not sure what you're referring to...

Benny

> 
> that sounds correct for GETDEVICEINFO, but it seems that GETDEVICELIST
> would need a filehandle so the server can id the filesystem in
> question (and the draft confirms that).  so i'm thinking that i should
> remove the flag for -LIST, yes?

GETDEVICEINFO doesn't use the current filehandle.
GETDEVICELIST must have a valid filehandle.

> 
> relatedly, the draft says that a possible error value for
> GETDEVICEINFO is NFS4ERR_NOFILEHANDLE (but not NFS4ERR_FHEXPIRED, at
> least) -- that error should be removed from the draft, yes?

Hmm, that's wrong.  GETDEVICEINFO needs no file handle
[nfsv4 mailing list Cc'ed]
I think that NFS4ERR_FHEXPIRED should allowed for all ops that
are allowed to return NFS4ERR_NOFILEHANDLE.  This seems like
something that will be fixed when the editors make the final scrubbing
of ops errors codes.

Benny

> 
> 
> thanks kindly,
> 
>   d
>   .
> _______________________________________________
> pNFS mailing list
> [email-masked]
> http://linux-nfs.org/cgi-bin/mailman/listinfo/pnfs

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nfsv4

---

From: "david m. richter" <[email-masked]>
Date: Thu, 1 May 2008 11:49:24 -0400

>  I'm not sure what you're referring to...

sure, sure -- it's just in one place.  in nfsd/nfs4proc.c, struct
nfsd4_operation nfsd4_ops has ALLOWED_WITHOUT_FH set for
OP_GETDEVICELIST (and it's only checked once, in
nfsd4_proc_compound()).

>  GETDEVICELIST must have a valid filehandle.

ok, that's what i wanted to confirm.

>  something that will be fixed when the editors make the final scrubbing

good, just wanted to make sure.

thanks, benny,

  d
  .

---

From: "Mike Eisler" <[email-masked]>
Date: Thu, 1 May 2008 09:03:17 -0700 (PDT)

>>  Hmm, that's wrong.  GETDEVICEINFO needs no file handle

I caught this weeks ago. Will be fixed in -22.

>>  something that will be fixed when the editors make the final scrubbing

I'll double check.

-- 
Mike Eisler, Senior Technical Director, NetApp, 719 599 9026,
http://blogs.netapp.com/eislers_nfs_blog/