Subject: [nfsv4] cthon04 bug

From: "J. Bruce Fields" <[email-masked]>
Date: Sat, 10 May 2008 16:04:28 -0400

The holey tests can print out an error message like:

	non-zero data read back from hole (offset 13388)

helpfully giving you the file offset at which the corruption was first
found.  The calcualtion of that offset is wrong.

Note that sz is tracking the amount of data left to process.  But the
size of the current hole (in "tot") has already been subtracted from sz;
so hole we're currently processing starts at offset

	filesz - sz - tot

not

	filesz - sz.

Any chance someone could update the tarball on the connectathon.org
site?

--b.

diff --git a/cthon04/special/holey.c- b/cthon04/special/holey.c
index 93a8e4b..17b6841 100644
--- a/cthon04/special/holey.c-
+++ b/cthon04/special/holey.c
@@ -230,7 +230,7 @@ char *argv[];
 					if (buf[i] != '\0') {
 						fprintf(stderr,
 			"non-zero data read back from hole (offset %d)\n",
-							filesz - sz + ct + i);
+						filesz - sz - tot + ct + i);
 						exit(1);
 					}
 				}
_______________________________________________
nfsv4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nfsv4

---

From: Mahesh Siddheshwar <[email-masked]>
Date: Mon, 12 May 2008 11:54:33 -0700

> Any chance someone could update the tarball on the connectathon.org
Bruce, thanks for the changes.  We have couple of other changes pending 
and a
few other noted changes which we are waiting on, so I am planning on
updating this after the Connectathon. 

If you need this pushed out sooner, let me know.

Mahesh

---

From: "J. Bruce Fields" <[email-masked]>
Date: Mon, 12 May 2008 16:43:25 -0400

> updating this after the Connectathon. 

OK, great.

> If you need this pushed out sooner, let me know.

Nah, no rush--just happy to know changes aren't getting lost.

--b.