Subject: Re: [nfsv4] comments on draft-ietf-nfsv4-rfc1831bis-08.txt

From: Robert Thurlow <[email-masked]>
Date: Mon, 09 Jun 2008 11:41:17 -0600

Hi Mike, sorry for the delay and thanks for the comments.
I've accepted most of your wording suggestions verbatim,
with a few exceptions as noted below.

Mike Eisler wrote:

>   (Section 9 defines the
>    various authentication protocols.)
> 
> No it doesn't.

Agreed; text deleted.

>    recommended that implementors include AUTH_SYS
> 
>    It is strongly
>    recommended that implementors include AUTH_SYS in their
>    implementations to promote interoperability, since many applications
>    make use of this flavor.
> 
> Disagree, since RPCSEC_GSS is now on all major
> platforms. I suggest:
> 
> 
>    Implementors MAY include AUTH_SYS in their
>    implementations.

Agreed, changed wording to:

Implementors MAY include AUTH_SYS in their implementations to
support existing applications.

>   Existing pseudo-flavors
>    have been granted in the decimal range 390000-390255 as described in
>    2.2.
> 
> There is no section 2.2.

Deleted - those were from a prior, separate draft.

>    'standards-track'
> 
> at least one other place used
> 
>    Standards Track
> 
> Be consistent.

Agreed; standards-track wins.

>      For authentication flavors to be used on
>      the Internet, it is strongly advised that
>      an informational or standards-track RFC
>      be published describing the authentication
>      mechanism behaviour and parameters.
> 
> We should discourage standards-track RFCs for
> new auth_flavors. Perhaps this sentence
> should be added:
> 
>      Note: at this time new standards-track
>      RFCs for new auth_flavors are discouraged.

I've instead worded it this way, since we need to have
RFCs for interoperability; let me know if you don't agree:

For authentication flavors or RPCSEC_GSS mechanisms
to be used on the Internet, it is strongly advised that an
informational or standards-track RFC  be published describing
the authentication mechanism behaviour and parameters.

Rob T
_______________________________________________
nfsv4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nfsv4

---

From: "Mike Eisler" <[email-masked]>
Date: Tue, 10 Jun 2008 14:33:04 -0700 (PDT)

Rob, the new I-D looks really good.

I suggest requesting a WG Last Call.

-- 
Mike Eisler, Senior Technical Director, NetApp, 719 599 9026,
http://blogs.netapp.com/eislers_nfs_blog/