Subject: [nfsv4] I-D Action:draft-ietf-nfsv4-pnfs-obj-09.txt

From: [email-masked]
Date: Thu, 19 Jun 2008 00:45:02 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network File System Version 4 Working Group of the IETF.

	Title           : Object-based pNFS Operations
	Author(s)       : B. Halevy, et al.
	Filename        : draft-ietf-nfsv4-pnfs-obj-09.txt
	Pages           : 35
	Date            : 2008-06-19

This Internet-Draft provides a description of the object-based pNFS
extension for NFSv4.  This is a companion to the main pnfs
specification in the NFSv4 Minor Version 1 Internet Draft, which is
currently draft-ietf-nfsv4-minorversion1-23.Requirements Language

The key words "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT",
"SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY", and "OPTIONAL" in this
document are to be interpreted as described in RFC 2119 [1].

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-nfsv4-pnfs-obj-09.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
nfsv4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nfsv4

---

From: Benny Halevy <[email-masked]>
Date: Thu, 19 Jun 2008 14:14:39 +0300

Spencer,

draft-09 contains the changes described below.
It should be ready for IESG review at this point.

Benny

1. Clarify client implicit use of OSD System ID:

-   The oda_systemid is used by the client, along with the object credential to sign
-   each request with the request integrity check value.
+   The oda_systemid is implicitly used by the client, by using the object credential
+   signing key to sign each request with the request integrity check value.

2. Use updated pnfs_osd_targetid_type4 type name:

- <section anchor="pnfs_osd_addr_type4" title="pnfs_osd_addr_type4">
+ <section anchor="pnfs_osd_targetid_type4" title="pnfs_osd_targetid_type4">

- </section> <!-- pnfs_osd_addr_type4 -->
+ </section> <!-- pnfs_osd_targetid_type4 -->
 
-The OBJ_TARGET_ANON pnfs_osd_addr_type4 MAY be used for providing no
+The OBJ_TARGET_ANON pnfs_osd_targetid_type4 MAY be used for providing no

3. Optimize device info representation when OSD System ID equals
   the SCSI Device Identifier.

+If the Device Identifier is identical to the OSD System ID, as given by
+oda_systemid, the server SHOULD provide a zero-length oti_scsi_device_id&lt;&gt
+opaque value 

4. Nit picked by Robert Gordon (Thanks!)

-  C = (132000-(8*16384)) / 4096 = 0
+  C = (132000-(8*16384)) / 4096 = 0 (D0)
   O = (8*4096) + (132000%4096) = 33696

5. Correction for security considerations regarding non-use of
   the NOSEC OSD security method.

   security credentials, the NOSEC security method MUST NOT be used for
-  I/O operation. It MAY only be used to get the System ID attribute when the
-  metadata server provided only the OSD name with the device address.
+  any I/O operation.

6. Editorial nit.

-  on that object, a byte range w/in the object (in OSDv2), and has an explicit
+  on that object, a byte range within the object (in OSDv2), and has an explicit

On Jun. 19, 2008, 10:45 +0300, [email-masked] wrote:
> ------------------------------------------------------------------------
>