Subject: [nfsv4] nfs-kernel-server: Extended account squashing using a number

From: Mark Hobley <[email-masked]>
Date: Sat, 5 Sep 2009 14:02:47 -0700 (PDT)

Hello.

I have an idea to extend NFS account squashing to allow a range of accounts to be squashed by providing a numerical parameter. The idea concerns implementations of NFS on Linux. I am not sure whether this information applies just to Linux, or whether it is of concern to the NFSV4 Working Group, so I have forwarded this for information.

On Linux, currently only the root account can be squashed via NFS. However, we could extend this facility by using a numeric option added to the /etc/exports file.

For example:

/foobar 10.0.0.0/18(rw,squashbelow=14)

This would squash all accounts numbered 14 or below.

This option could still be used with the no_root_squash option:

/foobar 10.0.0.0/18(rw,squashbelow=14,no_root_squash)

Here, accounts 1 to 14 are squashed, but the root account (0) is not 
squashed.

Regards,

Mark.

---

From: Thomas Haynes <[email-masked]>
Date: Sun, 06 Sep 2009 10:52:01 -0500

> I have an idea to extend NFS account squashing to allow a range of accounts to be squashed by providing a numerical parameter. The idea concerns implementations of NFS on Linux. I am not sure wheth…

Mark,

It isn't as much as it is a Linuxism as it is about exports, which are 
not part
of the NFS protocol. Neither the NFSv3 or NFSv4 protocol know anything
about the export model or about such user-id mapping.

I'd suggest that you try sending this to [email-masked].

Thanks,
Tom
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>