Subject: [nfsv4] nfsv4 & replication

From: [email-masked]
Date: Tue, 24 Nov 2009 12:10:37 +0100

hi,

trying to configure nfsv4 with replication on a clustered FS(GPFS)

setup:
client: 2.6.16.60-0.21-smp
server1/server2: aix6.1

exportfs on server[12]:
/mnt/install 
-vers=4,anon=0,rw,replicas=/mnt/install@server1:/mnt/install@server2

mount on client
# mount|grep nfs4
server1:/ on /mnt type nfs4 (rw,addr=192.168.212.13)

during halt of server1 i'd expect a automatic failover to server2, but 
this doesn't work.

any ideas?

regards
----------------
Disclaimer:
Diese Nachricht dient ausschließlich zu Informationszwecken und ist nur 
für den Gebrauch des angesprochenen Adressaten bestimmt.

This message is only for informational purposes and is intended solely for 
the use of the addressee.
----------------

---

From: Trond Myklebust <[email-masked]>
Date: Tue, 24 Nov 2009 09:38:34 -0500

> during halt of server1 i'd expect a automatic failover to server2, but

Migration/replication is still not supported on the client. We've only
finished referral support so far.

Trond