Subject: [nfsv4] NFS4ERR_DELAY and NFS4ERR_MOVED

From: Tom Haynes <[email-masked]>
Date: Fri, 26 Mar 2010 03:22:34 -0500

Every op that can return NFS4ERR_MOVED
should also be able to return NFS4ERR_DELAY. I.e., if during
the migration event, the client tries to access a filesystem
which is being migrated, then the server MUST be able to
tell the client to wait on the object.

This might be due to the transference of either content or
state information from the source to destination server.

The following ops do not support NFS4ERR_DELAY:

DELEGRETURN
LOCKU
COMMIT
SECINFO
GETFH
LOOKUP
LOOKUPP
OPEN_CONFIRM
OPEN_DOWNGRADE
RESTOREFH
SAVEFH

A quick sanity check of RFC 5661 shows that these ops
are allowed to return NFS4ERR_DELAY.

I'm going to propose:

1) We add this error code to the above ops.

2) We move the error codes from their own sections
after each op to a combined section like 15.2 from 5661.
That will make it easier for implementors to quickly
check error codes.

---

From: <[email-masked]>
Date: Fri, 26 Mar 2010 11:44:47 -0400

> are allowed to return NFS4ERR_DELAY. 

OPEN_CONFIRM can't but that's because it is mandatory-to-not-implement
in v4.1.

GETFH can't but I don't see this is a problem for RFC5661.  If there is
a need for DELAY when the current fh is set to an fs in the process of
migration you can return DELAY on that earlier op, even though you may
not want to return MOVED.  So I don't see this as an RFC5661 erratum.

With regard to RESTOREFH, I think adding DELAY in RFC3530bis is a good
thing even if it turns out that we are not absolutely forced to do so
due to MOVED.

> That will make it easier for implementors to quickly

What's with all this solicitude for current and future implementors?
Why shouldn't they suffer like we did? :-)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Tom Haynes
Sent: Friday, March 26, 2010 4:23 AM
To: [email-masked]
Subject: [nfsv4] NFS4ERR_DELAY and NFS4ERR_MOVED

DELEGRETURN
LOCKU
COMMIT
SECINFO
GETFH
LOOKUP
LOOKUPP
OPEN_CONFIRM
OPEN_DOWNGRADE
RESTOREFH
SAVEFH

I'm going to propose:

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nfsv4

---

From: Tom Haynes <[email-masked]>
Date: Fri, 26 Mar 2010 10:48:18 -0500

> Why shouldn't they suffer like we did? :-)

Okay, it isn't for anyone other than myself. It was a pain
to scroll through many pages that late at night. :->