Subject: [nfsv4] Priority tagging

From: Phil Love <[email-masked]>
Date: Fri, 16 Apr 2010 14:09:06 -0700

In "draft-eisler-nfsv4-minorversion-2-requirements-02", there is a 
bullet point for "Head of line blocking". I would be interested in 
seeing a draft proposal of how this would be implemented within nfsv4.2.

Thanks
Phil

---

From: <[email-masked]>
Date: Mon, 19 Apr 2010 13:05:41 -0400

I haven't heard of anyone currently working on one.  

If there isn't, it probably makes most sense to define something that
provides the functionality that you would want to see.  That's the most
effective way of making sure your requirements don't get ignored.
People may throw things at your proposal and its implied requirements
but they won't ignore it :-)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Phil Love
Sent: Friday, April 16, 2010 5:09 PM
To: [email-masked]
Subject: [nfsv4] Priority tagging

Thanks
Phil
_______________________________________________
nfsv4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nfsv4

---

From: Philip Love <[email-masked]>
Date: Mon, 19 Apr 2010 15:41:14 -0700

Here is one method for solving this problem. Please let me know your opionions.

One method for addressing the Head of Line Blocking is to introduce a priority tag for read request. A method for doing this could be to introduce a new operation that can set the relative priority for the current compound command that is being processed. This new operation introduces a method in which a client can inform the server of the relative priority between two commands. Note that these priorities are not global and that the NFS server is still required to impose its own fair use scheduling between the various clients.

If not specified then the default priority for the command is zero. Negative priorities are less important, and positive priorities are more important.

Operation A: SET_PRIORITY
 - Set relative priority for operations in the current compound command

ARGUMENTS

struct SET_PRIORITY4args {
	int32_t	priority;
};

RESULTS

struct SET_PRIORITY4res {
	nfsstat4	status;
};

---

From: Philip Love <[email-masked]>
Date: Mon, 19 Apr 2010 15:47:24 -0700

> One method for addressing the Head of Line Blocking is to introduce a priority tag for read request. 

Sorry typo: I meant 'each request'.