Subject: [nfsv4] Sharing same TCP connection for NFSv3 and NFSv4 traffic

From: "Erasani, Pranoop" <[email-masked]>
Date: Tue, 17 Aug 2010 20:33:42 -0700

Hello,

This distribution list is probably not the right one for this kind of
question. I figured I would get the best answer here.

Out of curiosity, Do any of the clients that you work on or that you
know of, share the same TCP connection for NFSv3 and NFSv4 traffic?

- Pranoop

---

From: Rick Macklem <[email-masked]>
Date: Wed, 18 Aug 2010 20:08:31 -0400 (EDT)

> know of, share the same TCP connection for NFSv3 and NFSv4 traffic?
Nope w.r.t the FreeBSD one, rick

---

From: Mitchell Erblich <[email-masked]>
Date: Wed, 18 Aug 2010 20:20:41 -0700

> Nope w.r.t the FreeBSD one, rick
I am not sure what "share the same TCP connection" means here.

If a client/HTTP  starts up a later connection to the same dest,
then some implementations have the later at least peak into
TCP info of the former to improve performance. It is specified
in a spec.

Whether some TCP structs have more than a single reference
count in an implementation should not be relevent.

Mitchell Erblich

> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4