Subject: [nfsv4] Discussion topics for the coming Bake-A-Thon

From: "Sorin Faibish" <[email-masked]>
Date: Fri, 17 Sep 2010 20:33:38 -0400

All,

I am trying to build an agenda for discussions during the coming  
Bake-A-Thon
at EMC October 4-8. I collected the last week several topics of interest  
and
I want to ask you all to add any other topics of interest so I can close  
the
agenda of the event. This is the list so far:

1. Layoutcommit for file layout (Dave Noveck)
2. Server side copy - (James)
3. Sparse files and storage preferences (Dean, Sorin)
4. Secure NFS (David Quigly)
5. Extend cthon tests with callback operations tests (Peter Honeyman)
6. Performance tests - tools and benchmarks (Peter Honeyman)
7. Utils and fedora rpm (Sorin, SteveD)
8. pNFS with IPv6 (Sorin)
9. Linux FedFS imlementation (Chuck)

I will allocate 30min for each topic and group them in 2 hours sessions
mostly in the early PM after lunch.

Please feel free to add any additional topics and thank you for your  
patience.

/Sorin

-- 
Best Regards
Sorin Faibish
Corporate Distinguished Engineer
Unified Storage Division

        EMC²
where information lives

Phone: 508-435-1000 x 48545
Cellphone: 617-510-0422
Email : [email-masked]

---

From: "Sorin Faibish" <[email-masked]>
Date: Sun, 19 Sep 2010 10:49:59 -0400

On Sun, 19 Sep 2010 10:12:32 -0400, Boaz Harrosh <[email-masked]>  
wrote:

> On 09/18/2010 02:33 AM, Sorin Faibish wrote:
>> All,
>>
>      And local/remote truncate torture tests.
Sure. Do we need a separate discussion or only this?

> to 6 or 5. Cluster tests. .i.e use of more then one client in  
> concertration
> to confuse and crash a server.
This aside from cthon, just for performance qaulification for the git.
Same do we need an additional spot or this is enough (30 min).

I will update the agenda with your comments and I assume you will be
part of the discussion, even drive it.

/Sorin

> Thanks
> Boaz
> To unsubscribe from this list: send the line "unsubscribe linux-nfs" in
> the body of a message to [email-masked]
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
>
>

        EMC²
where information lives

---

From: Thomas Haynes <[email-masked]>
Date: Mon, 20 Sep 2010 11:19:30 -0500

On Sep 19, 2010, at 9:49 AM, Sorin Faibish wrote:

> On Sun, 19 Sep 2010 10:12:32 -0400, Boaz Harrosh <[email-masked]> wrote:
> 
>> to 6 or 5. Cluster tests. .i.e use of more then one client in concertration

One subject I would like to see us address as a community is where we go
with respect to our general testing strategy. We have had discussions the
last several years at the Connectathons about the ability to contribute to the
cthon test suites and the legal status of the code.

Basically, because of the lack of understanding of the licensing, I believe
companies are not contributing changes back into the shared code base.

We can talk about what it would take to get the license straightened out,
but it might be more expedient to acknowledge that the cthon test suite is
a low bar and drive the creation of a new test suite.

---

From: <[email-masked]>
Date: Mon, 20 Sep 2010 15:47:50 -0400

I think this is an excellent suggestion.  Regardless of the way we
decide to go on this, I think it is important that we do something.

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Thomas Haynes
Sent: Monday, September 20, 2010 12:20 PM
To: faibish, sorin
Cc: [email-masked]; Peter Honeyman; [email-masked]; Boaz
Harrosh
Subject: Re: [nfsv4] Discussion topics for the coming Bake-A-Thon

	On Sun, 19 Sep 2010 10:12:32 -0400, Boaz Harrosh
<[email-masked]> wrote:

			5. Extend cthon tests with callback operations
tests (Peter Honeyman)

			6. Performance tests - tools and benchmarks
(Peter Honeyman)

		to 6 or 5. Cluster tests. .i.e use of more then one
client in concertration

	This aside from cthon, just for performance qaulification for
the git.
	Same do we need an additional spot or this is enough (30 min).
	
	I will update the agenda with your comments and I assume you
will be
	part of the discussion, even drive it.
	
	/Sorin

One subject I would like to see us address as a community is where we go
with respect to our general testing strategy. We have had discussions
the
last several years at the Connectathons about the ability to contribute
to the
cthon test suites and the legal status of the code.

Basically, because of the lack of understanding of the licensing, I
believe
companies are not contributing changes back into the shared code base.

We can talk about what it would take to get the license straightened
out,
but it might be more expedient to acknowledge that the cthon test suite
is
a low bar and drive the creation of a new test suite.