Subject: [nfsv4] [FedFS] Meeting Minutes, 9/16/2010

From: James Lentini <[email-masked]>
Date: Thu, 16 Sep 2010 14:45:51 -0400 (EDT)

FedFS Meeting Minutes, 9/16/2010
--------------------------------

Attendees
---------

Craig Everhart (NetApp)
Sorin Faibish (EMC)
James Lentini (NetApp)
Chuck Lever (Oracle)
Trond Myklebust (NetApp)
Paul LeMahieu (EMC)
Spencer Shepler (Microsoft)

Minutes
-------

+ IETF Note Well Agreement

  This is a reminder that our discussions are governed by the 
  IETF Note Well Agreement. See:

    http://www.ietf.org/NOTEWELL.html

  We will start each week's meeting with this announcement.

+ draft-ietf-nfsv4-federated-fs-protocol-09 published

  Please read through and consider if this is ready for last call.

+ October Bake-a-thon Planning

  Chuck asked if anyone was planning to setup a DNS server with an
  NFS SRV record from draft-ietf-nfsv4-federated-fs-dns-srv-namespace? 

  Nobody had plans to set one up, but we agreed that it would be 
  interesting if there were NFS client implementations to test.

  To test the NFS SRV record, would a special root NFS server be 
  necessary? Trond and Craig explained that a special server would 
  not be necessary, assuming the NFS client is interpreting the 
  DNS SRV record. The NFS server could be an ordinary fileserver 
  or one that supports junctions. Either would work for testing 
  the NFS SRV record.

  Trond suggested a competition: whoever gets their fileserver up 
  first gets to be root.

  We'll coordinate with Sorin to configure a DNS server with an 
  SRV record.

  Sorin reported that common bake-a-thon machines are being setup
  this week. He can setup a DNS server and could add an NFS SRV 
  record to it.

  Sorin has reserved a room for 30 minute discussions at the 
  bake-a-thon. The room will have an overhead projector, 
  whiteboards, and a phone for voice conferences.

  Sorin will be sending out an agenda with the talk schedule.

  Chuck requested a session on the Linux FedFS session.
  Sorin said that he would add this session to the list.

  Sorin has installed the pre-release Fedora 14 with development 
  packages on the common machines.

+ Admin Draft Update

  James reported that he had begun updating the Admin draft.

  We walked through what has been completed so far, see:

  http://jlentini.users.sourceforge.net/draft-ietf-nfsv4-federated-fs-admin-06.txt
  http://jlentini.users.sourceforge.net/draft-ietf-nfsv4-federated-fs-admin-rfcdiff.html

  The list of completed items is:
	- Each procedure now lists the errors it is allowed to return

	  This uncovered two issues:

		- In 5.2.1, the description of FEDFS_DELETE_JUNCTION
		  indicated that if the targeted object was not a 
		  junction, the error would be FEDFS_ERR_INVAL. In 
		  similar situations in other parts of the specification, 
		  the error is FEDFS_ERR_NOTJUNCT. The FEDFS_DELETE_JUNCTION
		  specification was corrected to be FEDFS_ERR_NOTJUNCT.

		- The NOTEMPTY and NOTDIR error codes are no longer in 
		  use (text that referred to them was removed from 
		  FEDFS_CREATE_JUNCTION in the previous revision). We agreed
		  to remove these unused error codes.

 	- An error code (FEDFS_ERR_NSDB_REFERRAL) and text (5.3.1) was added 
	  for LDAP referrals.

	- Type names used by both the JUNCTION and REPLICATION functions were 
	  renamed for consistency (see CreateJunctionArgs, FedFsLookupArgs, 
	  and FedFsLookupRes).

  The list of remaining items is:
	- Add a FEDFS_ERR_DELAY error value
	- Add additional error codes for LDAP referrals
	- Add cache lookup error codes discussed last week
	- Evaluate if RPC FSL structure should contain additional fields (e.g. TTL) 
	  from the LDAP fedfsFsl object

  Expect a completed update before our next meeting.

+ Meeting Schedule

  Our next meeting will be on September 30.

---

From: sfaibish <[email-masked]>
Date: Fri, 17 Sep 2010 08:20:02 -0400

> FedFS Meeting Minutes, 9/16/2010
My action item was to send the list of disscusion topics for meetings
during the BAT:

1. Layoutcommit for file layout (Dave Noveck)
2. Server side copy - (James)
3. Sparse files and storage preferences (Dean, Sorin)
4. Secure NFS (David Quigly)
5. Extend cthon tests with callback operations tests (Peter Honeyman)
6. Performance tests - tools and benchmarks (Peter Honeyman)
7. Utils and fedora rpm (Sorin, SteveD)
8. pNFS with IPv6 (Sorin)
9. Unix FedFS imlementation (Craig)

I included in brackets the request source. My intention is to allow 30 min  
per
item and group them in 2 hour sessions early AM after lunch each day.

Please let me know if there are other topics of interest.

> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>
>

-- 
Best Regards

Sorin Faibish
Corporate Distinguished Engineer
Unified Storage Division
         EMC²
where information lives

Phone: 508-249-5745
Cellphone: 617-510-0422
Email : [email-masked]

---

From: James Lentini <[email-masked]>
Date: Fri, 17 Sep 2010 09:32:22 -0400 (EDT)

On Fri, 17 Sep 2010, sfaibish wrote:

> On Thu, 16 Sep 2010 14:45:51 -0400, James Lentini <[email-masked]> wrote:
> 
> > 
<snip>
> 9. Unix FedFS imlementation (Craig)

Thanks Sorin. For #9, the speaker on the phone yesterday was Chuck 
Lever and his topic was "Linux FedFS implementation".

> 
> I included in brackets the request source. My intention is to allow 
> 30 min per item and group them in 2 hour sessions early AM after 
> lunch each day.
>

---

From: sfaibish <[email-masked]>
Date: Fri, 17 Sep 2010 10:18:21 -0400

>> 8. pNFS with IPv6 (Sorin)
Correction
8. pNFS and IPv6 (Chuck)

> Lever and his topic was "Linux FedFS implementation".
I am sorry, yes it was Chuck. Thanks for noticing James.

/Sorin

-- 
Best Regards

Sorin Faibish

Phone: 508-249-5745
Cellphone: 617-510-0422
Email : [email-masked]

---

From: sfaibish <[email-masked]>
Date: Fri, 17 Sep 2010 10:20:43 -0400

Last update:
1. Layoutcommit for file layout (Dave Noveck)
2. Server side copy - (James)
3. Sparse files and storage preferences (Dean, Sorin)
4. Secure NFS (David Quigly)
5. Extend cthon tests with callback operations tests (Peter Honeyman)
6. Performance tests - tools and benchmarks (Peter Honeyman)
7. Utils and fedora rpm (Sorin, SteveD)
8. pNFS with IPv6 (Chuck)
9. Linux FedFS imlementation (Chuck)

Sorry for the confusion and 3 emails. :(

/Sorin

-- 
Best Regards

Sorin Faibish

Phone: 508-249-5745
Cellphone: 617-510-0422
Email : [email-masked]

---

From: Robert Thurlow <[email-masked]>
Date: Mon, 20 Sep 2010 08:58:02 -0600

> FedFS Meeting Minutes, 9/16/2010

Hi folks,

Apologies for missing the meeting, I had to take my wife to
the doctor.  I am also going to miss the BAT, but we will
have the Solaris FedFS prototype code there for testing.
The bits we had last time are updated to draft-05 of the
admin spec and draft-09 of the NSDB spec.

>   We'll coordinate with Sorin to configure a DNS server with an 

I appear to have some modifications to the Solaris automounter
which work to do the DNS query and mount a FedFS namespace root.
They will be part of what we bring to the BAT.  I can send along
a sample DNS server setup, as well.

>  	- An error code (FEDFS_ERR_NSDB_REFERRAL) and text (5.3.1) was added 

Should this not be FEDFS_ERR_LDAP_REFERRAL?

Rob T

---

From: <[email-masked]>
Date: Mon, 20 Sep 2010 15:22:24 -0400

I think I'll be giving a brief presentation on the courtesy lock issue as it relates to RFC3530bis.  My expectation is that it can be done, as a few minutes at the end of LAYOUTCOMMIT discussion.  I don't think we'll need a separate time slot. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of sfaibish
Sent: Friday, September 17, 2010 10:21 AM
To: James Lentini
Cc: [email-masked]
Subject: Re: [nfsv4] [FedFS] Meeting Minutes, 9/16/2010

Last update:

/Sorin

-- 
Best Regards

Sorin Faibish

Phone: 508-249-5745
Cellphone: 617-510-0422
Email : [email-masked]

---

From: sfaibish <[email-masked]>
Date: Mon, 20 Sep 2010 18:46:15 -0400

Updated list with inputs of Boaz, Dave and Tom.

1. Layoutcommit for file layout (Dave Noveck)
2. Server side copy - (James)
3. Sparse files and storage preferences (Dean, Sorin)
4. Secure NFS (David Quigly)
5. Extend cthon tests with callback operations tests (Peter Honeyman)
    Add local/remote truncate torture tests (Boaz)
6. Performance tests - tools and benchmarks (Peter Honeyman)
    Cluster tests using more then one client in concertration (Boaz)
7. Utils and fedora rpm (Sorin, SteveD)
8. pNFS with IPv6 (Chuck)
9. Linux FedFS imlementation (Chuck)
10. Brief discussion on the courtesy lock issue as it relates to  
RFC3530bis (Dave Noveck)
11. Discussion on our general testing strategy and creation of a new test  
suite (Tom)

-- 
Best Regards

Sorin Faibish

Phone: 508-249-5745
Cellphone: 617-510-0422
Email : [email-masked]

---

From: James Lentini <[email-masked]>
Date: Tue, 21 Sep 2010 10:41:24 -0400 (EDT)

On Mon, 20 Sep 2010, Robert Thurlow wrote:

> > necessary? Trond and Craig explained that a special server would   not be
> > necessary, assuming the NFS client is interpreting the   DNS SRV record. The
> > NFS server could be an ordinary fileserver   or one that supports junctions.
> > Either would work for testing   the NFS SRV record.
> > 
> >   Trond suggested a competition: whoever gets their fileserver up   first
> > gets to be root.
> > 
> >   We'll coordinate with Sorin to configure a DNS server with an   SRV
> > record.
> 

I think that would be great.
 
> Should this not be FEDFS_ERR_LDAP_REFERRAL?

The other LDAP related error values use a prefix of "FEDFS_ERR_NSDB_": 
FEDFS_ERR_NSDB_LDAP and FEDFS_ERR_NSDB_LDAP_VAL. 
FEDFS_ERR_NSDB_REFERRAL seemed to fit in that naming scheme. I think 
FEDFS_ERR_NSDB_LDAP_REFERRAL would also make sense.

Does naming this error FEDFS_ERR_NSDB_LDAP_REFERRAL sound better or 
worse?

-james

---

From: Robert Thurlow <[email-masked]>
Date: Tue, 21 Sep 2010 08:44:15 -0600

> Does naming this error FEDFS_ERR_NSDB_LDAP_REFERRAL sound better or 

Better to me - I could see someone thinking of NFS referrals
without the "LDAP" in the error code.

Rob T

---

From: James Lentini <[email-masked]>
Date: Tue, 21 Sep 2010 11:34:01 -0400 (EDT)

On Tue, 21 Sep 2010, Robert Thurlow wrote:

> > FEDFS_ERR_NSDB_LDAP and FEDFS_ERR_NSDB_LDAP_VAL. FEDFS_ERR_NSDB_REFERRAL
> > seemed to fit in that naming scheme. I think FEDFS_ERR_NSDB_LDAP_REFERRAL
> > would also make sense.
> > 
> > Does naming this error FEDFS_ERR_NSDB_LDAP_REFERRAL sound better or worse?
> 
> Better to me - I could see someone thinking of NFS referrals without 
> the "LDAP" in the error code.

Good point. Unless there are objections, I'll change the name to 
FEDFS_ERR_NSDB_LDAP_REFERRAL.