Subject: [nfsv4] [FedFS] meeting agenda (9/30)

From: James Lentini <[email-masked]>
Date: Wed, 29 Sep 2010 17:40:50 -0400 (EDT)

Tomorrow's proposed agenda is below. Please let me know if you would
like to add additional topics.

    Time: Thursdays 1:30-2:30 PM EST/10:30-11:30 AM PST
 Dial-in: 1-888-765-3653 (us)
          303-218-2659 (international)
      Id: 2354843

Proposed Agenda
---------------

+ IETF Note Well Agreement

  This is a reminder that our discussions are governed by the 
  IETF Note Well Agreement. See:

    http://www.ietf.org/NOTEWELL.html

  We will start each week's meeting with this announcement.

+ October Bake-a-thon Planning

+ FEDFS_*_REPLICATION

  Is it clear from the description of these procedures that they 
  set the FSN for a present fileset, but don't manage a replication
  relationship between fileservers.

  If FEDFS_CREATE_REPLICATION is called on a fileset that already 
  has a FSN value, should the procedure fail (like FEDFS_JUNCTION
  create) or succeed (a SET/UNSET/GET model)?

+ Admin Draft Update

  Draft -06 was posted on 9/29 with the following changes:

 - Each procedure now lists the errors it is allowed to return

 - In 5.2.1, the description of FEDFS_DELETE_JUNCTION
   indicated that if the targeted object was not a 
   junction, the error would be FEDFS_ERR_INVAL. In 
   similar situations in other parts of the specification, 
   the error is FEDFS_ERR_NOTJUNCT. The FEDFS_DELETE_JUNCTION
   description was corrected to use the FEDFS_ERR_NOTJUNCT 
   error.

 - The NOTEMPTY and NOTDIR error codes were removed since 
   they were no longer in use (text that referred to them 
   was removed from FEDFS_CREATE_JUNCTION in the previous revision).  

 - Error codes (FEDFS_ERR_NSDB_REFERRAL, ...) and text (5.3.2) was 
   added for LDAP referrals.

 - Type names used by both the JUNCTION and REPLICATION functions were 
   renamed for consistency (see CreateJunctionArgs, FedFsLookupArgs, 
   and FedFsLookupRes).

 - Added a FEDFS_ERR_DELAY and FEDFS_ERR_NOTSUPP error values

 - Added cache lookup error codes (FEDFS_ERR_NO_CACHE, 
   FEDFS_ERR_UNKOWN_CACHE, and FEDFS_ERR_NO_CACHE_UPDATE)

 - Added a synopsis for each procedure

 - Added a description of the FEDFS_NULL procedure (5.1)

---

From: sfaibish <[email-masked]>
Date: Thu, 30 Sep 2010 13:55:14 -0400

My contact details including cellphone number are in the my signature
information included: 617-510-0422

/Sorin

-- 
Best Regards

Sorin Faibish
Corporate Distinguished Engineer
Unified Storage Division
         EMC²
where information lives

Phone: 508-249-5745
Cellphone: 617-510-0422
Email : [email-masked]

On Wed, 29 Sep 2010 17:40:50 -0400, James Lentini <[email-masked]>  
wrote:

> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>
>

-- 
Best Regards

Sorin Faibish
Corporate Distinguished Engineer
Unified Storage Division
         EMC²
where information lives

Phone: 508-249-5745
Cellphone: 617-510-0422
Email : [email-masked]