Subject: [nfsv4] NFSv4.2 I-D as a working group document

From: Spencer Shepler <[email-masked]>
Date: Mon, 27 Sep 2010 22:28:36 +0000

In case you missed it, Mike submitted the NFSv4.2 requirements 
I-D as a WG doc (thanks Mike).  
Look for draft-ietf-nfsv4-minorversion-2-requirements-00, 
the content will appear familiar.

I would like to provide some guidance related to this document and
with respect to "4.2" in general.

This NFSv4.2 requirements documents was a capture of a point
in time of WG discussion -- treat it as such.   Please do not read
this document as the only list allowed/committed/considered for 4.2.
The WG should not solely focus on the update of this document
as a means to define NFSv4.2.  It is useful to have the ideas
captured in an I-D so that it can be used as a means to communicate
WG discussion/thinking.  However, the WG has yet to build consensus 
about how to manage content for NFSv4.2. For example, is it a 
monolithic release (pre-defined set of features) or is it self-defined 
by the set of most interesting features that are well-defined and are
receiving reasonable focus and activity.

Thus, I would suggest that features be defined individually 
in a way that they can be considered in of themselves.  This 
has the obvious advantages of maximizing parallel effort and 
feature selectability for NFSv4.2.

Spencer

---

From: <[email-masked]>
Date: Tue, 28 Sep 2010 11:35:02 -0400

Thanks, Mike.

Thanks, Spencer.

I have a few comments about:

> Please do not read this document as the only list 
> allowed/committed/considered for 4.2. 

In the interests of clarity, let's treat each of those participles
separately.  Also, let's distinguish "a list of items X" from "the
(only) list of items X".  If six ain't enough, let's modalize by adding
"should be considered".  Although other modal combinations are possible,
I don't think they are relevant (and I'm already trying people's
patience :-)

The list below is my understanding and if Mike or Spencer or anyone
think differently, I think we are better off to get that resolved sooner
rather than later (e.g. by Beijing).

aALL) MV2R is not a list of item allowed for MV2.  
      There is no such list.

tALL) It follows that MV2R is not the only list of
      items allowed for MV2.  It seems like there is
      no good reason to have such a list.  If there 
      are things not allowed in MV2, we should have
      that list somewhere.

aCOM) MV2R is not is not a list of items committed
      for MV2.  There is no such list.

tCOM) It follows that MV2R is not the only list of
      items committed for MV2.  I think we need a list 
      of items expected for MV2 to help people understand
      where things are.  Things can be added if we feel
      that they are in good shape and helpful or taken
      off and deferred if we see unexpected issues that
      cause the group to revisit the issue.

aCON) MV2R is a list of items considered for MV2.

tCON) MV2R is not the only such list.  There does not
      seem a reason to have a global unified list of
      the sort.

aSCON) MV2R is a list of items that should be considered 
       for MV2.

tSCON) MV2R is not the only such list.  I think it does
       make sense to have a global unified list but it
       should be for items to be considered for future
       minor versions.  To be clear here, omission from
       the list does not an item should not be considered.
       Things could be added.  It is just that if something
       is on the list, it should be considered.  Things
       could also be taken off by the group.

So I guess I am saying, we need 

   an MVR document, presumably based on Mike's to fill 
   the tSCON role for all minor versions.

   A tCOM document for MV2, based in part on Mike's document,
   listing/explaining items currently expected to be in MV2.
   If there are items not allowed, those should be mentioned.
   This document would be a way of managing the MV2 process 
   and making sure we knew where we were (or that if we didn't 
   know where we were, we would all share exactly the same 
   confusion :-).  Let's hear it for working group togetherness.

Other opinions?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Spencer Shepler
Sent: Monday, September 27, 2010 6:29 PM
To: [email-masked]
Subject: [nfsv4] NFSv4.2 I-D as a working group document

Spencer
_______________________________________________
nfsv4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nfsv4

---

From: Thomas Haynes <[email-masked]>
Date: Tue, 28 Sep 2010 11:01:42 -0500

On Sep 28, 2010, at 10:35 AM, <[email-masked]> <[email-masked]> wrote:

> separately.

If clarity was your goal, you lost me on the way. My head
just exploded from all of the acronyms you just added.

>  Also, let's distinguish "a list of items X" from "the

---

From: Spencer Shepler <[email-masked]>
Date: Tue, 28 Sep 2010 17:10:23 +0000

The list of items being considered for the next or future minor versions is the list of Internet drafts that have "nfsv4" in their name. Said differently, the working group's consensus will be determined by the list of working group drafts. 

A requirements document with a list of features at this point in nfsv4's life is a mistake. The requirements document has proven too restrictive for discussion and progress. It allows for the inclusion of ideas that are not sufficiently vetted or cooked and slows the development of other ideas that need to be addressed more urgently. 

The Internet Draft process is sufficient and necessary for the development of ideas and the commitment to them. Let's use it. 

I apologize for asking for a requirements document to begin with. I did not appreciate the impact it would have. 

Spencer

---

From: <[email-masked]>
Date: Tue, 28 Sep 2010 14:24:27 -0400

> just exploded from all of the acronyms you just added.

Sorry. 

Head explosion due to my post.  Now I'm worried.  We live in a litigious
culture, dude.

Maybe not seeing that possibility is negligent and "sorry" just won't do
it.  If the head explosion could be easily foreseen, we may be talking
about gross negligence, punitive damages, etc.  Yours could be only one
explosion among many.  Possible class action.  ("If your head exploded
due to an nfsv4 working group post, you may be able to collect.  Call
866-xxx-yyyy").  There could be a big lawyer's bill or I could start
frantically studying to be able to do this pro se.  It really has its
attractions.  I've been an author on RFC's but never on a cert petition
:-)

Let me try an acronym-free version despite the fact that any recurrence
of the head explosion might put us further into gross negligence
territory :-)

OBTW, do you have any documentation of this head explosion (including
such information as EEG data, ER doctor's observations, etc.), and can
you really be sure it was not prompted some other external stimulus.  Of
course the issue of a contemporaneous blood profile would certainly
arise as many medication may have a contributory effect in leading to a
head explosion.  Also, after a head explosion, ones memories of details,
are often not clear or unreliable,  as much research has shown :-)

OK.  I'll be serious.

What I was saying is that:

     We don't have a list of things that are allowed 
     in v4.2, nor should we.

     We don't have a list of things committed for v4.2,
     and there is no reason to create one.

     I think we should have a document that briefly cites
     and describes the items expected for inclusion in
     the next minor version (such as v4.2).  This would 
     not entail a commitment but it would be a vehicle by
     which people had some common understanding of what 
     was going on.  Don't underestimate the importance of
     that.

     I am OK with Spencer's definition of the set of drafts
     but I think the group also give some attention to a 
     working group draft that cites things that the group 
     believes need work, and have not yet reached this stage.
     I think this will help avoid parallel work that could 
     be done better together and serve as a focal point to
     identify issues that the group thinks need work.  Think
     of it as serving in the role of a minor version feature 
     dating service.  (no obscene jokes on the list, private
     email only).

---

From: "J. Bruce Fields" <[email-masked]>
Date: Wed, 29 Sep 2010 13:09:26 -0400

On Tue, Sep 28, 2010 at 02:24:27PM -0400, [email-masked] wrote:
> you really be sure it was not prompted some other external stimulus.

The fact that mine exploded at about the same point, despite Tom and I
being in different states, is suggestive.

There's a startled groundhog in the backyard that might be able to serve
as a witness in my case.

--b.

> Of

---

From: Spencer Shepler <[email-masked]>
Date: Wed, 29 Sep 2010 17:14:04 +0000

>      identify issues that the group thinks need work

I'll state the obvious that email serves this purpose
reasonably well and is much more time efficient that
I-D submissions.

The email alias can be a method to cover proposals and
technical issues and for some reason the WG has fallen
out of the behavior of using it for this purpose.

Spencer

---

From: <[email-masked]>
Date: Wed, 29 Sep 2010 14:22:44 -0400

There's only one answer here. 

While of course details cannot be discussed because of security
considerations, a little reflection would lead to the conclusion that
the ability to make someone's head explode remotely would be a powerful
weapon. 

I cannot speak authoritatively of course, but my speculation would be
that any plaintiffs raising claims that involved this technology would
face the possibility of a US government agency becoming involved,
whereupon the State Secrets Doctrine might well be invoked, which would
prevent the case from proceeding. 

Note that despite the Supreme Court's views on the Second Amendment, it
has been made clear that that amendment does not apply to all weapons.
I believe there is no record of any instance where colonial militias
used document transmission of any sort to make people's heads explode.

I think we may be trying the working group's patience.  See you at
Bakeathon.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of J. Bruce Fields
Sent: Wednesday, September 29, 2010 1:09 PM
To: Noveck, David
Cc: [email-masked]
Subject: Re: [nfsv4] NFSv4.2 I-D as a working group document

--b.