Subject: [nfsv4] question on bulk recall text

From: Fred Isaman <[email-masked]>
Date: Tue, 12 Oct 2010 12:19:18 -0400

The text for bulk recalls in 12.5.5.2.1.5 seems flawed:

   Once a CB_LAYOUTRECALL of LAYOUTRECALL4_ALL is sent, the server MUST
   NOT allow the client to use any layout stateid except for
   LAYOUTCOMMIT operations.  Once the client receives a CB_LAYOUTRECALL
   of LAYOUTRECALL4_ALL, it MUST NOT use any layout stateid except for
   LAYOUTCOMMIT operations.

(similarly for LAYOUTRECALL4_FSID)

My question: what stateid does the client use to send the required LAYOUTRETURN?

Fred

---

From: Trond Myklebust <[email-masked]>
Date: Tue, 12 Oct 2010 12:59:58 -0400

> My question: what stateid does the client use to send the required LAYOUTRETURN?

LAYOUTRETURN with a LAYOUTRETURN4_FSID or a LAYOUTRETURN4_ALL argument
doesn't take a stateid. 

Cheers
  Trond

---

From: Fred Isaman <[email-masked]>
Date: Tue, 12 Oct 2010 13:20:09 -0400

> LAYOUTRETURN with a LAYOUTRETURN4_FSID or a LAYOUTRETURN4_ALL argument

Ah.  I see.

Thanks.
Fred

---

From: Benny Halevy <[email-masked]>
Date: Tue, 12 Oct 2010 13:43:53 -0400

> LAYOUTRETURN with a LAYOUTRETURN4_FSID or a LAYOUTRETURN4_ALL argument

Right, but if the client wants to return individual layouts
in the process the question is still valid.
One reason to do that is to show progress while the client
is flushing its caches.

Benny

> 
> Cheers
>   Trond
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4

---

From: Trond Myklebust <[email-masked]>
Date: Tue, 12 Oct 2010 14:37:01 -0400

> One reason to do that is to show progress while the client

LAYOUTCOMMIT should suffice to show progress, whereas LAYOUTRETURN with
a LAYOUTRETURN4_FILE appears to be explicitly prohibited by the spec
(and not just in the text that Fred quotes).

Cheers
  Trond

---

From: "Mike Eisler" <[email-masked]>
Date: Wed, 13 Oct 2010 15:33:53 -0700

> (and not just in the text that Fred quotes).

Correct, no point in a bulk recall if you can't have a bulk return.

-- 
Mike Eisler, Senior Technical Director, NetApp, 719 599 9026,
http://blogs.netapp.com/eislers_nfs_blog/

---

From: "Halevy, Benny" <[email-masked]>
Date: Thu, 14 Oct 2010 09:21:27 -0400

> 
> 
> From: [email-masked] on behalf of Mike Eisler
> Sent: Thu 2010-10-14 00:33
> To: [email-masked]
> Subject: Re: [nfsv4] question on bulk recall text
> 
> >> is flushing its caches.d 

True, and the last layoutreturn in response to the layoutrecall callback must be one.
But can't the client send RETURN_FILE layoutreturns voluntareely in the meanwhile
using the layout stateid is has in hand?.
I may need to be reminded at the exact test in the spec the prohibits that as Trond said...
 
Benny