Subject: [nfsv4] Potential schedules for BakeAThons in 2011

From: Thomas Haynes <[email-masked]>
Date: Thu, 7 Oct 2010 14:06:24 -0400

We've discussed potential venues for having 2 BakeAThons in 2011.

The dates would be in the middle of June and the start of October.

There are two different proposals:

1) 

June: EMC, Paris, France
Oct: NetApp, Sunnyvale, CA

2)

June: CITI, Ann Arbor, MI
Oct: NetApp, Sunnyvale, CA

We are seeing increased demand to host the event in Europe and it should
be feasible to do so once every 2 years. Between 20 - 25% of our participants
are based on the other side of the Atlantic. We might also draw in additional
testers and we all know once an organization gets a taste of testing, they
tend to continue attending.

We need to reach consensus on the venues by the middle of February. That
will give the June host plenty of time to make arrangements.

---

From: Benny Halevy <[email-masked]>
Date: Thu, 07 Oct 2010 14:13:35 -0400

> We need to reach consensus on the venues by the middle of February. That

Would rough consesus work? ;-)

Benny

> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4

---

From: Thomas Haynes <[email-masked]>
Date: Thu, 7 Oct 2010 14:31:06 -0400

> Would rough consesus work? ;-)

As long as I am acknowledged to be the WG chair.

---

From: sfaibish <[email-masked]>
Date: Fri, 08 Oct 2010 07:58:06 -0400

> Oct: NetApp, Sunnyvale, CA
If Peter has no objections I support and vote for this option.

> tend to continue attending.
It is very true that for BAT the presence of the Europe is slim. At cthon
is more visible but for BAT I was surprised to the best of the attendence
 from accross the ocean. We need if not every 2 years but once at least to
have a BAT in Europe.

/Sorin

-- 
Best Regards

Sorin Faibish
Corporate Distinguished Engineer
Unified Storage Division
         EMC²
where information lives

Phone: 508-249-5745
Cellphone: 617-510-0422
Email : [email-masked]

---

From: "Mkrtchyan, Tigran" <[email-masked]>
Date: Sat, 9 Oct 2010 10:12:47 +0200

My offer is still valid.
In June we have better chances for a good weather in Hamburg.

Tigran.

-----Original Message-----
From: [email-masked] on behalf of Thomas Haynes
Sent: Thu 10/7/2010 20:06
To: [email-masked]
Subject: [nfsv4] Potential schedules for BakeAThons in 2011

1) 

June: EMC, Paris, France

2)

---

From: sfaibish <[email-masked]>
Date: Sat, 09 Oct 2010 12:51:38 -0400

I believe the email was about chosing one of the offered options not to ask
for additional options. In general in June the BAT is at CITI. Let's
keep it simple and just vote for the proposed options. Thanks

/Sorin

-- 
Best Regards

Sorin Faibish

Phone: 508-249-5745
Cellphone: 617-510-0422
Email : [email-masked]

---

From: Thomas Haynes <[email-masked]>
Date: Sun, 10 Oct 2010 11:43:13 -0500

> In June we have better chances for a good weather in Hamburg.

Tigran,

It is good to have another option and if we got on a two-year
schedule, then you would be on the schedule for 2013. :->

Thanks,
Tom

---

From: Rick Macklem <[email-masked]>
Date: Sun, 10 Oct 2010 15:14:57 -0400 (EDT)

> Oct: NetApp, Sunnyvale, CA
For purely selfish reasons I'll vote for #2, because I think I can
actually make it the CITI in June. But don't let this sway your
decision, since I might not have 4.1 stuff to test at that point,
anyhow.

Btw, I think the client and server in FreeBSD8.1 are fairly solid
for NFSv4.0 and anyone can download/install it for testing. If
you are interested in doing that and need assistance, feel free
to email me.

Have fun wherever you go, rick

---

From: Thomas Haynes <[email-masked]>
Date: Sun, 10 Oct 2010 14:31:04 -0500

Rick,

A purely valid input and thanks for letting us know of intent, even
at about 8 months out.

All votes count.

Tom

---

From: Steve Dickson <[email-masked]>
Date: Mon, 11 Oct 2010 09:17:36 -0400

> Oct: NetApp, Sunnyvale, CA
Having the it at CITI makes it much more feasible... IMHO..

>From a strictly Red Hat point of view, its much easier and 
affordable for us to send one person to CITI and have 
two people participating verses sending two people to Paris 
France, along with equipment...  

> tend to continue attending.
So are most of the 20 to 25% based out of Paris? If it was held in Paris,
what would be percentage of people travelling out of country? Meaning would 
only 75 to 80% would have to travelling out of country or would that 
percentage go up to 90 to 95%? If its the latter I see no reason
to move it... 

My two cents...

steved.

---

From: "Mike Eisler" <[email-masked]>
Date: Mon, 11 Oct 2010 07:06:14 -0700

I get that as a WG in an international standards body with customers and
employees spread across the world that having a testing event outside of
the USA would be good.

However, there are significant costs for doing so, especially if equipment
heavier than laptops is involved.

I suggest amortizing travel costs to align with an IETF meeting (most of
much are no longer in the USA).

http://www.ietf.org/meeting/upcoming.html does not show Paris as future
venue, though there are several European meetings planned with TBD as the
venue.

So unless Oracle wants to host a bake-a-thon in Prague next spring, I think
we are going to Ann Arbor and Sunnyvale next year.

-- 
Mike Eisler, Senior Technical Director, NetApp, 719 599 9026,
http://blogs.netapp.com/eislers_nfs_blog/

---

From: "J. Bruce Fields" <[email-masked]>
Date: Mon, 11 Oct 2010 11:26:29 -0400

> France, along with equipment...  

Understood.

> > We are seeing increased demand to host the event in Europe and it
> > should be feasible to do so once every 2 years. Between 20 - 25% of
> > our participants are based on the other side of the Atlantic. We
> > might also draw in additional testers and we all know once an
> > organization gets a taste of testing, they tend to continue
> > attending.
> So are most of the 20 to 25% based out of Paris? If it was held in
> Paris, what would be percentage of people travelling out of country?
> Meaning would only 75 to 80% would have to travelling out of country
> or would that percentage go up to 90 to 95%? If its the latter I see
> no reason to move it... 

Most of the countries in question are more compact than the US, and in
terms of time and money spent, I would have expected the important
distinction to be whether you're crossing the Atlantic or not.  (But
I'll admit I don't know the costs.)

I'd be in favor of an occasional bakeathon in Europe for the reasons Tom
gives, but think we need to take into account details such as the timing
and facilities available.

--b.

---

From: Thomas Haynes <[email-masked]>
Date: Mon, 11 Oct 2010 10:57:59 -0500

> venue, though there are several European meetings planned with TBD as the

I actually consulted that schedule in making the proposal for Europe. My thoughts
were a little different in that I wanted to avoid having two international events in the
same quarter for a company.

You will notice that IETF 81 is in Canada (Which I don't consider a significant
cost unless I try to use my cell phone.) and in July. So a June trip to Europe
meets my criteria.

Using your criteria, the first available slot that works would be IETF 87 in July
2013.

> we are going to Ann Arbor and Sunnyvale next year.

Oracle does have an office there, no clue as to the size nor appropriateness.

---

From: <[email-masked]>
Date: Mon, 11 Oct 2010 12:44:30 -0400

> I suggest amortizing travel costs to align with an IETF 
> meeting (most of much are no longer in the USA). 

> http://www.ietf.org/meeting/upcoming.html does not show 
> Paris as future venue, though there are several European 
> meetings planned with TBD as the venue.

I think Mike makes a good point about amortizing travel costs.

I believe that having the events in the exact same city is not required
to provide that amortization.  Paris and Prague are 550 miles apart.  I
haven't got into the details of flight costs but I'd expect we are not
talking major bucks here.

So if a Paris Bakeathon were scheduled for the same time as IETF80,
people who had major interest in the Bakeathon could go to Prague for
the one day on which the nfsv4 working group was held and most Bakeathon
testing activities could be suspended for that time.  People who wanted
to be more involved in general IETF activities could not attend
Bakeathon but I don't know of anyone who would find that troubling.  If
you are one, speak up.

Note that I don't know what the time constraints are on a Paris
Bakeathon and I am not offering any site.  I just want us to be able to
consider non-US sites, without waiting years for an IETF meeting to be
scheduled.  

I think amortization using two cities a one-hour flight apart is quite
reasonable.  Our respective financial departments are going to give us
trouble no matter what we schedule.  After all, it is their job :-).   

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Mike Eisler
Sent: Monday, October 11, 2010 10:06 AM
To: [email-masked]
Subject: Re: [nfsv4] Potential schedules for BakeAThons in 2011

However, there are significant costs for doing so, especially if
equipment
heavier than laptops is involved.

So unless Oracle wants to host a bake-a-thon in Prague next spring, I
think
we are going to Ann Arbor and Sunnyvale next year.

>> We are seeing increased demand to host the event in Europe and it
should
> So are most of the 20 to 25% based out of Paris? If it was held in
Paris,

---

From: Thomas Haynes <[email-masked]>
Date: Mon, 11 Oct 2010 11:58:02 -0500

> talking major bucks here.

The main problems with that proposal are that

1) ConnectAThon is traditionally in that time frame and,

2) honestly, even with the IETF meeting being in the US, more people
attend a BAT than an IETF meeting. I.e., I don't think the savings would
be that huge per company.

---

From: "Erasani, Pranoop" <[email-masked]>
Date: Mon, 11 Oct 2010 11:08:55 -0700

Honestly, that cannot be a factor against that proposal.
 
That may be tue today. Because, folks like me that don't have an active proposal to present/discuss think that it's not a good use of their time to attend IETF, especially if I have to be conscious of my day-to-day job. If you align bakeathon with it, then they might come or vice-versa.
 
I think we are swayed too much by the urge to hold it in europe. No one seems to have any data on how many additional folks would attend bakeathon, if that is held outside US. If there was some, please do share. Also, weigh it against how many US regulars would not be able to make it to the event.
 
Just to reiterate, my comment is not about "DONT ever hold it in europe".
 
On the face of it, on the personal front, I certainly would not be able to attend, if it is held in europe. If I have to combine the trip with something like IETF, then I could consider.
 
- Pranoop

________________________________

From: Haynes, Tom
Sent: Mon 10/11/2010 9:58 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [nfsv4] Potential schedules for BakeAThons in 2011

---

From: Benny Halevy <[email-masked]>
Date: Mon, 11 Oct 2010 15:38:45 -0400

It's sad you guys are thinking of the costs of travelling from
the U.S. to Europe as something so hard to afford, yet the
European folks are paying these kind of costs regularly, coming
from the other direction.

Bottom like, if no shipping of equipment is involved, is the difference
that big?

Benny

On 2010-10-11 14:08, Erasani, Pranoop wrote:
> ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
--
> *From:* Haynes, Tom
> *Sent:* Mon 10/11/2010 9:58 AM
> *To:* [email-masked]
> *Cc:* [email-masked]
> *Subject:* Re: [nfsv4] Potential schedules for BakeAThons in 2011
> 
>

---

From: Thomas Haynes <[email-masked]>
Date: Mon, 11 Oct 2010 16:09:28 -0500

> Bottom like, if no shipping of equipment is involved, is the difference

$800 -> $1000 per engineer on the airfare.

I suspect that food and lodging is equivalent, mainly because we
seem to have the event in expensive venues in the US.

---

From: David Rhodus <[email-masked]>
Date: Mon, 11 Oct 2010 17:17:41 -0400

so expect to spend $2,000 on this event.

---

From: "Mkrtchyan, Tigran" <[email-masked]>
Date: Mon, 11 Oct 2010 23:51:28 +0200

> talking major bucks here.

Paris at least 3x more expensive than Prauge!

---

From: Trond Myklebust <[email-masked]>
Date: Mon, 11 Oct 2010 18:09:52 -0400

> Paris at least 3x more expensive than Prauge!

Oh, come on. You get the option of choosing high speed rail! :-)

Trond

---

From: Thomas Haynes <[email-masked]>
Date: Mon, 11 Oct 2010 17:19:22 -0500

I've had some offline discussions and it appears that I may not have
been clear enough on the proposal for Paris. The question is whether
or not we believe enough people/companies will be present to have
an interesting mix of implementations in order to be effective in
testing? (And yes, the whole utility is not testing, but it is a close
enough yardstick.)

We typically have 3 people present at each BakeAThon from Europe
or Israel. We happened to have 4 this time.

We have 3 or 4 people outside of those who have been vocal in the
past about having the event in Paris. We even proposed that the
BAT that was held in Ann Arbor be held in Paris this year. That never
gained any real traction.

I count that there might have been 30 people testing in Boston - there
were more who showed up for talks or who were registered but did
not attend.

I think a normal attendance number is 20 people.

In the past, we have had just one BAT in a year because the worth
was low - it wasn't a matter of cost, but because we didn't have
enough to test. I actually thought we were going to only have one
BAT in 2010, but the Linux developers in particular wanted
the second event.

And we have certainly seen organizations manage cost by reducing
attendance.

So if organizations commit to sending some developers, but not all,
what is the minimal mass in both technologies and people we need
to be effective?

I don't know the answers, but I do not want to see a BAT fail because
there is not enough representation and then see a drop off in attendance
in the next event.

So why don't we gather some data:

1) Do you plan to attend the June 2011 BAT if it is in Paris?

2) Do you plan to attend the June 2011 BAT if it is at CITI?

3) If you said yes to both, which one do you think you would get
the most worth from?

4) Did you attend the June 2010 BAT at CITI?

I'm asking you to answer as an individual and not as a company. But
please remember you need to secure funding from your company.
I.e., don't say yes to Paris because you want to visit it, say yes if
you know you will most likely be present. Also, if normally two of
you from your company attend and you know that your management
will only support one going to Paris, please reflect that in your
responses.

If you don't feel comfortable replying to list, just send your reply to me.

---

From: Rick Macklem <[email-masked]>
Date: Mon, 11 Oct 2010 18:27:54 -0400 (EDT)

> 1) Do you plan to attend the June 2011 BAT if it is in Paris?
no
> 2) Do you plan to attend the June 2011 BAT if it is at CITI?
yes
> 4) Did you attend the June 2010 BAT at CITI?
no

---

From: Benny Halevy <[email-masked]>
Date: Mon, 11 Oct 2010 18:46:08 -0400

yes

yes

> 3) If you said yes to both, which one do you think you would get

assuming attendance will be similar, at least in number of
companies (not individuals necessarily) attending, I think
both will work well.

yes

Benny

---

From: "Sorin Faibish" <[email-masked]>
Date: Mon, 11 Oct 2010 19:17:54 -0400

> or Israel. We happened to have 4 this time.
5 including Daniel from EMC France.

> gained any real traction.
Just to be clear whoever organizes the event in Europe needs to have
enough budget to support it. It is not clear to me who will have the
budget in Prague or Hamburg? In Paris there is EMC that can have the  
budget.
This is why we thought of Paris in the first place as an alternative to  
Boston
in 2010. Due to the economy people voted for Boston. This is why we had it  
in
Boston.

> were more who showed up for talks or who were registered but did
38 excluding EMC.

/Sorin

        EMC²
where information lives

Phone: 508-435-1000 x 48545
Cellphone: 617-510-0422
Email : [email-masked]

---

From: "Erasani, Pranoop" <[email-masked]>
Date: Mon, 11 Oct 2010 16:53:45 -0700

> 1) Do you plan to attend the June 2011 BAT if it is in Paris?
 
No.

> 2) Do you plan to attend the June 2011 BAT if it is at CITI?
 
Yes. I'd say most likely. But other factors will be considered, once we come close to the date.

the most worth from?
 
N/A.

> 4) Did you attend the June 2010 BAT at CITI?
 
Yes.
 
- Pranoop

---

From: Thomas Haynes <[email-masked]>
Date: Mon, 11 Oct 2010 21:01:23 -0500

On Oct 11, 2010, at 6:17 PM, Sorin Faibish wrote:

> On Mon, 11 Oct 2010 18:19:22 -0400, Thomas Haynes <[email-masked]> wrote:
> 
>> 
> budget in Prague or Hamburg? In Paris there is EMC that can have the budget.
> This is why we thought of Paris in the first place as an alternative to Boston
> in 2010. Due to the economy people voted for Boston. This is why we had it in
> Boston.

You have a small sample size of attended BakeAThons. Breakfast, lunch, excursion to
a bar, t shirts, etc, are all niceties that we always do not have present.

The budget has to be power, meeting room, network bandwidth, and setup time.

The only one which might cost real money is network bandwidth. I.e., I have been to
several where that was the cost which hit the books.

---

From: sfaibish <[email-masked]>
Date: Mon, 11 Oct 2010 23:26:41 -0400

> a bar, t shirts, etc, are all niceties that we always do not have  
This was extra. I just refer to the costs associated with the testing.

> The budget has to be power, meeting room, network bandwidth, and setup  
This kind of expenses. I believe CITI budget for all these was $5K.

/Sorin

-- 
Best Regards

Sorin Faibish

Phone: 508-249-5745
Cellphone: 617-510-0422
Email : [email-masked]

---

From: "Sandeep Joshi" <[email-masked]>
Date: Tue, 12 Oct 2010 15:16:15 -0700

3) If you said yes to both, which one do you think you would get the
most worth from?
CITI.

Regards
Sandeep

---

From: Steve Dickson <[email-masked]>
Date: Thu, 14 Oct 2010 07:32:12 -0400

Sorry for the delayed response.....

> 1) Do you plan to attend the June 2011 BAT if it is in Paris?
We would try... but no guarantees... 

Yes.

> 3) If you said yes to both, which one do you think you would get
CITI

Yes.

steved.

---

From: sfaibish <[email-masked]>
Date: Thu, 14 Oct 2010 10:32:28 -0400

My late responses:

Paris.

/Sorin

-- 
Best Regards

Sorin Faibish

Phone: 508-249-5745
Cellphone: 617-510-0422
Email : [email-masked]

---

From: Tigran Mkrtchyan <[email-masked]>
Date: Fri, 15 Oct 2010 11:31:42 +0200

yes
yes
yes