Subject: Re: [nfsv4] Determining interrim meeting interest

From: "Haynes, Tom" <[email-masked]>
Date: Mon, 6 Dec 2010 10:50:17 -0800

On Nov 30, 2010, at 8:47 AM, "Benny Halevy" <[email-masked]> wrote:

> On 2010-11-29 20:10, Spencer Shepler wrote:
>> 
>> I have received two responses of interest to my initial query about
>> an interim meeting.  Seems a little sparse to hold an interim meeting.
>> 
>> Thus, please send me email if you are interested in attending.
>> 
>> My suggestion for a 1.5 day meeting are:
>> 
>>    Feb 13th - 14th.
>> 
>> This is the two days prior to the FAST '11 conference.
>> 
>> Other date suggestions are most certainly welcome.
>> 
>> Ideas for agenda items?  Let me know that as well.
> 
> I suggest discussing:
> * layout stateid issues raised recently on the mailing list

So I see that discussion being something that occurs at Connectathon and not this meeting. I.e., it is 4.1 errata and not something about 4.2.

I'd like to see us do the deep dives that we haven't been able to do at the regular meetings.

> * pnfs-obj errata

> Benny
> 
>> 
>> Spencer
>> 
>> 
>> 
>> _______________________________________________
>> nfsv4 mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/nfsv4
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4

---

From: Spencer Shepler <[email-masked]>
Date: Mon, 6 Dec 2010 18:54:24 +0000

> -----Original Message-----
> From: Haynes, Tom [mailto:[email-masked]]
> Sent: Monday, December 06, 2010 10:50 AM
> To: Benny Halevy
> Cc: Spencer Shepler; [email-masked]
> Subject: Re: [nfsv4] Determining interrim meeting interest
> 
> 
> 
> So I see that discussion being something that occurs at Connectathon and
> not this meeting. I.e., it is 4.1 errata and not something about 4.2.
> 

Uh, last time I checked, NFSv4.1 errata was part of the WG charter and
therefore a candidate for WG meetings if there is a desire to discuss
and close on the issues.

If there is consensus from those in attendance that this or other
topics are not on the list, that is fine, but it is certainly a
candidate for discussion.

Spencer

---

From: <[email-masked]>
Date: Mon, 6 Dec 2010 14:33:01 -0500

I agree with Spencer.  There is no reason to exclude these errata (or
possible errata) from the list.  The question is what is the proper
priority ordering of the list if we find out that there is more to
discuss than time.

It is troubling that we have these uncertainties that are creating
difficulties for implementation.  To me that makes the priority higher.

I can see Tom's concern that there is v4.2 stuff that does need to get
some progress made, despite the high priority for clearing up the pNFS
(and other such?) stuff.  Maybe the right thing to do is divide the
meeting between past (cleanup of RFC3530bis, v4.1 errata), and future,
50-50 or whatever makes sense and apply priorities within those two
classes.  We can have big fights about the ratio, even after we agree
that there is a ratio.

I think we need to make progress on both divisions (I'm calling them
Archaea and Eukarya :-).  I think the most important thing in making the
meeting productive is to have clear material written in advance laying
out the issues and alternatives.  There will be some measure of "you've
got it all wrong" at the meeting but that beats trying to synthesize a
set of issues in the meeting.  I'll volunteer to create a document plus
slide set for the pNFS possible-errata.  My promise is to have both in
people's hands one week before the meeting.  Please send me suggestions.
First dibs on the kingdom/phylum name Euryarchaeota :-) 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Spencer Shepler
Sent: Monday, December 06, 2010 1:54 PM
To: Haynes, Tom; Benny Halevy
Cc: [email-masked]
Subject: Re: [nfsv4] Determining interrim meeting interest

> I'd like to see us do the deep dives that we haven't been able to do
at
> the regular meetings.

Spencer

---

From: sfaibish <[email-masked]>
Date: Mon, 06 Dec 2010 15:10:25 -0500

I would suggest to have the continuation of the discussions at
the BAT as they were related to both errata's and new stuff. I
will put together the list of issues that we left unfinished
at BAT soon.

/Sorin

-- 
Best Regards

Sorin Faibish
Corporate Distinguished Engineer
Unified Storage Division
         EMC²
where information lives

Phone: 508-249-5745
Cellphone: 617-510-0422
Email : [email-masked]

---

From: Fred Isaman <[email-masked]>
Date: Mon, 6 Dec 2010 16:33:47 -0500

On Mon, Dec 6, 2010 at 2:33 PM,  <[email-masked]> wrote:
> I'll volunteer to create a document plus

Here are the issues I'm dealing with that immediately come to mind:

What does it mean if the server sends a bulk CB_LAYOUTRECALL with
iomode != ANY?  Should this even be allowed, given the strict "dump
all layoutstate" requirements of the bulk recalls.

How should the server respond to a LAYOUTGET with an open stateid when
it has already handed out a layoutstateid?  Should it consider this a
signal that the client has forgotten previous state, or should it
assume that this is one of several parallel LAYOUTGETs sent by the
client?
The former choice forces serialization of the LAYOUTGETs with open
stateids.  The second requires the forgetful client to remember the
layoutstateid when forgetting the layout, and raises the question of
why doesn't the client just always send an openstateid in LAYOUTGET?

Does the file layout ever *have* to send a LAYOUTCOMMIT.

If the server sends a CB_LAYOUTRECALL, what client responses
necessitate updating the clients layoutstateid seqid?  Clearly OK, but
isn't NOMATCHING also a "successful" response that should update the
clients view?  What about other errors, especially DELAY?

What happens when the client sends a close for a file with layouts
marked roc without sending the LAYOUTRETURN?  What serialization
requirements are there if this is considered an implicit LAYOUTRETURN?

Fred

---

From: "J. Bruce Fields" <[email-masked]>
Date: Wed, 8 Dec 2010 10:21:26 -0500

> This is the two days prior to the FAST '11 conference.

Sounds like connectathon is the 21st--25th?  So putting the meeting
between the two events (say, the 17th-18th or 18th-19) might simplify
things for people making combined trips.

--b.

---

From: Benny Halevy <[email-masked]>
Date: Thu, 09 Dec 2010 15:53:32 +0200

> things for people making combined trips.

+1 on this.
Is there problem with having IETF interim meetings *during* the
Connectathon?

Benny

---

From: sfaibish <[email-masked]>
Date: Thu, 09 Dec 2010 10:17:53 -0500

> things for people making combined trips.
I am with Bruce.

/Sorin

-- 
Best Regards

Sorin Faibish

Phone: 508-249-5745
Cellphone: 617-510-0422
Email : [email-masked]

---

From: Thomas Haynes <[email-masked]>
Date: Thu, 9 Dec 2010 09:21:08 -0800

> Is there problem with having IETF interim meetings *during* the

With the same set of people, you either get testing done or IETF work done.

The Cthon has dropped down to 5 days instead of 10. I'd prefer to not
overlap.

---

From: "Spencer Shepler" <[email-masked]>
Date: Thu, 9 Dec 2010 09:44:00 -0800

So are there objections to having the interim meeting over
the weekend? (Feb 15-16)?  

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> sfaibish
> Sent: Thursday, December 09, 2010 7:18 AM
> To: J. Bruce Fields; Spencer Shepler
> Cc: [email-masked]

---

From: "Mike Eisler" <[email-masked]>
Date: Thu, 9 Dec 2010 09:54:54 -0800

A weekend is a non-starter.

On Thu, December 9, 2010 9:44 am, Spencer Shepler wrote:
>> Of

-- 
Mike Eisler, Senior Technical Director, NetApp, 719 599 9026,
http://blogs.netapp.com/eislers_nfs_blog/

---

From: Benny Halevy <[email-masked]>
Date: Thu, 09 Dec 2010 19:58:40 +0200

>> the weekend? (Feb 15-16)?

I assume you meant Feb 19-20 (15-16 weekend is in January)
Boaz and I will be around but I agree with Mike about preferring not
doing it on the weekend.

Benny

---

From: Spencer Shepler <[email-masked]>
Date: Thu, 9 Dec 2010 18:12:33 +0000

> A weekend is a non-starter.

Assuming:

2 day minimum for interim meeting
No overlap with FAST '11
No overlap with Connectathon '11
No weekend dates

Then the weeks of Feb 14 and Feb 21.

I had started down this path of dates close
to FAST and Connectathon to help minimize travel...

So, when do people want to meet?

If we are going to be on a separate week should
we plan on 2 or 3 days?

Spencer

---

From: Thomas Haynes <[email-masked]>
Date: Thu, 9 Dec 2010 10:21:27 -0800

> No overlap with Connectathon '11

In the past, FAST and Cthon overlapped.

It may be the case that a 1 day overlap is acceptable for people
who want to attend the interim meeting.

> So, when do people want to meet?

I'd like for Benny and Boaz to be able to meet with us.

---

From: Spencer Shepler <[email-masked]>
Date: Thu, 9 Dec 2010 18:26:26 +0000

> Thomas Haynes
> Sent: Thursday, December 09, 2010 10:21 AM
> To: Spencer Shepler
> Cc: [email-masked]
> It may be the case that a 1 day overlap is acceptable for people who want
> to attend the interim meeting.

Not for me.  Others can provide their opinion.

> > I had started down this path of dates close to FAST and Connectathon
> > to help minimize travel...
> >

I want to accommodate anyone who would like to attend.

The other requirements for dates are:

2 week notice before the meeting.
Meet 2 weeks prior to the next IETF meeting (March 11th last day)

Suggested dates would be appreciated.

Spencer

---

From: Dean <[email-masked]>
Date: Thu, 09 Dec 2010 11:19:05 -0800

> Not for me.  Others can provide their opinion.
The dates for FAST11 are actually a little confusing.  The original post 
regarding FAST11 stated it was Feb 15-18 (Tu-Fr), but the website now 
says Feb 15-17 (Tu-Th).  I think it must be 15-18, as every previous 
FAST conference ends on Friday.  I'll email Greg and John to find out.

Dean

---

From: Dean <[email-masked]>
Date: Thu, 09 Dec 2010 12:34:37 -0800

On 12/9/10 11:19 AM, Dean wrote:
> The dates for FAST11 are actually a little confusing.  The original 
> post regarding FAST11 stated it was Feb 15-18 (Tu-Fr), but the website 
> now says Feb 15-17 (Tu-Th).  I think it must be 15-18, as every 
> previous FAST conference ends on Friday.  I'll email Greg and John to 
> find out.
Garth informs me that in fact the conference will be crammed into 2 days 
on Feb 16-17, with the tutorials on the 15th. Thanks!

I'm not attending the Tutorials, so I could do Feb 14-15th if we need 2 
days, or if we can also cram it, we could do a single day on Feb 18th.

Dean

---

From: Thomas Haynes <[email-masked]>
Date: Thu, 9 Dec 2010 14:24:16 -0800

On Dec 9, 2010, at 12:34 PM, Dean wrote:

>> The dates for FAST11 are actually a little confusing.  The original post regarding FAST11 stated it was Feb 15-18 (Tu-Fr), but the website now says Feb 15-17 (Tu-Th).  I think it must be 15-18, as every previous FAST conference ends on Friday.  I'll email Greg and John to find out.
> Garth informs me that in fact the conference will be crammed into 2 days on Feb 16-17, with the tutorials on the 15th. Thanks!
> 
> I'm not attending the Tutorials, so I could do Feb 14-15th if we need 2 days, or if we can also cram it, we could do a single day on Feb 18th.
> 

I'd be willing to do the Saturday as well.

---

From: Spencer Shepler <[email-masked]>
Date: Thu, 9 Dec 2010 22:58:13 +0000

> Sent: Thursday, December 09, 2010 12:35 PM
> To: [email-masked]
> >>> It may be the case that a 1 day overlap is acceptable for people who
> >>> want to attend the interim meeting.

I have assumed that Feb 14th would be off limits.

Spencer

---

From: sfaibish <[email-masked]>
Date: Thu, 09 Dec 2010 18:40:18 -0500

On Thu, 09 Dec 2010 17:24:16 -0500, Thomas Haynes <[email-masked]>  
wrote:

>> Garth informs me that in fact the conference will be crammed into 2  
>> days on Feb 16-17, with the tutorials on the 15th. Thanks!
>>
Sorin too.

/Sorin

-- 
Best Regards

Sorin Faibish

Phone: 508-249-5745
Cellphone: 617-510-0422
Email : [email-masked]

---

From: Trond Myklebust <[email-masked]>
Date: Thu, 09 Dec 2010 21:13:25 -0500

> I have assumed that Feb 14th would be off limits.

We're all old and already married...

Trond

---

From: Trond Myklebust <[email-masked]>
Date: Thu, 09 Dec 2010 21:15:10 -0500

> We're all old and already married...

...and every day is just like Valentine's day (I'm under surveillance).

-- 
Trond Myklebust
Linux NFS client maintainer

NetApp
[email-masked]
www.netapp.com

---

From: Benny Halevy <[email-masked]>
Date: Fri, 10 Dec 2010 18:32:37 +0200

> days, or if we can also cram it, we could do a single day on Feb 18th.

Works for me too.

Benny

---

From: "William A. (Andy) Adamson" <[email-masked]>
Date: Fri, 10 Dec 2010 12:45:59 -0500

>> days, or if we can also cram it, we could do a single day on Feb 18th.

Feb 18 works for me

-->Andy