Subject: [nfsv4] RFC 1813 and MOUNT errors question

From: Thomas Haynes <[email-masked]>
Date: Tue, 11 Jan 2011 11:16:22 -0800

Page 107 describes the set of mount errors:

   enum mountstat3 {
      MNT3_OK = 0,                 /* no error */
      MNT3ERR_PERM = 1,            /* Not owner */
      MNT3ERR_NOENT = 2,           /* No such file or directory */
      MNT3ERR_IO = 5,              /* I/O error */
      MNT3ERR_ACCES = 13,          /* Permission denied */
      MNT3ERR_NOTDIR = 20,         /* Not a directory */
      MNT3ERR_INVAL = 22,          /* Invalid argument */
      MNT3ERR_NAMETOOLONG = 63,    /* Filename too long */
      MNT3ERR_NOTSUPP = 10004,     /* Operation not supported */
      MNT3ERR_SERVERFAULT = 10006  /* A failure on the server */
   };

And the only procedure which can return errors is MOUNTPROC3_MNT:

   ERRORS

      MNT3ERR_NOENT
      MNT3ERR_IO
      MNT3ERR_ACCES
      MNT3ERR_NOTDIR
      MNT3ERR_NAMETOOLONG
(page 109).

So where are the other errors used?

Brent's book avoids this by not describing the codes beforehand and states that
all error codes can be returned by MOUNTPROC3_MNT.

My guess is that Brent's book is more correct than 1813.

Anyone disagree?

---

From: Tigran Mkrtchyan <[email-masked]>
Date: Tue, 11 Jan 2011 20:54:41 +0100

Actually to me it looks like that spec have to be fixed as some operations
potentially may fail.

Some ops require  AUTH_UNIX authentication or better.
If it's not the case, probably MNT3ERR_ACCES is the right
reply.

Regards,
   Tigran.

On 01/11/2011 08:16 PM, Thomas Haynes wrote:
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>

---

From: Thomas Haynes <[email-masked]>
Date: Tue, 11 Jan 2011 12:27:53 -0800

Peter,

Thanks for the clarification - I know of several implementations which take the per operation
list of error codes to be gospel.

Tom

On Jan 11, 2011, at 12:15 PM, <[email-masked]> <[email-masked]> wrote:

> Hi Tom.
>  
> For RFC1813, the philosophy behind the lists of errors associated with any particular protocol operation, NFS, MOUNT, or NLM, is different than that behind the lists of errors listed in rfc3530bis or rfc5661.  The philosophy in RFC1813 was to list the common errors, but that each list was not definitive and that any error could be returned to any operation.  Clearly, for any particular operation, there would be some errors which would not be applicable.
>  
> However, in the interest of simplicity, I chose not to construct definitive and restricted lists of errors that could be returned for each specific operation.
>  
>                 Thanx…
>  
>                                 ps
>  
>  
>  
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Thomas Haynes
> Sent: Tuesday, January 11, 2011 2:16 PM
> To: [email-masked]
> Subject: [nfsv4] RFC 1813 and MOUNT errors question
>