Subject: [nfsv4] [NFSv4.2] Meeting Agenda for 5/4/11 (new conference number)

From: Thomas Haynes <[email-masked]>
Date: Tue, 3 May 2011 22:17:04 -0500

Thursday's proposed agenda is below. Please let me know if
you would like to add additional topics.

PLEASE NOTE: Both the phone numbers and the conference ID have been changed.

   Time: Thursdays 12:30-1:30 PM CST/1:30-2:30 PM EST/10:30-11:30 AM PST
Dial-in: 1-866-844-9418 (Toll Free)
       1-517-345-9208 (Caller paid)     
         353-1-506-0479 (Israel paid)
         1800-936-206 (Israel toll free)

     Id: 9744122017

Proposed Agenda
---------------

+ IETF Note Well Agreement

 This is a reminder that our discussions are governed by the 
 IETF Note Well Agreement. See:

   http://www.ietf.org/NOTEWELL.html

 We will start each week's meeting with this announcement.

+ Unstable file creation

Trond will lead this discussion.

+ LAYOUTCOMMIT deprecation of loca_offset and loca_length

David Black will lead this discussion.

+ Application Data Blocks (was patterns)

I will lead the discussion.

I will shortly send out a new section that covers the issues brought
up at the last meeting.

+ NFS4ERR_NOTSUPP and enums

In this message, http://www.ietf.org/mail-archive/web/nfsv4/current/msg09450.html
I presented a loophole that allows us to extend the arguments to an
operation in a new minor version. Since these extensions should be
optional, how do we differentiate between NFS4ERR_NOTSUPP
for the operation versus NFS4ERR_NOTSUPP for the specific enum?

---

From: <[email-masked]>
Date: Wed, 4 May 2011 09:35:17 -0400

> David Black will lead this discussion.

It's my turn to be unavailable for a Thursday call for personal reasons that I can't change :-(.

Based on list discussion, it's become apparent that these two arguments have no functional value - they're not used by pNFS file and object layouts, and the pNFS block layout would prefer to ignore them in favor or more specific layout-dependent information about what to commit.

There are two questions that need attention (IMHO):
- Should we revise the specification to recognize this?
      IMHO - Yes.
- Is this 4.1 errata or functional changes that belong in 4.2?
      IMHO - functional change for 4.2

Thanks,
--David

From: [email-masked] [mailto:[email-masked]] On Behalf Of Thomas Haynes
Sent: Tuesday, May 03, 2011 11:17 PM
To: [email-masked]
Subject: [nfsv4] [NFSv4.2] Meeting Agenda for 5/4/11 (new conference number)

     Id: 9744122017

Proposed Agenda
---------------

+ Unstable file creation