Subject: [nfsv4] NFSv4.2 + LNFS xdr file for BAT

From: Thomas Haynes <[email-masked]>
Date: Mon, 9 May 2011 15:41:30 -0500

Several people have mentioned that they might have prototype code available
for the BAT for both NFSv4.2 and LNFS features.

I'd like us to all be on the same page with respect to the XDR, so I temporally pulled
the LNFS XDR into the 4.2 XDR and published version 2 of the three documents. 

This will give us a common base for interoperability:
 1) the base 4.2 protocol
 2) the LNFS attribute support
 3) the LNFS CB, 
 4) error codes to help debug.

If you plan to bring a LNFS prototype, you will need all three documents. And
note that after the event, I will be pulling the LNFS stuff out of the XDR.

NOTE: The 4.2 document is really in a state of flux. I am busy fixing up the
ADB, Sparse, and Space chapters to be consistent.

WARNING: The XDR is slightly different from the previous versions in that I took
extra effort to make sure it would compile correctly. You can look at the 'make testx'
target if you want to validate things.

You can grab the XDR directly from http://datatracker.ietf.org/doc/draft-ietf-nfsv4-minorversion2-dot-x/
or grab it from github:

https://github.com/loghyr/NFSv4.2/blob/master/events/bat_06_2011/nfsv42.x

It would be better if you got it directly from the document and used the other
file for a sanity diff.

---

From: "Sorin Faibish" <[email-masked]>
Date: Mon, 09 May 2011 20:33:08 -0400

Will do.

/Sorin

On Mon, 09 May 2011 16:41:30 -0400, Thomas Haynes <[email-masked]>  
wrote:

> You can grab the XDR directly from  
> http://datatracker.ietf.org/doc/draft-ietf-nfsv4-minorversion2-dot-x/
> or grab it from github:
>
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>

-- 
Best Regards
Sorin Faibish
Corporate Distinguished Engineer
Unified Storage Division

        EMC²
where information lives

Phone: 508-435-1000 x 48545
Cellphone: 617-510-0422
Email : [email-masked]