Subject: [nfsv4] [PATCH] Clean up section describing NSDBs

From: Chuck Lever <[email-masked]>
Date: Thu, 16 Aug 2012 16:31:10 -0400

http://www.ietf.org/mail-archive/web/nfsv4/current/msg11233.html

During this discussion, James mentioned "proxied FSLs."  The text
he referred to describes something that the current NSDB architecture
appears not to support.

We could develop this concept further within the existing
architecture, or remove it from the current NSDB protocol in favor
of making it "future work."

Remove the mention for now to avoid inconsistent language.
Reorganize the NSDB section for clarity.
---

 nsdb-proto.xml |   27 ++++++++++++++-------------
 1 files changed, 14 insertions(+), 13 deletions(-)

diff --git a/nsdb-proto.xml b/nsdb-proto.xml
index eb570ba..465555d 100644
--- a/nsdb-proto.xml
+++ b/nsdb-proto.xml
@@ -415,25 +415,26 @@
         <t> The NSDB service is a federation-wide service that
         provides interfaces to define, update, and query FSN
         information, FSL information, and FSN to FSL mapping
-        information.  An individual repository of namespace
-        information is called an NSDB node.  Each NSDB node
-        is managed by a single administrative entity.  A single admin
-        entity can manage multiple NSDB nodes.  </t>
+        information.  </t>
 
-        <t> The difference between the NSDB service and an NSDB
-        node is analogous to that between the DNS service
-        and a particular DNS server.  </t>
+        <t> An individual repository of namespace information
+        is called an NSDB node.  The difference between the NSDB
+        service and an NSDB node is analogous to that between the
+        DNS service and a particular DNS server.  </t>
+
+        <t> Each NSDB node is managed by a single administrative
+        entity.  A single admininistrative entity can manage
+        multiple NSDB nodes.  </t>
 
         <t> Each NSDB node stores the definition of the FSNs
         for which it is authoritative.  It also stores the
         definitions of the FSLs associated with those FSNs.  An
         NSDB node is authoritative for the filesets that it
-        defines.  An NSDB node can cache information from a
-        peer NSDB node.  The fileserver can always contact a
-        local NSDB node (if it has been defined) or directly
-        contact any NSDB node to resolve a junction.  Each
-        NSDB node supports an LDAP <xref target="RFC4510"/>
-        interface and can be accessed by an LDAP client.  </t>
+        defines.  </t>
+
+        <t> Each NSDB node supports an LDAP <xref target="RFC4510"/>
+        interface.  The information stored on an NSDB node is
+        accessed and updated by LDAP clients.  </t>
 
         <t> An NSDB MAY be replicated throughout the federation.
         If an NSDB is replicated, the NSDB MUST exhibit loose,

---

From: "Haynes, Tom" <[email-masked]>
Date: Thu, 16 Aug 2012 21:11:10 +0000

Picked all of these up.